]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blob - apache-mod_gzip.spec
- unified
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
1 %define         mod_name        gzip
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: On-the-fly compression of HTML documents
4 Summary(pl):    Modu³ do apache: kompresuje dokumenty HTML w locie
5 Name:           apache-mod_%{mod_name}
6 Version:        2.0.40
7 Release:        0.1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://www.gknw.com/development/apache/httpd-2.0/unix/modules/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  30c17d999edb5d83368369cde1c921bb
12 Source1:        %{name}.conf
13 Source2:        %{name}.logrotate
14 #URL:           http://www.schroepl.net/projekte/mod_gzip/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0.40
17 BuildRequires:  zlib-devel
18 Requires(triggerpostun):        %{apxs}
19 Requires(triggerpostun):        grep
20 Requires(triggerpostun):        sed >= 4.0
21 Requires:       apache(modules-api) = %apache_modules_api
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26 %define         _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
27
28 %description
29 Apache module: On-the-fly compression of HTML documents. Browser will
30 transparently decompress and display such documents.
31
32 %description -l pl
33 Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±darki w
34 sposób przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
35
36 %prep
37 %setup -q -n mod_%{mod_name}
38
39 %build
40 %{apxs} -Wc,-Wall,-pipe -c mod_%{mod_name}.c mod_%{mod_name}_debug.c mod_%{mod_name}_compress.c -o mod_%{mod_name}.so
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,/etc/logrotate.d,%{_pkglogdir}}
45
46 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
48 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
49
50 > $RPM_BUILD_ROOT%{_pkglogdir}/mod_gzip.log
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59
60 %postun
61 if [ "$1" = "0" ]; then
62         if [ -f /var/lock/subsys/httpd ]; then
63                 /etc/rc.d/init.d/httpd restart 1>&2
64         fi
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc *.txt logos/*
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
71 %attr(755,root,root) %{_pkglibdir}/*.so
72 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
73 %attr(640,root,root) %ghost %{_pkglogdir}/*
This page took 0.062425 seconds and 4 git commands to generate.