]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blob - apache-mod_gzip.spec
- release 2
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
1 %define         mod_name        gzip
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: On-the-fly compression of HTML documents
4 Summary(pl):    Modu³ do apache: kompresuje dokumenty HTML w locie
5 Name:           apache-mod_%{mod_name}
6 Version:        1.3.19.1a
7 Release:        2
8 License:        Apache Software License
9 Group:          Networking/Daemons
10 Group(cs):      Sí»ové/Démoni
11 Group(da):      Netværks/Dæmoner
12 Group(de):      Netzwerkwesen/Server
13 Group(es):      Red/Servidores
14 Group(fr):      Réseau/Serveurs
15 Group(is):      Net/Púkar
16 Group(it):      Rete/Demoni
17 Group(no):      Nettverks/Daemoner
18 Group(pl):      Sieciowe/Serwery
19 Group(pt):      Rede/Servidores
20 Group(ru):      óÅÔØ/äÅÍÏÎÙ
21 Group(sl):      Omre¾ni/Stre¾niki
22 Group(sv):      Nätverk/Demoner
23 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
24 Source0:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/mod_%{mod_name}.c
25 Source1:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/changes.txt
26 Source2:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/commands.txt
27 Source3:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/samples.txt
28 BuildRequires:  %{apxs}
29 BuildRequires:  apache(EAPI)-devel
30 BuildRequires:  zlib-devel
31 Prereq:         %{_sbindir}/apxs
32 Requires:       apache(EAPI)
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
36
37 %description
38 Apache module: On-the-fly compression of HTML documents. Browser will
39 transparently decompress and display such documents.
40
41 %description -l pl
42 Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±darki w
43 sposób przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
44
45 %prep 
46 %setup -q -T -c
47 cp %{SOURCE0} .
48 cp %{SOURCE1} .
49 cp %{SOURCE2} .
50 cp %{SOURCE3} .
51
52 %build
53 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT%{_pkglibdir}
58
59 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
60
61 gzip -9nf *.txt
62
63 %post
64 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
65 if [ -f /var/lock/subsys/httpd ]; then
66         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
67 fi
68
69 %preun
70 if [ "$1" = "0" ]; then
71         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
72         if [ -f /var/lock/subsys/httpd ]; then
73                 /etc/rc.d/init.d/httpd restart 1>&2
74         fi
75 fi
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc *.gz
83 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.026938 seconds and 3 git commands to generate.