]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blob - apache-mod_gzip.spec
- Based on apache-mod_gunzip.spec.
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
1 %define         mod_name        gzip
2 Summary:        Apache module: On-the-fly compression of HTML documents
3 Summary(pl):    Modu³ do apache: kompresuje dokumenty HTML w locie
4 Name:           apache-mod_%{mod_name}
5 Version:        1.3.19.1a
6 Release:        1
7 License:        Apache Software License
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/mod_%{mod_name}.c
12 Source1:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/changes.txt
13 Source2:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/commands.txt
14 Source3:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/samples.txt
15 BuildRequires:  /usr/sbin/apxs
16 BuildRequires:  apache(EAPI)-devel
17 BuildRequires:  zlib-devel
18 Prereq:         /usr/sbin/apxs
19 Requires:       apache(EAPI)
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
23
24 %description
25 Apache module: On-the-fly compression of HTML documents. Browser will
26 transparently decompress and display such documents.
27
28 %description -l pl
29 Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±daki w sposób
30 przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
31
32 %prep 
33 %setup -q -T -c
34 cp %{SOURCE0} .
35 cp %{SOURCE1} .
36 cp %{SOURCE2} .
37 cp %{SOURCE3} .
38
39 %build
40 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_pkglibdir}
45
46 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47
48 gzip -9nf *.txt
49
50 %post
51 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52 if [ -f /var/lock/subsys/httpd ]; then
53         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
54 fi
55
56 %preun
57 if [ "$1" = "0" ]; then
58         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
59         if [ -f /var/lock/subsys/httpd ]; then
60                 /etc/rc.d/init.d/httpd restart 1>&2
61         fi
62 fi
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc *.gz
70 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.135295 seconds and 3 git commands to generate.