]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blob - apache-mod_gzip.spec
55e9de0da7e4c579e4a465a6d5526d5a4017715c
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
1 %define         mod_name        gzip
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: On-the-fly compression of HTML documents
4 Summary(pl):    Modu³ do apache: kompresuje dokumenty HTML w locie
5 Name:           apache-mod_%{mod_name}
6 Version:        1.3.19.1a
7 Release:        2
8 License:        Apache Software License
9 Group:          Networking/Daemons
10 Source0:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/mod_%{mod_name}.c
11 Source1:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/changes.txt
12 Source2:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/commands.txt
13 Source3:        http://www.remotecommunications.com/apache/mod_%{mod_name}/src/%{version}/samples.txt
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache(EAPI)-devel
16 BuildRequires:  zlib-devel
17 Prereq:         %{_sbindir}/apxs
18 Requires:       apache(EAPI)
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
22
23 %description
24 Apache module: On-the-fly compression of HTML documents. Browser will
25 transparently decompress and display such documents.
26
27 %description -l pl
28 Modu³ do apache: kompresuje dokumenty HTML w locie. Przegl±darki w
29 sposób przezroczysty dekompresuj± i wy¶wietlaj± takie dokumenty.
30
31 %prep 
32 %setup -q -T -c
33 cp %{SOURCE0} .
34 cp %{SOURCE1} .
35 cp %{SOURCE2} .
36 cp %{SOURCE3} .
37
38 %build
39 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_pkglibdir}
44
45 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
47 gzip -9nf *.txt
48
49 %post
50 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51 if [ -f /var/lock/subsys/httpd ]; then
52         %{_sysconfdir}/rc.d/init.d/httpd restart 1>&2
53 fi
54
55 %preun
56 if [ "$1" = "0" ]; then
57         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
58         if [ -f /var/lock/subsys/httpd ]; then
59                 /etc/rc.d/init.d/httpd restart 1>&2
60         fi
61 fi
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc *.gz
69 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.030805 seconds and 2 git commands to generate.