]> git.pld-linux.org Git - packages/apache-mod_gzip.git/blame_incremental - apache-mod_gzip.spec
- converted to UTF-8
[packages/apache-mod_gzip.git] / apache-mod_gzip.spec
... / ...
CommitLineData
1%define mod_name gzip
2%define apxs /usr/sbin/apxs
3Summary: Apache module: On-the-fly compression of HTML documents
4Summary(pl.UTF-8): Moduł do apache: kompresuje dokumenty HTML w locie
5Name: apache-mod_%{mod_name}
6Version: 2.0.40
7Release: 0.1
8License: Apache
9Group: Networking/Daemons
10Source0: http://www.gknw.net/development/apache/httpd-2.0/unix/modules/mod_%{mod_name}-%{version}.tar.gz
11# Source0-md5: 30c17d999edb5d83368369cde1c921bb
12Source1: %{name}.conf
13Source2: %{name}.logrotate
14URL: http://www.gknw.net/development/apache/
15BuildRequires: %{apxs}
16BuildRequires: apache-devel >= 2.0.40
17BuildRequires: rpmbuild(macros) >= 1.268
18BuildRequires: zlib-devel
19Requires: apache(modules-api) = %apache_modules_api
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24%define _pkglogdir %(%{apxs} -q PREFIX 2>/dev/null)/logs
25
26%description
27Apache module: On-the-fly compression of HTML documents. Browser will
28transparently decompress and display such documents.
29
30%description -l pl.UTF-8
31Moduł do apache: kompresuje dokumenty HTML w locie. Przeglądarki w
32sposób przezroczysty dekompresują i wyświetlają takie dokumenty.
33
34%prep
35%setup -q -n mod_%{mod_name}
36
37%build
38%{apxs} -Wc,-Wall,-pipe -c mod_%{mod_name}.c mod_%{mod_name}_debug.c mod_%{mod_name}_compress.c -o mod_%{mod_name}.so
39
40%install
41rm -rf $RPM_BUILD_ROOT
42install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf,/etc/logrotate.d,%{_pkglogdir}}
43
44install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
46install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
47
48> $RPM_BUILD_ROOT%{_pkglogdir}/mod_gzip.log
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54%service -q httpd restart
55
56%postun
57if [ "$1" = "0" ]; then
58 %service -q httpd restart
59fi
60
61%files
62%defattr(644,root,root,755)
63%doc *.txt logos/*
64%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
65%attr(755,root,root) %{_pkglibdir}/*.so
66%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
67%attr(640,root,root) %ghost %{_pkglogdir}/*
This page took 0.031116 seconds and 4 git commands to generate.