]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blobdiff - apache-mod_fastcgi.spec
- rel 2
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
index 3141f4832daccf01af43e8c93e85b972fe5bb5bb..4ecdbe1e524e961e39a66eda935ee36994761108 100644 (file)
@@ -1,14 +1,23 @@
+%define        apxs    /usr/sbin/apxs
+%define                _apache1        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 0 || echo 1)
 Summary:       Support for the FastCGI protocol for apache webserver
+Summary(pl):   Obs³uga protoko³u FastCGI dla serwera apache
+Summary(ru):   FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
+Summary(uk):   FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
 Name:          apache-mod_fastcgi
-Version:       2.2.10
+Version:       2.4.2
 Release:       2
-Copyright:     Open Market
+License:       distributable
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
-Source0:       http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
+Source0:       http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
+# Source0-md5: e994414304b535cb99e10b7d1cad1d1e
+Patch0:                %{name}-allow-uid-gid.patch
+Source1:       70_mod_fastcgi.conf
 URL:           http://www.FastCGI.com/
+BuildRequires: %{apxs}
 BuildRequires: apache-devel
+BuildRequires: libtool
+Requires(post,preun):  %{apxs}
 Requires:      apache >= 1.3.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -21,43 +30,78 @@ FastCGI is a language independent, scalable, open extension to CGI
 that provides high performance and persistence without the limitations
 of server specific APIs.
 
+%description -l pl
+To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
+niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
+du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
+
+%description -l ru
+FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
+×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
+ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
+
+óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
+
+%description -l uk
+FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
+×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
+ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
+
+û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
+
 %prep
-%setup -q -n mod_fastcgi_%{version}
+%setup -q -n mod_fastcgi-%{version}
+%patch0 -p1
 
 %build
-apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
+%if %{_apache1}
+%{apxs} -o mod_fastcgi.so -c *.c
+%else
+%{__make} -f Makefile.AP2 top_dir=%{_libexecdir} INCLUDES="-I%{_includedir}/apache"
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
 
+%if %{_apache1}
 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
+%else
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
+libtool --mode=install install mod_fastcgi.la $RPM_BUILD_ROOT%{_libexecdir}
+install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/
+%endif
 
 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
 
-gzip -9nf docs/LICENSE.TERMS CHANGES
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
+%if %{_apache1}
+%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%endif
 if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+        /etc/rc.d/init.d/httpd restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+        echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
 fi
-
 %preun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+%if %{_apache1}
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%endif
+        if [ -f /var/lock/subsys/httpd ]; then
+                /etc/rc.d/init.d/httpd restart 1>&2
+        fi
 fi
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
-%doc docs/*.gz *.gz
-%doc %{_htmldocdir}
-%attr(755,root,root) %{_libexecdir}/*
+%doc docs/LICENSE.TERMS CHANGES
+%doc %{_htmldocdir}/*
+%attr(755,root,root) %{_libexecdir}/*.so
+%if ! %{_apache1}
+%config %{_sysconfdir}/httpd/httpd.conf/*.conf
+%endif
This page took 0.404421 seconds and 4 git commands to generate.