]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blame - apache-mod_fastcgi.spec
- do not strip binaries (this perporms rpm in %install_post script),
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
CommitLineData
1bc96cf4
JR
1Summary: Support for the FastCGI protocol for apache webserver
2Name: apache-mod_fastcgi
717b2bd5 3Version: 2.2.10
4Release: 1
1bc96cf4
JR
5Copyright: Open Market
6Group: Networking/Daemons
7Group(de): Netzwerkwesen/Server
8Group(pl): Sieciowe/Serwery
1bc96cf4 9Source0: http://www.FastCGI.com/dist/mod_fastcgi_%{version}.tar.gz
75f63f77 10URL: http://www.FastCGI.com/
11BuildRequires: apache-devel
1bc96cf4
JR
12Requires: apache >= 1.3.1
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
1bc96cf4 14
65b7de09 15%define _libexecdir %{_libdir}/apache
16%define _htmldocdir /home/httpd/html/docs/%{name}_%{version}
17
1bc96cf4
JR
18%description
19This 3rd party module provides support for the FastCGI protocol.
20FastCGI is a language independent, scalable, open extension to CGI
21that provides high performance and persistence without the limitations
22of server specific APIs.
23
1bc96cf4
JR
24%prep
25%setup -q -n mod_fastcgi_%{version}
26
27%build
35e5dca4 28apxs -D SUEXEC_BIN="\"\\\"/usr/sbin/suexec\\\"\"" -o mod_fastcgi.so -c *.c
1bc96cf4
JR
29strip mod_fastcgi.so
30
31%install
32rm -rf $RPM_BUILD_ROOT
33install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
34
35install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
36
37install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
38
39gzip -9nf docs/LICENSE.TERMS CHANGES
40
7af704d6
JR
41%post
42%{_sbindir}/apxs -e -a -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
43if [ -f /var/lock/subsys/httpd ]; then
44 /etc/rc.d/init.d/httpd restart 1>&2
45else
46 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
47fi
48
49%preun
50if [ "$1" = "0" ]; then
51 %{_sbindir}/apxs -e -A -n fastcgi %{_libexecdir}/mod_fastcgi.so 1>&2
52 if [ -f /var/lock/subsys/httpd ]; then
53 /etc/rc.d/init.d/httpd restart 1>&2
54 fi
55fi
56
1bc96cf4
JR
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
65b7de09 62%doc docs/*.gz *.gz
1bc96cf4
JR
63%doc %{_htmldocdir}
64%attr(755,root,root) %{_libexecdir}/*
This page took 0.036376 seconds and 4 git commands to generate.