]> git.pld-linux.org Git - packages/apache-mod_extract_forwarded.git/blame - apache-mod_extract_forwarded.spec
- do not conflict with irrelevant apache 1 packages
[packages/apache-mod_extract_forwarded.git] / apache-mod_extract_forwarded.spec
CommitLineData
99bd6926
PG
1%define mod_name extract_forwarded
2%define apxs /usr/sbin/apxs
3Summary: Apache module: Extract X-Forwarded-For header
4Name: apache-mod_%{mod_name}
5Version: 2.0.2
6Release: 1
7License: Apache
8Group: Networking/Daemons/HTTP
9Source0: http://www.openinfo.co.uk/apache/%{mod_name}-%{version}.tar.gz
10# Source0-md5: d7aeb59fa81cbe74c485c33873ea1c65
11Source1: %{name}.conf
12URL: http://www.openinfo.co.uk/apache/index.html
13BuildRequires: %{apxs}
14BuildRequires: apache-devel >= 2.0.40
15BuildRequires: rpmbuild(macros) >= 1.268
16Requires: apache(modules-api) = %apache_modules_api
ce17d2ac
ER
17Requires: apache-mod_proxy
18Conflicts: apache-mod_rpaf
99bd6926
PG
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
ce17d2ac 22%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
99bd6926
PG
23
24%description
ce17d2ac
ER
25mod_extract_forwarded is designed to transparently (to other Apache
26modules) modify the information about the connection over which an
27HTTP request is received when that connection is not directly from a
28requesting client to the Apache server but is instead via one or more
29intervening proxy servers.
99bd6926 30
ce17d2ac
ER
31Operation relies on the X-Forwarded-For header, inserted by proxy
32servers. This is a non-RFC-standard request header which was
33introduced by the Squid caching proxy server's developers and which is
34now also supported, for reverse proxy server operation, by Apache 2.
35If the intervening proxy servers doesn't add such headers, we can't do
36anything about it. It is worth noting that a normally configured Squid
37proxy server will add to the X-Forwarded-For. However, when used as a
38proxy server, Apache prior to version 2 does not add X-Forwarded-For
39headers unless the third party mod_proxy_add_forward module has been
40added to it. This can leave potentially important gaps in the
41information recorded in X-Forwarded-For header.
99bd6926
PG
42
43%prep
44%setup -q -n %{mod_name}
45
46%build
47%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
48
49%install
50rm -rf $RPM_BUILD_ROOT
ce17d2ac
ER
51install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
52cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
53install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
99bd6926
PG
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%post
59%service -q httpd restart
60
61%postun
62if [ "$1" = "0" ]; then
63 %service -q httpd restart
64fi
65
66%files
67%defattr(644,root,root,755)
68%doc README INSTALL
ce17d2ac 69%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
99bd6926 70%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.068757 seconds and 4 git commands to generate.