]> git.pld-linux.org Git - packages/apache-mod_evasive.git/blame - apache-mod_evasive.spec
- init
[packages/apache-mod_evasive.git] / apache-mod_evasive.spec
CommitLineData
6674f92f 1%define mod_name evasive
2%define apxs %{_sbindir}/apxs
3Summary: Apache module: evasive
4Summary(pl.UTF-8): ModuĊ‚ Apache'a: evasive
5Name: apache-mod_%{mod_name}
6Version: 1.10.1
7Release: 1
8License: GPL
9Group: Networking/Daemons/HTTP
10Source0: http://www.zdziarski.com/projects/mod_evasive/mod_evasive_1.10.1.tar.gz
11# Source0-md5: 784fca4a124f25ccff5b48c7a69a65e5
12Source1: %{name}.conf
13URL: http://www.zdziarski.com/projects/mod_evasive/
14BuildRequires: %{apxs}
15BuildRequires: apache-devel >= 2.2
16BuildRequires: rpmbuild(macros) >= 1.268
17Requires: apache(modules-api) = %apache_modules_api
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
22
23%description
24mod_evasive is an evasive maneuvers module for Apache.
25
26%description -l pl.UTF-8
27
28%prep
29%setup -q -n mod_%{mod_name}
30
31%build
32%{apxs} -c mod_%{mod_name}20.c -o mod_%{mod_name}20.la -DMAILER='/usr/sbin/sendmail -t'
33
34%install
35rm -rf $RPM_BUILD_ROOT
36install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
37
38install .libs/mod_%{mod_name}20.so $RPM_BUILD_ROOT%{_pkglibdir}
39
40install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%post
46%service -q httpd restart
47
48%postun
49if [ "$1" = "0" ]; then
50 %service -q httpd restart
51fi
52
53%files
54%defattr(644,root,root,755)
55%doc README
56%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
57%attr(755,root,root) %{_pkglibdir}/*
This page took 0.130396 seconds and 4 git commands to generate.