]> git.pld-linux.org Git - packages/apache-mod_epp.git/blob - apache-mod_epp.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/apache-mod_epp.git] / apache-mod_epp.spec
1 # TODO:
2 # - example/minimal configuration file
3 %define         mod_name        epp
4 %define         apxs            /usr/sbin/apxs
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        An EPP (Extensible Provisioning Protocol) implementation for Apache2
7 Summary(pl.UTF-8):      Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
8 Name:           apache-mod_%{mod_name}
9 Version:        1.10
10 Release:        0.2
11 License:        Apache
12 Group:          Networking/Daemons/HTTP
13 Source0:        http://downloads.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  1418187bf2b478ef2769271000f2b2c8
15 Source1:        http://downloads.sourceforge.net/aepps/epp-erd-20030122.tar.gz
16 # Source1-md5:  3d7720410e83fe6e90742119892011e2
17 URL:            http://aepps.sourceforge.net/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0.43
20 BuildRequires:  rpm-perlprov
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27
28 %description
29 This Apache 2.0 module implements the EPP over TCP protocol as defined
30 in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
31 of draft-ietf-provreg-epp-0(6|7).txt.
32
33 This is *not* a full implementation of EPP, this module just makes it
34 possible to write an EPP server as a set of CGI scripts.
35
36 %description -l pl.UTF-8
37 Ten moduł Apache 2.0 jest implementacją protokołu EPP po TCP zgodną z
38 dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz częściami
39 dotyczącymi zarządzania sesją z draft-ietf-provreg-epp-0(6|7).txt.
40
41 *Nie* jest to pełna implementacja EPP, ten moduł jedynie umożliwia
42 pisanie serwera EPP jako zestawu skryptów CGI.
43
44 %prep
45 %setup -q -n mod_%{mod_name}-%{version} -a1
46
47 %build
48 %{apxs} -c mod_%{mod_name}.c
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
53
54 libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
55 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
56
57 install -p epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
58 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
61         $RPM_BUILD_ROOT%{_sysconfdir}/68_mod_%{mod_name}.conf
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %service -q httpd restart
68
69 %postun
70 if [ "$1" = "0" ]; then
71         %service -q httpd restart
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README TODO epp-erd*
77 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
78 %attr(755,root,root) %{_pkglibdir}/*.so
79 %attr(755,root,root) %{_bindir}/*
80 %{_examplesdir}/%{name}-%{version}
This page took 0.084728 seconds and 3 git commands to generate.