]> git.pld-linux.org Git - packages/apache-mod_epp.git/blame - apache-mod_epp.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/apache-mod_epp.git] / apache-mod_epp.spec
CommitLineData
687cab59 1# TODO:
2# - example/minimal configuration file
687cab59 3%define mod_name epp
4%define apxs /usr/sbin/apxs
5Summary: An EPP (Extensible Provisioning Protocol) implementation for Apache2
07cd93ce 6Summary(pl.UTF-8): Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
687cab59 7Name: apache-mod_%{mod_name}
df9334ab 8Version: 1.10
8a51e947 9Release: 0.2
687cab59 10License: Apache
edbb084a 11Group: Networking/Daemons/HTTP
93d82238 12Source0: http://downloads.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
df9334ab 13# Source0-md5: 1418187bf2b478ef2769271000f2b2c8
93d82238
ER
14Source1: http://downloads.sourceforge.net/aepps/epp-erd-20030122.tar.gz
15# Source1-md5: 3d7720410e83fe6e90742119892011e2
687cab59 16URL: http://aepps.sourceforge.net/
d57fdca1 17BuildRequires: %{apxs}
687cab59 18BuildRequires: apache-devel >= 2.0.43
19BuildRequires: rpm-perlprov
20545a98 20BuildRequires: rpmbuild(macros) >= 1.268
737483df 21Requires: apache(modules-api) = %apache_modules_api
687cab59 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
737483df 24%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
a4442373 25%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
687cab59 26
27%description
28This Apache 2.0 module implements the EPP over TCP protocol as defined
29in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
30of draft-ietf-provreg-epp-0(6|7).txt.
31
32This is *not* a full implementation of EPP, this module just makes it
33possible to write an EPP server as a set of CGI scripts.
34
ea01e4d6
JR
35%description -l pl.UTF-8
36Ten moduł Apache 2.0 jest implementacją protokołu EPP po TCP zgodną z
37dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz częściami
38dotyczącymi zarządzania sesją z draft-ietf-provreg-epp-0(6|7).txt.
5d28c916 39
ea01e4d6
JR
40*Nie* jest to pełna implementacja EPP, ten moduł jedynie umożliwia
41pisanie serwera EPP jako zestawu skryptów CGI.
687cab59 42
43%prep
82003490 44%setup -q -n mod_%{mod_name}-%{version} -a1
687cab59 45
46%build
47%{apxs} -c mod_%{mod_name}.c
48
49%install
50rm -rf $RPM_BUILD_ROOT
a4442373 51install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir},%{_examplesdir}/%{name}-%{version}}
687cab59 52
737483df
ER
53libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
54rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
82003490 55
a4442373 56install -p epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
737483df 57cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
687cab59 58
737483df 59echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
a4442373 60 $RPM_BUILD_ROOT%{_sysconfdir}/68_mod_%{mod_name}.conf
82003490 61
687cab59 62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
20545a98 66%service -q httpd restart
687cab59 67
335d68d6 68%postun
687cab59 69if [ "$1" = "0" ]; then
20545a98 70 %service -q httpd restart
687cab59 71fi
72
73%files
74%defattr(644,root,root,755)
82003490 75%doc README TODO epp-erd*
a4442373 76%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
82003490 77%attr(755,root,root) %{_pkglibdir}/*.so
737483df 78%attr(755,root,root) %{_bindir}/*
687cab59 79%{_examplesdir}/%{name}-%{version}
This page took 0.06996 seconds and 4 git commands to generate.