]> git.pld-linux.org Git - packages/apache-mod_encoding.git/blob - apache-mod_encoding.spec
- fix config dir
[packages/apache-mod_encoding.git] / apache-mod_encoding.spec
1 %define         mod_name        encoding
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: convert character encoding of request URLs
4 Summary(pl.UTF-8):      Moduł Apache'a przekształcający kodowanie znaków żądanych URL-i
5 Name:           apache-mod_%{mod_name}
6 %define         _source_version 20021209
7 Version:        20040616
8 Release:        0.1
9 License:        Apache or BSD-like?
10 Group:          Networking/Daemons/HTTP
11 Source0:        http://webdav.todo.gr.jp/download/mod_%{mod_name}-%{_source_version}.tar.gz
12 # Source0-md5:  489cbd9c7429baf45c4234c51cb2af23
13 Source1:        http://webdav.todo.gr.jp/download/experimental/mod_%{mod_name}.c.apache2.%{version}
14 # Source1-md5:  5015b7a38e16be8534d2edcc8614d00e
15 #Source1:       %{name}.conf
16 #Source2:       %{name}.logrotate
17 Patch0:         %{name}-iconv_h.patch
18 URL:            http://webdav.todo.gr.jp/
19 BuildRequires:  %{apxs}
20 BuildRequires:  apache-devel >= 2.0.40
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  rpmbuild(macros) >= 1.268
24 Requires:       apache(modules-api) = %apache_modules_api
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
28 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
29 %define         _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
30
31 %description
32 This module improves non-ascii filename interoperability of Apache
33 (and mod_dav).
34
35 %description -l pl.UTF-8
36 Ten moduł poprawia współpracę Apache'a (i mod_dav) z nazwami plików
37 zawierającymi znaki spoza ASCII.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{_source_version}
41 install %{SOURCE1} mod_%{mod_name}.c
42 #%patch0 -p0
43
44 %build
45 %{__autoconf}
46 %{__aclocal}
47 %{__automake}
48 %configure \
49         --with-apxs=%{apxs}
50
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},/etc/logrotate.d,%{_pkglogdir}}
56
57 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
59 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %service -q httpd restart
66
67 %postun
68 if [ "$1" = "0" ]; then
69         %service -q httpd restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS ChangeLog README*
75 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
76 #%attr(755,root,root) %{_pkglibdir}/*.so
77 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
78 #%attr(640,root,root) %ghost %{_pkglogdir}/*
This page took 0.112645 seconds and 3 git commands to generate.