]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blob - apache-mod_clamav.spec
Release 8 (by relup.sh)
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
1 %define         apxs            /usr/sbin/apxs
2 %define         mod_name        clamav
3 Summary:        An Apache virus scanning filter
4 Summary(pl.UTF-8):      Filtr skanera antywirusowego dla Apache'a
5 Name:           apache-mod_%{mod_name}
6 Version:        0.23
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  32c7b285dfdff5d13371b92ebe73b352
12 Source1:        %{name}.conf
13 URL:            http://software.othello.ch/mod_clamav/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.0
16 BuildRequires:  apr-devel >= 1:1.0
17 BuildRequires:  apr-util-devel >= 1:1.0
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  clamav-devel
21 BuildRequires:  libtool
22 BuildRequires:  rpmbuild(macros) >= 1.268
23 Requires:       apache(modules-api) = %apache_modules_api
24 Requires:       apache-mod_proxy
25 Requires:       clamav
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
30
31 %description
32 mod_clamav is an Apache 2 filter which scans the content delivered by
33 the proxy module (mod_proxy) for viruses using the Clamav virus
34 scanning engine.
35
36 %description -l pl.UTF-8
37 mod_clamav to filtr dla serwera Apache 2 skanujący treści dostarczane
38 przez moduł proxy (mod_proxy) pod kątem wirusów przy użyciu silnika
39 skanera antywirusowego Clamav.
40
41 %prep
42 %setup -q -n mod_%{mod_name}-%{version}
43
44 %build
45 %{__libtoolize}
46 %{__aclocal}
47 %{__autoconf}
48 %{__automake}
49
50 CPPFLAGS="-I `/usr/bin/apr-1-config --includedir` -I `/usr/bin/apu-1-config --includedir`"
51 %configure \
52         --with-apxs=%{apxs}
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
58
59 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
60 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/32_mod_clamav.conf
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %service -q httpd restart
67
68 %postun
69 if [ "$1" = "0" ]; then
70         %service -q httpd restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
76 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
77 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.075178 seconds and 3 git commands to generate.