]> git.pld-linux.org Git - packages/apache-mod_chroot.git/blame_incremental - apache-mod_chroot.spec
- apache-apxs -> %{apxs} in BR
[packages/apache-mod_chroot.git] / apache-mod_chroot.spec
... / ...
CommitLineData
1%define mod_name chroot
2%define apxs /usr/sbin/apxs
3Summary: Apache module: makes running Apache in a secure chroot environment easy
4Summary(pl.UTF-8): Moduł Apache'a do uruchamiania serwera w bezpiecznym środowisku chroot
5Name: apache-mod_%{mod_name}
6Version: 0.5
7Release: 0.1
8License: GPL
9Group: Networking/Daemons
10Source0: http://core.segfault.pl/~hobbit/mod_chroot/dist/mod_chroot-%{version}.tar.gz
11# Source0-md5: d72716052faa3bdd3371210f26b13f38
12URL: http://core.segfault.pl/~hobbit/mod_chroot/
13BuildRequires: %{apxs}
14BuildRequires: apache-devel >= 2.0
15BuildRequires: rpmbuild(macros) >= 1.268
16Requires: apache(modules-api) = %apache_modules_api
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
20%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
21
22%description
23mod_chroot makes running Apache in a secure chroot environment easy.
24You don't need to create a special directory hierarchy containing
25/dev, /lib, /etc...
26
27%description -l pl.UTF-8
28mod_chroot ułatwia uruchamianie Apache'a w bezpiecznym środowisku
29chroot. Nie trzeba tworzyć specjalnej hierarchii katalogów /dev, /lib,
30/etc, itp.
31
32%prep
33%setup -q -n mod_%{mod_name}-%{version}
34
35%build
36%{apxs} -c mod_%{mod_name}.c
37
38%install
39rm -rf $RPM_BUILD_ROOT
40install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
41
42install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
43echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
44 $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%post
50%service -q httpd restart
51
52%postun
53if [ "$1" = "0" ]; then
54 %service -q httpd restart
55fi
56
57%files
58%defattr(644,root,root,755)
59%doc CAVEATS ChangeLog INSTALL README
60%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
61%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.136879 seconds and 4 git commands to generate.