]> git.pld-linux.org Git - packages/apache-mod_cband.git/blob - apache-mod_cband.spec
- rel 2
[packages/apache-mod_cband.git] / apache-mod_cband.spec
1 %define         mod_name        cband
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: bandwidth limits per vhosts
4 Summary(pl):    Modu³ do Apache: limity pasma dla poszczególnych vhostów
5 Name:           apache-mod_%{mod_name}
6 Version:        0.9.7.4
7 Release:        2
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://cband.linux.pl/download/mod-%{mod_name}-%{version}.tgz
11 # Source0-md5:  ff635d7b55bf7ca648d319247dfb45e3
12 Source1:        %{name}.conf
13 URL:            http://cband.linux.pl/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires:       apache(modules-api) = %apache_modules_api
18 Requires:       crondaemon
19 Requires:       procps
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24
25 %description
26 mod_cband is an Apache 2 module provided to solve the problem of
27 limiting users' and virtualhosts' bandwidth usage. When the configured
28 virtualhost's transfer limit is exceeded, mod_cband will redirect all
29 further requests to a location specified in the configuration file.
30
31 %description -l pl
32 mod_cband to modu³ Apache'a 2 maj±cy za zadanie ograniczanie zu¿ycia
33 pasma przez u¿ytkowników i hosty wirtualne. Gdy okre¶lony limit
34 zostanie przekroczony, mod_cband przekieruje wszelkie zapytania do
35 strony wskazanej w pliku konfiguracyjnym.
36
37 %prep
38 %setup -q -n mod-%{mod_name}-%{version}
39
40 %build
41 %configure \
42         --with-apxs=%{apxs}
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
48
49 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
50 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/97_mod_%{mod_name}.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %service -q httpd restart
57
58 %postun
59 if [ "$1" = "0" ]; then
60         %service -q httpd restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS Changes INSTALL conf/*.example
66 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*mod_*.conf
67 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.026433 seconds and 3 git commands to generate.