]> git.pld-linux.org Git - packages/apache-mod_cband.git/blame_incremental - apache-mod_cband.spec
- HTTP group
[packages/apache-mod_cband.git] / apache-mod_cband.spec
... / ...
CommitLineData
1%define mod_name cband
2%define apxs /usr/sbin/apxs
3Summary: Apache module: bandwidth limits per vhosts
4Summary(pl.UTF-8): Moduł do Apache: limity pasma dla poszczególnych vhostów
5Name: apache-mod_%{mod_name}
6Version: 0.9.7.5
7Release: 2
8License: Apache
9Group: Networking/Daemons/HTTP
10Source0: http://cband.linux.pl/download/mod-%{mod_name}-%{version}.tgz
11# Source0-md5: 5c5d65dc9abe6cdc6931b6dd33be5018
12Source1: %{name}.conf
13URL: http://cband.linux.pl/
14BuildRequires: %{apxs}
15BuildRequires: apache-devel >= 2.0.0
16BuildRequires: rpmbuild(macros) >= 1.268
17Requires: apache(modules-api) = %apache_modules_api
18Requires: crondaemon
19Requires: procps
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
23%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24
25%description
26mod_cband is an Apache 2 module provided to solve the problem of
27limiting users' and virtualhosts' bandwidth usage. When the configured
28virtualhost's transfer limit is exceeded, mod_cband will redirect all
29further requests to a location specified in the configuration file.
30
31%description -l pl.UTF-8
32mod_cband to moduł Apache'a 2 mający za zadanie ograniczanie zużycia
33pasma przez użytkowników i hosty wirtualne. Gdy określony limit
34zostanie przekroczony, mod_cband przekieruje wszelkie zapytania do
35strony wskazanej w pliku konfiguracyjnym.
36
37%prep
38%setup -q -n mod-%{mod_name}-%{version}
39
40%build
41%configure \
42 --with-apxs=%{apxs}
43%{__make}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
48
49install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
50install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/97_mod_%{mod_name}.conf
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56%service -q httpd restart
57
58%postun
59if [ "$1" = "0" ]; then
60 %service -q httpd restart
61fi
62
63%files
64%defattr(644,root,root,755)
65%doc AUTHORS Changes INSTALL conf/*.example
66%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*mod_*.conf
67%attr(755,root,root) %{apachelibdir}/*.so
This page took 0.154959 seconds and 4 git commands to generate.