]> git.pld-linux.org Git - packages/apache-mod_authnz_external.git/blame - apache-mod_authnz_external.spec
- updated to 3.3.1
[packages/apache-mod_authnz_external.git] / apache-mod_authnz_external.spec
CommitLineData
a836b4e4
ER
1%define mod_name authnz_external
2%define apxs /usr/sbin/apxs
e500636a 3Summary: Basic authentication for the Apache Web server using arbitrary shell commands
981b4a87
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí shellových příkazů
5Summary(da.UTF-8): En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9Summary(nb.UTF-8): En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10Summary(pl.UTF-8): Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11Summary(pt.UTF-8): Um módulo de autenticação de LDAP para o servidor Web Apache
12Summary(sl.UTF-8): Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13Summary(sv.UTF-8): Grundläggande autentisering för webbservern Apache med valfria skalkommandon
e500636a 14Name: apache-mod_%{mod_name}
d6753acc
JR
15Version: 3.3.1
16Release: 1
e500636a 17License: BSD
3f2b39ea 18Group: Networking/Daemons/HTTP
b934ae5c 19Source0: http://mod-auth-external.googlecode.com/files/mod_%{mod_name}-%{version}.tar.gz
d6753acc
JR
20# Source0-md5: 4cb3f16ff85b62fbc2cc73bac406bb67
21Patch0: mod_authnz_external-apache24.patch
b934ae5c 22URL: http://code.google.com/p/mod-auth-external/
34e5b376 23BuildRequires: %{apxs}
e500636a
JR
24BuildRequires: apache-devel >= 2.2
25BuildRequires: rpmbuild(macros) >= 1.268
26Requires: apache(modules-api) = %apache_modules_api
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
a836b4e4 30%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
e500636a
JR
31
32%description
b9ce1d78 33This module allows you to use any command line program to authenticate
34a user.
e500636a 35
4752df0d
JR
36%description -l cs.UTF-8
37Balíček mod_auth_external slouží pro omezení přístupu k dokumentům,
38které poskytuje WWW server Apache. Jména a hesla jsou kontrolována
39pomocí jakéhokoliv příkazu (jeho návratovým kódem).
e500636a 40
4752df0d 41%description -l de.UTF-8
b9ce1d78 42Mod_auth_external kann verwendet werden, um den Zugriff auf von einem
4752df0d
JR
43Web- Server bediente Dokumente zu beschränken, indem es den Rückcode
44eines gegebenen arbiträren Befehls prüft.
e500636a 45
4752df0d 46%description -l es.UTF-8
b9ce1d78 47Mod_auth_external puede usarse para limitar el acceso a documentos
4752df0d 48servidos desde un servidor web verificando el código de retorno de un
b9ce1d78 49comando arbitrario especificado.
e500636a 50
4752df0d
JR
51%description -l fr.UTF-8
52Mod_auth_external peut être utilisé pour limiter l'accès à des
53documents servis par un serveur Web en vérifiant le code de retour
54d'une commande spécifiée arbitraire.
e500636a 55
4752df0d
JR
56%description -l it.UTF-8
57Mod_auth_external può essere utilizzato per limitare l'accesso ai
b9ce1d78 58documenti serviti da un server Web controllando il codice di ritorno
59di un dato comando arbitrario.
e500636a 60
4752df0d 61%description -l ja.UTF-8
b9ce1d78 62Mod_auth_external
4752df0d
JR
63は任意に指定されたコマンドの戻りコードをチェックすること によって、Web
64サーバーが提供するドキュメントへのアクセスを制限すること ができます。
e500636a 65
4752df0d
JR
66%description -l pl.UTF-8
67Ten moduł pozwala na użycie dowolnego programu działającego z linii
68poleceń do uwierzytelniania użytkownika.
e500636a 69
4752df0d
JR
70%description -l sv.UTF-8
71Mod_auth_external kan användas för att begränsa åtkomsten till
b9ce1d78 72dokument servade av en webbserver genom att kontrollera returkoden
4752df0d 73från ett godtyckligt angivet kommando.
e500636a
JR
74
75%prep
76%setup -q -n mod_%{mod_name}-%{version}
d6753acc 77%patch0 -p1
e500636a
JR
78
79%build
80%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
81
82%install
83rm -rf $RPM_BUILD_ROOT
a836b4e4 84install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
e500636a 85
a836b4e4 86install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
e500636a 87echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
a836b4e4 88 $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
e500636a
JR
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post
94%service -q httpd restart
95
96%postun
97if [ "$1" = "0" ]; then
98 %service -q httpd restart
99fi
100
101%files
102%defattr(644,root,root,755)
d6753acc 103%doc TODO AUTHENTICATORS CHANGES README INSTALL test
a836b4e4 104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
e500636a 105%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.113649 seconds and 4 git commands to generate.