]> git.pld-linux.org Git - packages/apache-mod_auth_xradius.git/blame - apache-mod_auth_xradius.spec
- fix building with apache 2.4
[packages/apache-mod_auth_xradius.git] / apache-mod_auth_xradius.spec
CommitLineData
71532eb5
SP
1#
2%define mod_name auth_xradius
40fb715d 3%define apxs %{_sbindir}/apxs
71532eb5
SP
4Summary: Apache module:
5Name: apache-mod_%{mod_name}
6Version: 0.4.6
40fb715d 7Release: 5
71532eb5
SP
8License: GPL
9Group: Networking/Daemons/HTTP
10Source0: http://www.outoforder.cc/downloads/mod_auth_xradius/mod_auth_xradius-%{version}.tar.bz2
11# Source0-md5: eeecc96f15dec9fe0a9c78c0b022903d
12Source1: %{name}.conf
40fb715d 13Patch0: mod_auth_xradius-unixd.patch
71532eb5 14URL: http://www.outoforder.cc/projects/apache/mod_auth_xradius/
f7ab3a57 15BuildRequires: %{apxs}
71532eb5
SP
16BuildRequires: apache-devel >= 2.2
17BuildRequires: rpmbuild(macros) >= 1.268
18Requires: apache(modules-api) = %apache_modules_api
6a772d83 19Requires: apache-mod_auth_basic >= 2.2
90b988e8 20Requires: apache-mod_authz_user >= 2.2
71532eb5
SP
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
25
26%description
27mod_auth_xradius provides high performance authentication against RFC
282865 RADIUS Servers. Features:
29- Supports popular RADIUS Servers including OpenRADIUS, FreeRADIUS and
30 commercial servers.
31- Distributed Authentication Cache using apr_memcache.
32- Local Authentication Cache using DBM.
33- Uses standard HTTP Basic Authentication, unlike mod_auth_radius
34 which uses cookies for sessions.
35
36%prep
37%setup -q -n mod_%{mod_name}-%{version}
40fb715d 38%patch0 -p1
71532eb5
SP
39
40%build
41%configure
42
43%{__make}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
48
49%{__make} install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58%service -q httpd restart
59
60%postun
61if [ "$1" = "0" ]; then
62 %service -q httpd restart
63fi
64
65%files
66%defattr(644,root,root,755)
67%doc README
68%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
69%attr(755,root,root) %{_pkglibdir}/*
This page took 0.072697 seconds and 4 git commands to generate.