]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- fix config dir
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da.UTF-8):      Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es.UTF-8):      Autenticación vía PostgreSQL para Apache
8 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it.UTF-8):      Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja.UTF-8):      PostgreSQL データベースを使った Apache Web サーバーへの基本認証
11 Summary(nb.UTF-8):      Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl.UTF-8):      Moduł uwierzytelnienia PostgreSQL dla Apache
13 Summary(pt_BR.UTF-8):   Autenticação via PostgreSQL para o Apache
14 Summary(sv.UTF-8):      Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.0.3
17 Release:        1
18 License:        GPL
19 Group:          Networking/Daemons/HTTP
20 Source0:        http://www.giuseppetanzilli.it/mod_auth_pgsql2/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  d44074b3b9bdb0a5eb9702814872ad43
22 Source1:        apache-mod_auth_pgsql.conf
23 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql2/
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache-devel >= 2.0.52-2
26 BuildRequires:  postgresql-devel
27 BuildRequires:  rpmbuild(macros) >= 1.268
28 Requires:       apache(modules-api) = %apache_modules_api
29 Obsoletes:      mod_auth_pgsql
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
34
35 %description
36 This is an authentication module for Apache that allows you to
37 authenticate HTTP clients using PostgreSQL RDBMS.
38
39 %description -l cs.UTF-8
40 Balíček mod_auth_pgsql slouží pro omezení přístupu k dokumentům, které
41 poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
42 PostgreSQL.
43
44 %description -l de.UTF-8
45 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
46 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
47 einer Tabelle in einer PostgresQL-Datenbank prüft.
48
49 %description -l es.UTF-8
50 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
51 servidos desde un servidor web verificando datos en una base de datos
52 PostgreSQL.
53
54 %description -l fr.UTF-8
55 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
56 servis par un serveur Web en vérifiant des champs dans une table d'une
57 base de données PostgresQL.
58
59 %description -l it.UTF-8
60 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
61 serviti da un server Web controllando i campi di una tabella in un
62 database PostgresQL.
63
64 %description -l ja.UTF-8
65 Mod_auth_pgsql は、PostgresQL データベースのテーブルの中のフィールドを
66 チェックすることによって、Web サーバーが提供する文書へのアクセスを
67 制限できます。
68
69 %description -l pl.UTF-8
70 To jest moduł uwierzytelnienia dla Apache pozwalający na
71 uwierzytelnianie klientów HTTP z użyciem bazy danych PostgreSQL.
72
73 %description -l pt_BR.UTF-8
74 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
75 PostgreSQL.
76
77 %description -l sv.UTF-8
78 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
79 servade av en webbserver genom att kontrollera data i en
80 PostgreSQL-databas.
81
82 %prep
83 %setup -q -n mod_%{mod_name}-%{version}
84
85 %build
86 %{apxs} \
87         -I%{_includedir}/postgresql \
88         -lpq \
89         -c mod_%{mod_name}.c \
90         -o mod_%{mod_name}.la
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
95
96 install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
97 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/52_mod_auth_pgsql.conf
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 %service -q httpd restart
104
105 %postun
106 if [ "$1" = "0" ]; then
107         %service -q httpd restart
108 fi
109
110 %files
111 %defattr(644,root,root,755)
112 %doc *.html
113 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_auth_pgsql.conf
114 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.09822 seconds and 3 git commands to generate.