]> git.pld-linux.org Git - packages/apache-mod_auth_pam.git/blame - apache-mod_auth_pam.spec
- new & works for me.
[packages/apache-mod_auth_pam.git] / apache-mod_auth_pam.spec
CommitLineData
1511467c 1%define mod_name auth_pam
2Summary: This is the PAM authentication module for Apache
3Name: apache-mod_%{mod_name}
4Version: 1.0a
5Release: 1
6License: GPL
7Group: Networking/Daemons
8Group(de): Netzwerkwesen/Server
9Group(pl): Sieciowe/Serwery
10Source0: http://pam.sourceforge.net/mod_auth_pam/dist/mod_%{mod_name}.tar.gz
11BuildRequires: /usr/sbin/apxs
12BuildRequires: apache(EAPI)-devel
13Prereq: /usr/sbin/apxs
14Requires: apache(EAPI)
15URL: http://pam.sourceforge.net/mod_auth_pam/
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _pkglibdir %(/usr/sbin/apxs -q LIBEXECDIR)
19
20%description
21This is an authentication module for Apache that allows you to
22authenticate HTTP clients using user entries in an samba directory.
23
24%prep
25%setup -q -n mod_%{mod_name}-%{version}
26
27%build
28%{_sbindir}/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so
29
30%install
31rm -rf $RPM_BUILD_ROOT
32install -d $RPM_BUILD_ROOT%{_pkglibdir}
33
34install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
35
36%post
37/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
38if [ -f /var/lock/subsys/httpd ]; then
39 /etc/rc.d/init.d/httpd restart 1>&2
40fi
41
42%preun
43if [ "$1" = "0" ]; then
44 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46 /etc/rc.d/init.d/httpd restart 1>&2
47 fi
48fi
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%attr(755,root,root) %{_pkglibdir}/*
This page took 0.121064 seconds and 4 git commands to generate.