]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- use http://ftp.debian.org/ url
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da.UTF-8):      Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es.UTF-8):      Autenticación vía MySQL para Apache
8 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja.UTF-8):      MySQL データベースを使った Apache Web サーバーへの基本認証
11 Summary(nb.UTF-8):      Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl.UTF-8):      Moduł uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR.UTF-8):   Autenticação via MySQL para o Apache
14 Summary(sv.UTF-8):      Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        4.3.9
17 Release:        0.2
18 License:        GPL
19 Group:          Networking/Daemons/HTTP
20 Source0:        ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21 # Source0-md5:  9c1ecbe5fb64d4c93444311ff34bfe35
22 Patch0:         %{name}-ac.patch
23 # Needs review:
24 #  https://rhn.redhat.com/errata/RHSA-2009-0259.html
25 BuildRequires:  security(CVE-2008-2384)
26 BuildRequires:  %{apxs}
27 BuildRequires:  apache-devel >= 2.0.0
28 BuildRequires:  apr-util >= 1:1.0
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  libtool
32 BuildRequires:  mysql-devel
33 BuildRequires:  rpmbuild(macros) >= 1.268
34 Requires:       apache(modules-api) = %apache_modules_api
35 Requires:       apache-mod_auth
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
39 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
40
41 %description
42 This is an authentication module for Apache that allows you to
43 authenticate HTTP clients using MySQL RDBMS.
44
45 %description -l cs.UTF-8
46 Balíček mod_auth_mysql slouží pro omezení přístupu k dokumentům, které
47 poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
48 MySQL.
49
50 %description -l de.UTF-8
51 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
52 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
53 einer MySQL-Datenbank prüft.
54
55 %description -l es.UTF-8
56 mod_auth_mysql puede usarse para limitar el acceso a documentos
57 servidos por un servidor web verificando datos en una base de datos
58 MySQL.
59
60 %description -l fr.UTF-8
61 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
62 servis par un serveur Web en vérifiant les données dans une base de
63 données MySQL.
64
65 %description -l it.UTF-8
66 mod_auth_mysql può essere usato per limitare l'accesso a documenti
67 serviti da un server Web controllando i dati in un database MySQL.
68
69 %description -l ja.UTF-8
70 mod_auth_mysql は、MySQL データベースのデータをチェックすること
71 によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
72 ができます。
73
74 %description -l pl.UTF-8
75 To jest moduł uwierzytelnienia dla Apache pozwalający na
76 uwierzytelnianie klientów HTTP z użyciem bazy danych MySQL.
77
78 %description -l pt_BR.UTF-8
79 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
80 MySQL.
81
82 %description -l sv.UTF-8
83 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
84 servade av en webbserver genom att kontrollera data i en
85 MySQL-databas.
86
87 %prep
88 %setup -q -n mod-auth-mysql-%{version}
89 %patch0 -p1
90
91 %build
92 %{__aclocal}
93 %{__autoconf}
94 %configure \
95         --disable-static \
96         --disable-apache13 \
97         --enable-apache2 \
98         --with-apxs2=%{apxs} \
99         --with-mysql=%{_prefix}
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
105
106 libtool install apache2_mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
107 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
108
109 echo 'LoadModule %{mod_name}_module     modules/apache2_mod_%{mod_name}.so' > \
110         $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 %service -q httpd restart
117
118 %postun
119 if [ "$1" = "0" ]; then
120         %service -q httpd restart
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc DIRECTIVES USAGE
126 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
127 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.076039 seconds and 3 git commands to generate.