]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blame - apache-mod_auth_mysql.spec
- spec adapterized.
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
CommitLineData
d342ce4f 1%define mod_name auth_mysql
2Summary: This is the PAM authentication module for Apache
3Name: apache-mod_%{mod_name}
4Version: 0.3
5Release: 1
6License: GPL
7Group: Networking/Daemons
8Group(de): Netzwerkwesen/Server
9Group(pl): Sieciowe/Serwery
10Source0: ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
a2c00ae7 11BuildRequires: mysql-devel
d342ce4f 12BuildRequires: /usr/sbin/apxs
13BuildRequires: apache(EAPI)-devel
14Prereq: /usr/sbin/apxs
15Requires: apache(EAPI)
16URL: http://modntlm.sourceforge.net/
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(/usr/sbin/apxs -q LIBEXECDIR)
20
21%description
22This is an authentication module for Apache that allows you to
23authenticate HTTP clients using mysql RDBMS.
24
25%prep
a2c00ae7 26%setup -q -T -c
d342ce4f 27cp %{SOURCE0} .
28gzip -d mod_%{mod_name}.c.gz
29
30%build
db68d741 31/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
d342ce4f 32
33%install
34rm -rf $RPM_BUILD_ROOT
35install -d $RPM_BUILD_ROOT%{_pkglibdir}
36
37install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
38
39%post
40/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
41if [ -f /var/lock/subsys/httpd ]; then
42 /etc/rc.d/init.d/httpd restart 1>&2
43fi
44
45%preun
46if [ "$1" = "0" ]; then
47 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
48 if [ -f /var/lock/subsys/httpd ]; then
49 /etc/rc.d/init.d/httpd restart 1>&2
50 fi
51fi
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%attr(755,root,root) %{_pkglibdir}/*
This page took 0.067811 seconds and 4 git commands to generate.