]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blame - apache-mod_auth_mysql.spec
- HTTP group
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
CommitLineData
530d9142
AM
1%define mod_name auth_mysql
2%define apxs /usr/sbin/apxs
3Summary: This is the MySQL authentication module for Apache
f37bfe52
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí MySQL
5Summary(da.UTF-8): Autenticering for webtjeneren Apache fra en MySQL-database
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7Summary(es.UTF-8): Autenticación vía MySQL para Apache
8Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante un database MySQL
10Summary(ja.UTF-8): MySQL データベースを使った Apache Web サーバーへの基本認証
11Summary(nb.UTF-8): Autentisering for webtjeneren Apache fra en MySQL-database
12Summary(pl.UTF-8): Moduł uwierzytelnienia MySQL dla Apache
13Summary(pt_BR.UTF-8): Autenticação via MySQL para o Apache
14Summary(sv.UTF-8): Grundläggande autenticering för webbservern Apache med en MySQL-databas
530d9142
AM
15Name: apache-mod_%{mod_name}
16Version: 4.3.9
d1b75e11 17Release: 0.2
530d9142 18License: GPL
687eb26f 19Group: Networking/Daemons/HTTP
530d9142
AM
20Source0: ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21# Source0-md5: 9c1ecbe5fb64d4c93444311ff34bfe35
b808f919 22Patch0: %{name}-ac.patch
e84ca197 23BuildRequires: %{apxs}
530d9142 24BuildRequires: apache-devel >= 2.0.0
19e7f197 25BuildRequires: apr-util >= 1:1.0
530d9142
AM
26BuildRequires: autoconf
27BuildRequires: automake
b808f919 28BuildRequires: libtool
530d9142 29BuildRequires: mysql-devel
74851189 30BuildRequires: rpmbuild(macros) >= 1.268
b808f919 31Requires: apache(modules-api) = %apache_modules_api
530d9142 32Requires: apache-mod_auth
530d9142
AM
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
36%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
37
38%description
39This is an authentication module for Apache that allows you to
40authenticate HTTP clients using MySQL RDBMS.
41
6f509cd6
JR
42%description -l cs.UTF-8
43Balíček mod_auth_mysql slouží pro omezení přístupu k dokumentům, které
44poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
530d9142
AM
45MySQL.
46
6f509cd6 47%description -l de.UTF-8
530d9142 48mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
6f509cd6
JR
49Web- Server bediente Dokumente zu beschränken, indem es die Daten in
50einer MySQL-Datenbank prüft.
530d9142 51
6f509cd6 52%description -l es.UTF-8
530d9142
AM
53mod_auth_mysql puede usarse para limitar el acceso a documentos
54servidos por un servidor web verificando datos en una base de datos
55MySQL.
56
6f509cd6
JR
57%description -l fr.UTF-8
58mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
59servis par un serveur Web en vérifiant les données dans une base de
60données MySQL.
530d9142 61
6f509cd6
JR
62%description -l it.UTF-8
63mod_auth_mysql può essere usato per limitare l'accesso a documenti
530d9142
AM
64serviti da un server Web controllando i dati in un database MySQL.
65
6f509cd6
JR
66%description -l ja.UTF-8
67mod_auth_mysql は、MySQL データベースのデータをチェックすること
68によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
69ができます。
530d9142 70
6f509cd6
JR
71%description -l pl.UTF-8
72To jest moduł uwierzytelnienia dla Apache pozwalający na
73uwierzytelnianie klientów HTTP z użyciem bazy danych MySQL.
530d9142 74
6f509cd6
JR
75%description -l pt_BR.UTF-8
76Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
530d9142
AM
77MySQL.
78
6f509cd6
JR
79%description -l sv.UTF-8
80mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
530d9142
AM
81servade av en webbserver genom att kontrollera data i en
82MySQL-databas.
83
84%prep
85%setup -q -n mod-auth-mysql-%{version}
b808f919 86%patch0 -p1
530d9142
AM
87
88%build
b808f919
ER
89%{__aclocal}
90%{__autoconf}
530d9142 91%configure \
b808f919 92 --disable-apache13 \
530d9142 93 --enable-apache2 \
b808f919 94 --with-apxs2=%{apxs} \
530d9142 95 --with-mysql=%{_prefix}
b808f919 96%{__make}
530d9142
AM
97
98%install
99rm -rf $RPM_BUILD_ROOT
b808f919 100install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
530d9142 101
b808f919
ER
102libtool install apache2_mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
103rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
530d9142 104
d1b75e11 105echo 'LoadModule %{mod_name}_module modules/apache2_mod_%{mod_name}.so' > \
b808f919 106 $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
530d9142
AM
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post
74851189 112%service -q httpd restart
530d9142
AM
113
114%postun
115if [ "$1" = "0" ]; then
74851189 116 %service -q httpd restart
530d9142
AM
117fi
118
119%files
120%defattr(644,root,root,755)
636b383b 121%doc DIRECTIVES USAGE
b808f919 122%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
636b383b 123%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.129248 seconds and 4 git commands to generate.