]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- release 7
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl.UTF-8):      Moduł uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.4
7 Release:        7
8 Epoch:          1
9 License:        GPL
10 Group:          Networking/Daemons/HTTP
11 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}.tar.gz
12 # Source0-md5:  642b81763ad3ca81dba359cb952da5e3
13 Source1:        %{name}.conf
14 Patch0:         %{name}-heimdal.patch
15 Patch1:         %{name}-basic-auth.patch
16 URL:            http://modauthkerb.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2.0
19 BuildRequires:  gdbm-devel
20 BuildRequires:  heimdal-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRequires:  sed >= 4.0
23 Requires:       apache(modules-api) = %apache_modules_api
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
28
29 %description
30 This is an authentication module for Apache that allows you to
31 authenticate HTTP clients using user entries in an Kerberos directory.
32
33 %description -l pl.UTF-8
34 To jest moduł uwierzytelnienia dla Apache pozwalający na
35 uwierzytelnianie klientów HTTP z użyciem wpisów w katalogu Kerberosa.
36
37 %prep
38 %setup -q -n mod_%{mod_name}-%{version}
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 %configure \
44         --without-krb4 \
45         --with-apache=%{_prefix}
46
47 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
53
54 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
55 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/20_mod_%{mod_name}.conf
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %service -q httpd restart
62
63 %postun
64 if [ "$1" = "0" ]; then
65         %service -q httpd restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README
71 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
72 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.069098 seconds and 4 git commands to generate.