]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- use %service
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl):    Modu³ uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.0
7 %define pre rc6
8 Release:        0.%{pre}.1
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}-%{pre}.tar.gz
13 # Source0-md5:  274edfb950af20ce6ef0ddcb7c20263a
14 Source1:        %{name}.conf
15 Patch1:         %{name}-aprfix.patch
16 URL:            http://modauthkerb.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel
19 BuildRequires:  gdbm-devel
20 BuildRequires:  heimdal-devel
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRequires:  sed >= 4.0
23 Requires:       apache(modules-api) = %apache_modules_api
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
28
29 %description
30 This is an authentication module for Apache that allows you to
31 authenticate HTTP clients using user entries in an Kerberos directory.
32
33 %description -l pl
34 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
35 uwierzytelnianie klientów HTTP z u¿yciem wpisów w katalogu Kerberosa.
36
37 %prep
38 %setup -q -n mod_%{mod_name}-%{version}-%{pre}
39 %patch1 -p1
40
41 %build
42 %configure
43 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
49
50 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
51 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/20_mod_%{mod_name}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %service -q httpd restart
58
59 %preun
60 if [ "$1" = "0" ]; then
61         %service -q httpd restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
68 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.059765 seconds and 4 git commands to generate.