]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- release 5
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl.UTF-8):      Moduł uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.4
7 Release:        5
8 Epoch:          1
9 License:        GPL
10 Group:          Networking/Daemons/HTTP
11 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}.tar.gz
12 # Source0-md5:  642b81763ad3ca81dba359cb952da5e3
13 Source1:        %{name}.conf
14 Patch0:         %{name}-heimdal.patch
15 URL:            http://modauthkerb.sourceforge.net/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel >= 2.0
18 BuildRequires:  gdbm-devel
19 BuildRequires:  heimdal-devel
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 BuildRequires:  sed >= 4.0
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
26 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27
28 %description
29 This is an authentication module for Apache that allows you to
30 authenticate HTTP clients using user entries in an Kerberos directory.
31
32 %description -l pl.UTF-8
33 To jest moduł uwierzytelnienia dla Apache pozwalający na
34 uwierzytelnianie klientów HTTP z użyciem wpisów w katalogu Kerberosa.
35
36 %prep
37 %setup -q -n mod_%{mod_name}-%{version}
38 %patch0 -p1
39
40 %build
41 %configure \
42         --without-krb4 \
43         --with-apache=%{_prefix}
44
45 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
51
52 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/20_mod_%{mod_name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %service -q httpd restart
60
61 %postun
62 if [ "$1" = "0" ]; then
63         %service -q httpd restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
70 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.062323 seconds and 4 git commands to generate.