]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- BR s@%{apxs}@apache-apxs@g
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 #
2 # Conditional build:
3 %bcond_with     krb4            # build with Kerberos V4 support
4 #
5 %define         mod_name        auth_kerb
6 %define         apxs    /usr/sbin/apxs
7 Summary:        This is the Kerberos authentication module for Apache
8 Summary(pl.UTF-8):      Moduł uwierzytelnienia Kerberos dla Apache
9 Name:           apache-mod_%{mod_name}
10 Version:        5.3
11 Release:        1
12 Epoch:          1
13 License:        GPL
14 Group:          Networking/Daemons
15 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}.tar.gz
16 # Source0-md5:  a363588578050b3d320a2ceccf3ed666
17 Source1:        %{name}.conf
18 URL:            http://modauthkerb.sourceforge.net/
19 BuildRequires:  apache-apxs >= 2.0
20 BuildRequires:  apache-devel
21 BuildRequires:  gdbm-devel
22 BuildRequires:  krb5-devel
23 BuildRequires:  rpmbuild(macros) >= 1.268
24 BuildRequires:  sed >= 4.0
25 Requires:       apache(modules-api) = %apache_modules_api
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30
31 %description
32 This is an authentication module for Apache that allows you to
33 authenticate HTTP clients using user entries in an Kerberos directory.
34
35 %description -l pl.UTF-8
36 To jest moduł uwierzytelnienia dla Apache pozwalający na
37 uwierzytelnianie klientów HTTP z użyciem wpisów w katalogu Kerberosa.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{version}
41
42 %build
43 %configure \
44         %{?with_krb4:--with-krb4} \
45         %{!?with_krb4:--without-krb4} \
46         --with-apache=%{_prefix}
47
48 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
54
55 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/20_mod_%{mod_name}.conf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %service -q httpd restart
63
64 %postun
65 if [ "$1" = "0" ]; then
66         %service -q httpd restart
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README
72 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
73 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.077913 seconds and 4 git commands to generate.