]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blame_incremental - apache-mod_auth_kerb.spec
- use conf.d for apache config fragment; rel 2
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with krb4 # build with Kerberos V4 support
4#
5%define mod_name auth_kerb
6%define apxs /usr/sbin/apxs
7Summary: This is the Kerberos authentication module for Apache
8Summary(pl.UTF-8): Moduł uwierzytelnienia Kerberos dla Apache
9Name: apache-mod_%{mod_name}
10Version: 5.3
11Release: 2
12Epoch: 1
13License: GPL
14Group: Networking/Daemons
15Source0: http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}.tar.gz
16# Source0-md5: a363588578050b3d320a2ceccf3ed666
17Source1: %{name}.conf
18URL: http://modauthkerb.sourceforge.net/
19BuildRequires: %{apxs}
20BuildRequires: apache-devel >= 2.0
21BuildRequires: gdbm-devel
22BuildRequires: krb5-devel
23BuildRequires: rpmbuild(macros) >= 1.268
24BuildRequires: sed >= 4.0
25Requires: apache(modules-api) = %apache_modules_api
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%define pkgconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
29%define pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
30
31%description
32This is an authentication module for Apache that allows you to
33authenticate HTTP clients using user entries in an Kerberos directory.
34
35%description -l pl.UTF-8
36To jest moduł uwierzytelnienia dla Apache pozwalający na
37uwierzytelnianie klientów HTTP z użyciem wpisów w katalogu Kerberosa.
38
39%prep
40%setup -q -n mod_%{mod_name}-%{version}
41
42%build
43%configure \
44 %{?with_krb4:--with-krb4} \
45 %{!?with_krb4:--without-krb4} \
46 --with-apache=%{_prefix}
47
48%{__sed} -i -e 's/-pthread/-lpthread/' Makefile
49%{__make}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT{%{pkglibdir},%{pkgconfdir}}
54
55install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{pkglibdir}
56install %{SOURCE1} $RPM_BUILD_ROOT%{pkgconfdir}/20_mod_%{mod_name}.conf
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%service -q httpd restart
63
64%postun
65if [ "$1" = "0" ]; then
66 %service -q httpd restart
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc README
72%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{pkgconfdir}/*_mod_%{mod_name}.conf
73%attr(755,root,root) %{pkglibdir}/*.so
This page took 0.053337 seconds and 4 git commands to generate.