]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
- fix config dir
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define mod_name        auth_any
2 %define apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí shellových příkazů
5 Summary(da.UTF-8):      En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb.UTF-8):      En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl.UTF-8):      Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11 Summary(pt.UTF-8):      Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl.UTF-8):      Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv.UTF-8):      Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        1.6
16 Release:        0.rc1.1
17 Epoch:          1
18 License:        BSD
19 Group:          Networking/Daemons/HTTP
20 Source0:        http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}-rc1.tar.gz
21 # Source0-md5:  76a105e42fb82947c2c4243975a1b7f9
22 Patch0:         %{name}-conf.patch
23 URL:            http://www.itlab.musc.edu/webNIS/mod_auth_any.html
24 BuildRequires:  %{apxs}
25 BuildRequires:  apache-devel >= 2.0
26 BuildRequires:  rpmbuild(macros) >= 1.268
27 Requires:       apache(modules-api) = %apache_modules_api
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
31 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
32
33 %description
34 This module allows you to use any command line program (such as
35 webNIS) to authenticate a user.
36
37 %description -l cs.UTF-8
38 Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
39 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
40 jakéhokoliv příkazu (jeho návratovým kódem).
41
42 %description -l de.UTF-8
43 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
44 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
45 gegebenen arbiträren Befehls prüft.
46
47 %description -l es.UTF-8
48 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
49 desde un servidor web verificando el código de retorno de un comando
50 arbitrario especificado.
51
52 %description -l fr.UTF-8
53 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
54 servis par un serveur Web en vérifiant le code de retour d'une
55 commande spécifiée arbitraire.
56
57 %description -l it.UTF-8
58 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
59 serviti da un server Web controllando il codice di ritorno di un dato
60 comando arbitrario.
61
62 %description -l ja.UTF-8
63 Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
64 によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
65 ができます。
66
67 %description -l pl.UTF-8
68 Ten moduł pozwala na użycie dowolnego programu działającego z linii
69 poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
70
71 %description -l sv.UTF-8
72 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
73 servade av en webbserver genom att kontrollera returkoden från ett
74 godtyckligt angivet kommando.
75
76 %prep
77 %setup -q -n mod_%{mod_name}
78 %patch0 -p1
79
80 %build
81 %{__make} \
82         APXS2=/usr/sbin/apxs
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
87
88 install -p src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
89 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
90         $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 %service -q httpd restart
97
98 %postun
99 if [ "$1" = "0" ]; then
100         %service -q httpd restart
101 fi
102
103 %files
104 %defattr(644,root,root,755)
105 %doc docs/* TODO
106 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
107 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.066114 seconds and 3 git commands to generate.