]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blame - apache-mod_auth_any.spec
- fix config dir
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
CommitLineData
fd84993e 1%define mod_name auth_any
2%define apxs /usr/sbin/apxs
676fd2f3 3Summary: Basic authentication for the Apache Web server using arbitrary shell commands
66f119b7
ER
4Summary(cs.UTF-8): Základní autentizace pro WWW server Apache pomocí shellových příkazů
5Summary(da.UTF-8): En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6Summary(de.UTF-8): Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7Summary(fr.UTF-8): Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8Summary(it.UTF-8): Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9Summary(nb.UTF-8): En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10Summary(pl.UTF-8): Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11Summary(pt.UTF-8): Um módulo de autenticação de LDAP para o servidor Web Apache
12Summary(sl.UTF-8): Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13Summary(sv.UTF-8): Grundläggande autentisering för webbservern Apache med valfria skalkommandon
9ad9f9b8 14Name: apache-mod_%{mod_name}
4900a6b1
JR
15Version: 1.6
16Release: 0.rc1.1
fd84993e 17Epoch: 1
a0e413a1 18License: BSD
6f29f543 19Group: Networking/Daemons/HTTP
4900a6b1
JR
20Source0: http://www.itlab.musc.edu/webNIS/dist/mod_%{mod_name}-%{version}-rc1.tar.gz
21# Source0-md5: 76a105e42fb82947c2c4243975a1b7f9
22Patch0: %{name}-conf.patch
fd84993e 23URL: http://www.itlab.musc.edu/webNIS/mod_auth_any.html
1f8d6dd5 24BuildRequires: %{apxs}
3acb4a4e 25BuildRequires: apache-devel >= 2.0
f410416f 26BuildRequires: rpmbuild(macros) >= 1.268
3acb4a4e 27Requires: apache(modules-api) = %apache_modules_api
9ad9f9b8 28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
3acb4a4e 30%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
1c242323 31%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
9ad9f9b8 32
33%description
7b3a93d9
JB
34This module allows you to use any command line program (such as
35webNIS) to authenticate a user.
36
0a1583ef
JR
37%description -l cs.UTF-8
38Balíček mod_auth_any slouží pro omezení přístupu k dokumentům, které
39poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
40jakéhokoliv příkazu (jeho návratovým kódem).
676fd2f3 41
0a1583ef 42%description -l de.UTF-8
676fd2f3 43Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
0a1583ef
JR
44Server bediente Dokumente zu beschränken, indem es den Rückcode eines
45gegebenen arbiträren Befehls prüft.
676fd2f3 46
0a1583ef 47%description -l es.UTF-8
676fd2f3 48Mod_auth_any puede usarse para limitar el acceso a documentos servidos
0a1583ef 49desde un servidor web verificando el código de retorno de un comando
676fd2f3 50arbitrario especificado.
51
0a1583ef
JR
52%description -l fr.UTF-8
53Mod_auth_any peut être utilisé pour limiter l'accès à des documents
54servis par un serveur Web en vérifiant le code de retour d'une
55commande spécifiée arbitraire.
676fd2f3 56
0a1583ef
JR
57%description -l it.UTF-8
58Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
676fd2f3 59serviti da un server Web controllando il codice di ritorno di un dato
60comando arbitrario.
61
0a1583ef
JR
62%description -l ja.UTF-8
63Mod_auth_any は任意に指定されたコマンドの戻りコードをチェックすること
64によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
65ができます。
676fd2f3 66
0a1583ef
JR
67%description -l pl.UTF-8
68Ten moduł pozwala na użycie dowolnego programu działającego z linii
69poleceń (jak np. webNIS) do uwierzytelniania użytkownika.
9ad9f9b8 70
0a1583ef
JR
71%description -l sv.UTF-8
72Mod_auth_any kan användas för att begränsa åtkomsten till dokument
73servade av en webbserver genom att kontrollera returkoden från ett
676fd2f3 74godtyckligt angivet kommando.
75
76%prep
4900a6b1
JR
77%setup -q -n mod_%{mod_name}
78%patch0 -p1
b4a42275 79
9ad9f9b8 80%build
1c242323
ER
81%{__make} \
82 APXS2=/usr/sbin/apxs
9ad9f9b8 83
84%install
85rm -rf $RPM_BUILD_ROOT
1c242323 86install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
9ad9f9b8 87
1c242323 88install -p src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
3acb4a4e 89echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
1c242323 90 $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
7b3a93d9 91
7b3a93d9
JB
92%clean
93rm -rf $RPM_BUILD_ROOT
94
9ad9f9b8 95%post
f410416f 96%service -q httpd restart
9ad9f9b8 97
5b0017c1 98%postun
9ad9f9b8 99if [ "$1" = "0" ]; then
f410416f 100 %service -q httpd restart
9ad9f9b8 101fi
102
9ad9f9b8 103%files
104%defattr(644,root,root,755)
2025a67d 105%doc docs/* TODO
1c242323 106%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
c36b7c64 107%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.105875 seconds and 4 git commands to generate.