]> git.pld-linux.org Git - packages/apache-mod_annodex.git/blob - apache-mod_annodex.spec
- fix config dir
[packages/apache-mod_annodex.git] / apache-mod_annodex.spec
1 %define         apxs            /usr/sbin/apxs
2 Summary:        mod_annodex - full support for Annodex.net media for Apache
3 Summary(pl.UTF-8):      mod_annodex - pełna obsługa mediów Annodex.net dla Apache'a
4 Name:           apache-mod_annodex
5 Version:        0.2.2
6 Release:        1
7 License:        Apache v1.1
8 Group:          Networking/Daemons/HTTP
9 Source0:        http://www.annodex.net/software/mod_annodex/download/mod_annodex-ap20-%{version}.tar.gz
10 # Source0-md5:  54d3fd4237d7789206797eb0c6de9af2
11 URL:            http://www.annodex.net/software/mod_annodex/index.html
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache-devel >= 2.0
14 BuildRequires:  libannodex-devel
15 BuildRequires:  libcmml-devel
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires:       apache(modules-api) = %apache_modules_api
19 Requires:       apr >= 1:1.0.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
24
25 %description
26 mod_annodex is a handler for type application/x-annodex. It provides
27 the following features:
28  - dynamic generation of Annodex media from CMML files.
29  - handling of timed query offsets, such as
30         http://media.example.com/fish.anx?t=npt:01:20.8
31    or
32         http://media.example.com/fish.anx?id=Preparation
33  - dynamic retrieval of CMML summaries, if the Accept: header prefers
34    type text/x-cmml over application/x-annodex.
35
36 %description -l pl.UTF-8
37 mod_annodex to moduł obsługi dla typu application/x-annodex. Ma
38 następujące możliwości:
39  - dynamiczne generowanie mediów Annodex z plików CMML
40  - obsługę czasowych offsetów zapytań, takich jak
41         http://media.example.com/fish.anx?t=npt:01:20.8
42    albo
43         http://media.example.com/fish.anx?id=Preparation
44  - dynamiczne odtwarzanie podsumowań CMML, jeśli nagłówek Accept:
45    preferuje typ text/x-cmml ponad application/x-annodex
46
47 %prep
48 %setup -q -n mod_annodex-ap20-%{version}
49
50 # regenerate Makefile
51 %{apxs} -n annodex -g
52 mv -f annodex/Makefile .
53 rm -rf annodex
54
55 %build
56 %{__make} \
57         top_builddir=%{_pkglibdir} \
58         APXS=%{apxs} \
59         SH_LIBS=`pkg-config --libs annodex cmml`
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
64
65 install -p .libs/mod_annodex.so $RPM_BUILD_ROOT%{_pkglibdir}
66 cat annodex.load annodex.conf > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_annodex.conf
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 %service -q httpd restart
73
74 %postun
75 if [ "$1" = "0" ]; then
76         %service -q httpd restart
77 fi
78
79 %files
80 %defattr(644,root,root,755)
81 %doc LICENSE README
82 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/90_mod_annodex.conf
83 %attr(755,root,root) %{_pkglibdir}/mod_annodex.so
This page took 0.051547 seconds and 3 git commands to generate.