]> git.pld-linux.org Git - packages/apache-mod_annodex.git/blame - apache-mod_annodex.spec
- fix config dir
[packages/apache-mod_annodex.git] / apache-mod_annodex.spec
CommitLineData
b503c206
JB
1%define apxs /usr/sbin/apxs
2Summary: mod_annodex - full support for Annodex.net media for Apache
31fdee27 3Summary(pl.UTF-8): mod_annodex - pełna obsługa mediów Annodex.net dla Apache'a
b503c206
JB
4Name: apache-mod_annodex
5Version: 0.2.2
6Release: 1
7License: Apache v1.1
b52ca3f2 8Group: Networking/Daemons/HTTP
b503c206
JB
9Source0: http://www.annodex.net/software/mod_annodex/download/mod_annodex-ap20-%{version}.tar.gz
10# Source0-md5: 54d3fd4237d7789206797eb0c6de9af2
11URL: http://www.annodex.net/software/mod_annodex/index.html
689911ce 12BuildRequires: %{apxs}
b503c206
JB
13BuildRequires: apache-devel >= 2.0
14BuildRequires: libannodex-devel
15BuildRequires: libcmml-devel
16BuildRequires: pkgconfig
17BuildRequires: rpmbuild(macros) >= 1.268
18Requires: apache(modules-api) = %apache_modules_api
19Requires: apr >= 1:1.0.0
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
9cddf2d8 23%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
b503c206
JB
24
25%description
26mod_annodex is a handler for type application/x-annodex. It provides
27the following features:
28 - dynamic generation of Annodex media from CMML files.
29 - handling of timed query offsets, such as
30 http://media.example.com/fish.anx?t=npt:01:20.8
31 or
32 http://media.example.com/fish.anx?id=Preparation
33 - dynamic retrieval of CMML summaries, if the Accept: header prefers
34 type text/x-cmml over application/x-annodex.
35
3e9b969b
JR
36%description -l pl.UTF-8
37mod_annodex to moduł obsługi dla typu application/x-annodex. Ma
38następujące możliwości:
39 - dynamiczne generowanie mediów Annodex z plików CMML
40 - obsługę czasowych offsetów zapytań, takich jak
b503c206
JB
41 http://media.example.com/fish.anx?t=npt:01:20.8
42 albo
43 http://media.example.com/fish.anx?id=Preparation
3e9b969b 44 - dynamiczne odtwarzanie podsumowań CMML, jeśli nagłówek Accept:
b503c206
JB
45 preferuje typ text/x-cmml ponad application/x-annodex
46
47%prep
48%setup -q -n mod_annodex-ap20-%{version}
49
50# regenerate Makefile
51%{apxs} -n annodex -g
52mv -f annodex/Makefile .
53rm -rf annodex
54
55%build
56%{__make} \
57 top_builddir=%{_pkglibdir} \
58 APXS=%{apxs} \
59 SH_LIBS=`pkg-config --libs annodex cmml`
60
61%install
62rm -rf $RPM_BUILD_ROOT
9cddf2d8 63install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
b503c206 64
9cddf2d8
ER
65install -p .libs/mod_annodex.so $RPM_BUILD_ROOT%{_pkglibdir}
66cat annodex.load annodex.conf > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_annodex.conf
b503c206
JB
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post
72%service -q httpd restart
73
74%postun
75if [ "$1" = "0" ]; then
76 %service -q httpd restart
77fi
78
79%files
80%defattr(644,root,root,755)
81%doc LICENSE README
9cddf2d8 82%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/90_mod_annodex.conf
b503c206 83%attr(755,root,root) %{_pkglibdir}/mod_annodex.so
This page took 0.084126 seconds and 4 git commands to generate.