]> git.pld-linux.org Git - packages/anyterm.git/blame - anyterm.spec
- use apxs macro
[packages/anyterm.git] / anyterm.spec
CommitLineData
57ac7731 1%define apxs /usr/sbin/apxs
2Summary: Terminal emulator in a web browser
3Name: anyterm
4Version: 1.1.4
ecd95c79 5Release: 0.3
e1dd02cd 6Epoch: 0
57ac7731 7License: GPL
8Group: Networking/Daemons
9Source0: http://anyterm.org/download/%{name}-%{version}.tbz2
10# Source0-md5: cf841703b7438866e573f5a33137ff6f
8785aef2 11Patch0: %{name}-makefile.patch
57ac7731 12URL: http://anyterm.org/
13BuildRequires: apache-devel >= 2.0.52-2
14BuildRequires: apr-devel
15BuildRequires: rote-devel >= 0.2.8
ecd95c79 16BuildRequires: rpmbuild(macros) >= 1.228
57ac7731 17BuildRequires: %{apxs}
18Requires: apache >= 2.0.52-2
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
ecd95c79 21%define _appdir %{_datadir}/%{name}
8785aef2
ER
22%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23%define _sysconfdir /etc/httpd
57ac7731 24
25%description
26An apache module plus scripts to make a terminal within a web browser.
27
28%prep
29%setup -q
30%patch0 -p1
ecd95c79 31mv -f browser/.htaccess htaccess
57ac7731 32
33%build
34rm -rf $RPM_BUILD_ROOT
35cd apachemod
36%{__make} \
8785aef2 37 INCLUDES='-I%{_includedir}/apr-util' \
ecd95c79 38 APXS2=%{apxs} \
57ac7731 39 APR_CONFIG=apr-1-config
40cd ..
41cd anygetty
42%{__make}
43cd ..
44
45%install
46rm -rf $RPM_BUILD_ROOT
ecd95c79 47install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/httpd.conf,%{_pkglibdir},%{_mandir}/man8,%{_appdir}}
57ac7731 48
49cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_anyterm.conf <<END
50LoadModule anyterm modules/%{name}.so
ecd95c79
ER
51<IfModule anyterm>
52 Alias /%{name} "%{_appdir}"
53 anyterm_command '%{_sbindir}/anygetty --remotehost "Anyterm: %h"'
54
55 <Files anyterm-module>
56 SetHandler anyterm
57 </Files>
58</IfModule>
59# vim: filetype=apache ts=4 sw=4 et
57ac7731 60END
61
62install apachemod/.libs/%{name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{name}.so
ecd95c79 63cp -a browser/* $RPM_BUILD_ROOT%{_appdir}
57ac7731 64install anygetty/anygetty $RPM_BUILD_ROOT/%{_sbindir}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
ecd95c79
ER
69%post
70%service httpd restart
71
72%banner %{name} <<EOF
73For full function, setuid %{_sbindir}/anygetty.
74EOF
75
76%preun
77if [ "$1" = "0" ]; then
78 %service -q httpd restart
79fi
80
57ac7731 81%files
82%defattr(644,root,root,755)
ecd95c79 83%doc README htaccess
8785aef2 84%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*
57ac7731 85%attr(755,root,root) %{_pkglibdir}/%{name}.so
86%attr(755,root,root) %{_sbindir}/anygetty
ecd95c79 87%{_appdir}
This page took 0.094957 seconds and 4 git commands to generate.