]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- openssl support is gone, enable gnutls by default
[packages/anubis.git] / anubis.spec
1 #
2 # Conditional build:
3 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
4 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
5 %bcond_without  pam             # disable using of PAM authentication
6 %bcond_without  pcre            # disable using pcre library
7 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
8 %bcond_with     mysql           # enable MySQL support
9 %bcond_with     postgres        # enable PostgreSQL support
10 #
11 %include        /usr/lib/rpm/macros.perl
12 Summary:        An outgoing mail processor, and the SMTP tunnel
13 Summary(pl.UTF-8):      Procesor wychodzącej poczty i tunel SMTP
14 Name:           anubis
15 Version:        4.1
16 Release:        1
17 License:        GPL v3+
18 Group:          Applications/Mail
19 Source0:        http://ftp.gnu.org/gnu/anubis/%{name}-%{version}.tar.gz
20 # Source0-md5:  fbbf97ee8e973347e0412bfeef14aa6a
21 Source1:        %{name}.init
22 Source2:        %{name}.pamd
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-nolibnsl.patch
25 Patch2:         %{name}-pl.po-update.patch
26 URL:            http://www.gnu.org/software/anubis/
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.8.3
29 BuildRequires:  bison
30 BuildRequires:  gdbm-devel
31 BuildRequires:  gettext-tools >= 0.16
32 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
33 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:1.0.0}
34 BuildRequires:  gsasl-devel >= 0.2.3
35 BuildRequires:  guile-devel >= 5:1.8.0
36 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
37 %{?with_mysql:BuildRequires:    mysql-devel}
38 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
39 %{?with_pam:BuildRequires:      pam-devel}
40 BuildRequires:  pcre-devel
41 %{?with_postgres:BuildRequires: postgres-devel}
42 BuildRequires:  rpm-perlprov
43 BuildRequires:  rpmbuild(macros) >= 1.268
44 BuildRequires:  texinfo
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       identserver
47 Requires:       pam >= 0.77.3
48 Requires:       rc-scripts
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 GNU Anubis is an outgoing mail processor. It goes between the MUA
53 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
54 on the fly various sorts of processing and conversion on the outgoing
55 mail in accord with the sender's specified rules, based on a highly
56 configurable regular expressions system. It operates as a proxy
57 server, independently from mail user agents. GNU Anubis can edit
58 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
59 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
60 using the TLS/SSL encryption even if your mail user agent doesn't
61 support it, or tunnel a connection through a SOCKS proxy. Moreover,
62 GNU Anubis supports the remailers (it allows sending mail in an
63 anonymous way).
64
65 Remember, that to use per-user configuration files ident server has to
66 be running. Without it only system-wide configuration file is used.
67
68 If you want to use GNU Anubis with mutt mail client, install msg2smtp
69 package.
70
71 %description -l pl.UTF-8
72 GNU Anubis zajmuje się przetwarzaniem poczty wychodzącej. Znajduje się
73 on pomiędzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i może
74 wykonywać w locie różne rodzaje przetwarzania i konwersji poczty
75 wychodzącej zależnie od podanych reguł, bazujących na wysoce
76 konfigurowalnym systemie wyrażeń regularnych. GNU Anubis działa jako
77 serwer proxy, niezależnie od programów pocztowych. Potrafi on zmieniać
78 nagłówki listów, szyfrować lub podpisywać jest przy pomocy GNU Privacy
79 Guard, tworzyć bezpieczne tunele SMTP używając szyfrowania TLS/SSL
80 nawet, gdy Twój program pocztowy nie ma takich możliwości. Możliwe
81 jest też tunelowanie połączeń przez SOCKS proxy. Co więcej, GNU Anubis
82 wspiera także remailery (czyli pozawala na anonimowe wysyłanie
83 poczty).
84
85 Pamiętaj, że aby używać plików konfiguracyjnych użytkowników, serwer
86 ident musi być aktywny. Inaczej, użyty będzie tylko główny plik
87 konfiguracyjny.
88
89 Jeśli chcesz używać GNU Anubis z klientem poczty mutt, zainstaluj
90 pakiet msg2smtp.
91
92 %package -n msg2smtp
93 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
94 Summary(pl.UTF-8):      msg2smtp wysyła pocztę przyjmowaną na wejściu do serwera SMTP
95 Group:          Applications/Mail
96
97 %description -n msg2smtp
98 The msg2smtp script is a bridge between MUA programs which use
99 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
100 particularly useful when used in connection with GNU Anubis mail
101 processor.
102
103 %description -n msg2smtp -l pl.UTF-8
104 Skrypt msg2smtp jest pomostem między programami pocztowymi używającymi
105 polecenia "sendmail" do wysyłania listów (np. Mutt), a serwerem smtp.
106 Jest on szczególnie przydatny w połączeniu z procesorem poczty GNU
107 Anubis.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114
115 rm -f po/stamp-po
116
117 %build
118 %{__gettextize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__automake}
122 %configure \
123 %{!?with_gnutls:        --without-gnutls} \
124 %{!?with_gnutls:        --with-openssl} \
125 %{?with_pam:            --with-pam} \
126 %{?with_pcre:           --with-pcre} \
127 %{!?with_gpgme:         --without-gpgme} \
128 %{?with_mysql:          --with-mysql} \
129 %{?with_postgres:       --with-postgres} \
130 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
131         --disable-dependency-tracking
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
143 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
144 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
145 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
146 cp -f ./examples/1anubisrc examples/anubisrc
147
148 %find_lang %{name}
149 rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 /sbin/chkconfig --add anubis
156 %service anubis restart
157 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
158
159
160 %preun
161 if [ "$1" = "0" ]; then
162         %service anubis stop
163         /sbin/chkconfig --del anubis
164 fi
165
166 %postun -p      /sbin/postshell
167 -/usr/sbin/fix-info-dir -c %{_infodir}
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc %{?with_pam:examples/pam}
172 %attr(754,root,root) /etc/rc.d/init.d/anubis
173 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/anubisrc
174 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/anubis}
175 %attr(755,root,root) %{_bindir}/anubisusr
176 %attr(755,root,root) %{_sbindir}/anubis
177 %attr(755,root,root) %{_sbindir}/anubisadm
178 %{_datadir}/anubis
179 %{_mandir}/man1/anubis.1*
180 %{_infodir}/anubis.info*
181
182 %files -n msg2smtp
183 %defattr(644,root,root,755)
184 %doc contrib/msg2smtp.txt
185 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.081595 seconds and 3 git commands to generate.