]> git.pld-linux.org Git - packages/ant.git/blobdiff - ant.spec
- rel 2
[packages/ant.git] / ant.spec
index d70d9c3ebff57d7ed3c82b692bd078f376eb1313..f47290da2b3d23995ceb1367bbfc5f5271c9cce8 100644 (file)
--- a/ant.spec
+++ b/ant.spec
@@ -1,9 +1,13 @@
 # TODO
 # - prepare all BR and test the full build
-#   (TODO: stylebook, starteam, jai, jdepend, weblogic)
+#   TODO:
+#   - stylebook: http://svn.apache.org/viewcvs.cgi/xml/stylebook/
+#   - starteam: http://www.borland.com/downloads/download_starteam.html (30-day trial, needs registration)
+#   - weblogic: http://www.bea.com/ ? (needs registration)
 #
 # Conditional build:
 %bcond_with    bootstrap       # minimal build for bootstrap
+%bcond_with    nonfree         # build tasks with non-distributable dependencies
 %bcond_without antlr           # disable building antlr optional task(s)
 %bcond_without apache_bcel     # disable building apache-bcel optional task(s)
 %bcond_without apache_bsf      # disable building apache-bsf optional task(s)
 %bcond_without apache_resolver # disable building apache-resolver optional task(s)
 %bcond_without commons_logging # disable building commons-logging optional task(s)
 %bcond_without commons_net     # disable building commons-net optional task(s)
-%bcond_with    jai             # enable building jai optional task(s)
+%bcond_without jai             # disable building jai optional task(s)
 %bcond_without javamail        # disable building javamail optional task(s)
-%bcond_with    jdepend         # enable building jdepend optional task(s)
+%bcond_without jdepend         # disable building jdepend optional task(s)
 %bcond_without jsch            # disable building jsch optional task(s)
 %bcond_without junit           # disable building junit optional task(s)
 %bcond_without netrexx         # disable building netrexx optional taks(s)
 #
+%if %{without nonfree}
+%undefine      with_jai
+%endif
 %if %{with bootstrap}
 %undefine      with_antlr
 %undefine      with_apache_bcel
 %undefine      with_apache_resolver
 %undefine      with_commons_logging
 %undefine      with_commons_net
+%undefine      with_jai
 %undefine      with_javamail
+%undefine      with_jdepend
 %undefine      with_jsch
 %undefine      with_netrexx
 %endif
 #
-%define                _rel    0.1
+%define                _rel    2
 Summary:       Ant build tool for Java
 Summary(fr.UTF-8):     Outil de compilation pour java
 Summary(it.UTF-8):     Tool per la compilazione di programmi java
 Summary(pl.UTF-8):     Ant - narzÄ™dzie do budowania w Javie
 Name:          ant
 Version:       1.7.0
-Release:       %{?with_bootstrap:bootstrap.}%{_rel}
+Release:       %{_rel}%{?with_bootstrap:.bootstrap}
 License:       Apache
 Group:         Development/Languages/Java
 Source0:       http://www.apache.org/dist/ant/source/apache-%{name}-%{version}-src.tar.bz2
@@ -59,8 +68,10 @@ URL:         http://ant.apache.org/
 %{?with_commons_net:BuildRequires:     jakarta-commons-net}
 %{?with_apache_oro:BuildRequires:      jakarta-oro}
 %{?with_apache_regexp:BuildRequires:   jakarta-regexp}
+%{?with_jai:BuildRequires:     jai}
 %{?with_javamail:BuildRequires:        javamail}
 BuildRequires: jaxp_parser_impl
+%{?with_jdepend:BuildRequires: jdepend}
 BuildRequires: jdk
 BuildRequires: jpackage-utils
 %{?with_jsch:BuildRequires:    jsch >= 0.1.21}
@@ -537,7 +548,7 @@ required_jars="jaxp_parser_impl"
 %{?with_apache_resolver:required_jars="$required_jars resolver"}
 %{?with_commons_logging:required_jars="$required_jars commons-logging"}
 %{?with_commons_net:required_jars="$required_jars commons-net"}
-%{?with_jai:required_jars="$required_jars jait"}
+%{?with_jai:required_jars="$required_jars jai_core jai_codec"}
 %{?with_apache_bcel:required_jars="$required_jars bcel"}
 %{?with_apache_log4j:required_jars="$required_jars log4j"}
 %{?with_apache_oro:required_jars="$required_jars oro"}
This page took 0.126046 seconds and 4 git commands to generate.