]> git.pld-linux.org Git - packages/ant.git/blobdiff - ant.spec
- rel 8
[packages/ant.git] / ant.spec
index e050df85687fa4aa511079b864536205ddcf3067..5ff30d57b4130d92e41c12523a4c6a371eec94c5 100644 (file)
--- a/ant.spec
+++ b/ant.spec
@@ -1,4 +1,5 @@
 # TODO
+# - review config files in /etc/ant.d. Something seems to be broken there.
 # - prepare all BR and test the full build
 #   TODO:
 #   - stylebook: http://svn.apache.org/viewcvs.cgi/xml/stylebook/
@@ -23,7 +24,7 @@
 %bcond_without jsch            # disable building jsch optional task(s)
 %bcond_without junit           # disable building junit optional task(s)
 %bcond_without netrexx         # disable building netrexx optional taks(s)
-#
+
 %if %{without nonfree}
 %undefine      with_jai
 %endif
 %undefine      with_jsch
 %undefine      with_netrexx
 %endif
-#
-%define                _rel    4
+
+%include       /usr/lib/rpm/macros.java
+
+%define                _rel    8
 Summary:       Ant build tool for Java
 Summary(fr.UTF-8):     Outil de compilation pour java
 Summary(it.UTF-8):     Tool per la compilazione di programmi java
 Summary(pl.UTF-8):     Ant - narzÄ™dzie do budowania w Javie
 Name:          ant
 Version:       1.7.1
-Release:       %{_rel}%{?with_bootstrap:.bootstrap}
+Release:       %{bootstrap_release %_rel}
 License:       Apache
 Group:         Development/Languages/Java
 Source0:       http://www.apache.org/dist/ant/source/apache-%{name}-%{version}-src.tar.bz2
@@ -62,29 +65,32 @@ Patch0:             %{name}-antRun.patch
 # next release of ant.
 Patch1:                %{name}-gcjtask.patch
 URL:           http://ant.apache.org/
+%{!?with_bootstrap:BuildRequires:      ant}
 %{?with_antlr:BuildRequires:   antlr}
-%{?with_apache_bsf:BuildRequires:      beanshell}
-%{?with_apache_bsf:BuildRequires:      bsf}
-%{?with_javamail:BuildRequires:        jaf}
-%{?with_jai:BuildRequires:     jai}
-%{?with_apache_bcel:BuildRequires:     jakarta-bcel}
-%{?with_commons_logging:BuildRequires: jakarta-commons-logging}
-%{?with_commons_net:BuildRequires:     jakarta-commons-net}
-%{?with_apache_oro:BuildRequires:      jakarta-oro}
-%{?with_apache_regexp:BuildRequires:   jakarta-regexp}
-BuildRequires: java-gcj-compat-devel
+%{?with_javamail:BuildRequires:        java(jaf)}
+%{?with_jai:BuildRequires:     java(jai)}
+%{?with_javamail:BuildRequires:        java(javamail)}
+%{?with_apache_bsf:BuildRequires:      java-beanshell}
+%{?with_apache_bcel:BuildRequires:     java-bcel}
+%{?with_apache_bsf:BuildRequires:      java-bsf}
+%{?with_commons_logging:BuildRequires: java-commons-logging}
+%{?with_commons_net:BuildRequires:     java-commons-net1}
+%{?with_jdepend:BuildRequires: java-jdepend}
+%{?with_netrexx:BuildRequires: java-netrexx}
+%{?with_apache_oro:BuildRequires:      java-oro}
+%{?with_apache_regexp:BuildRequires:   java-regexp}
+%{?with_jsch:BuildRequires:    java-jsch >= 0.1.21}
+BuildRequires: java-xerces
 %{?with_apache_resolver:BuildRequires: java-xml-commons-resolver}
-%{?with_javamail:BuildRequires:        javamail}
-%{?with_jdepend:BuildRequires: jdepend}
+BuildRequires: jdk
 BuildRequires: jpackage-utils
-%{?with_jsch:BuildRequires:    jsch >= 0.1.21}
 %{?with_junit:BuildRequires:   junit}
 %{?with_apache_bsf:BuildRequires:      jython}
-%{?with_apache_log4j:BuildRequires:    logging-log4j >= 1.2}
-%{?with_netrexx:BuildRequires: netrexx}
+%{?with_apache_log4j:BuildRequires:    java-log4j >= 1.2}
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpm-javaprov
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.300
-BuildRequires: xerces-j
 Requires:      jpackage-utils
 Obsoletes:     jakarta-ant
 BuildArch:     noarch
@@ -174,7 +180,7 @@ Summary(fr.UTF-8):  Taches apache log4j optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache log4j dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      logging-log4j >= 1.2
+Requires:      java-log4j >= 1.2
 Provides:      ant-jakarta-log4j = %{version}-%{release}
 Obsoletes:     ant-jakarta-log4j
 Conflicts:     ant-optional-clean
@@ -195,7 +201,7 @@ Summary(fr.UTF-8):  Taches apache oro optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache oro dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-oro
+Requires:      java-oro
 Provides:      ant-jakarta-oro = %{version}-%{release}
 Obsoletes:     ant-jakarta-oro
 Conflicts:     ant-optional-clean
@@ -216,7 +222,7 @@ Summary(fr.UTF-8):  Taches apache regexp optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache regexp dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-regexp
+Requires:      java-regexp
 Obsoletes:     ant-jakarta-regexp
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
@@ -236,7 +242,7 @@ Summary(fr.UTF-8):  Taches apache resolver optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache resolver dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      xml-commons-resolver
+Requires:      java-xml-commons-resolver
 Provides:      ant-apache-resolver = %{version}-%{release}
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
@@ -272,7 +278,7 @@ Summary(fr.UTF-8):  Taches commons net optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania commons net dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-commons-net
+Requires:      java-commons-net1
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
 
@@ -310,8 +316,8 @@ Summary(fr.UTF-8):  Taches javamail optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania javamail dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jaf
-Requires:      javamail >= 1.2
+Requires:      java(jaf)
+Requires:      java(javamail) >= 1.2
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
 
@@ -479,10 +485,10 @@ Summary:  Additional scripts for %{name}
 Summary(fr.UTF-8):     Scripts additionels pour %{name}
 Summary(pl.UTF-8):     Dodatkowe skrypty dla anta
 Group:         Development/Languages/Java
-AutoReqProv:   no
 Requires:      %{name} = %{version}-%{release}
 Requires:      /usr/bin/perl
 Requires:      /usr/bin/python
+AutoReqProv:   no
 
 %description scripts
 Additional Perl and Python scripts for %{name}.
@@ -552,13 +558,13 @@ required_jars="jaxp_parser_impl"
 %{?with_apache_bsf:required_jars="$required_jars bsf jython bsh"}
 %{?with_apache_resolver:required_jars="$required_jars resolver"}
 %{?with_commons_logging:required_jars="$required_jars commons-logging"}
-%{?with_commons_net:required_jars="$required_jars commons-net"}
+%{?with_commons_net:required_jars="$required_jars commons-net1"}
 %{?with_jai:required_jars="$required_jars jai_core jai_codec"}
 %{?with_apache_bcel:required_jars="$required_jars bcel"}
 %{?with_apache_log4j:required_jars="$required_jars log4j"}
 %{?with_apache_oro:required_jars="$required_jars oro"}
 %{?with_apache_regexp:required_jars="$required_jars regexp"}
-%{?with_javamail:required_jars="$required_jars mailapi activation"}
+%{?with_javamail:required_jars="$required_jars mail activation"}
 %{?with_jdepend:required_jars="$required_jars jdepend"}
 %{?with_jsch:required_jars="$required_jars jsch"}
 %{?with_netrexx:required_jars="$required_jars NetRexxC"}
@@ -618,17 +624,17 @@ echo "bsf ant/ant-apache-bsf" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-b
 
 %if %{with apache_resolver}
 install build/lib/%{name}-apache-resolver.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-apache-resolver-%{version}.jar
-echo "xml-commons-resolver ant/ant-apache-resolver" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-resolver
+echo "resolver ant/ant-apache-resolver" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-resolver
 %endif
 
 %if %{with commons_logging}
 install build/lib/%{name}-commons-logging.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-commons-logging-%{version}.jar
-echo "jakarta-commons-logging ant/ant-commons-logging" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-logging
+echo "commons-logging ant/ant-commons-logging" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-logging
 %endif
 
 %if %{with commons_net}
 install build/lib/%{name}-commons-net.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-commons-net-%{version}.jar
-echo "jakarta-commons-net ant/ant-commons-net" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-net
+echo "commons-net1 ant/ant-commons-net" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-net
 %endif
 
 %if %{with jai}
@@ -664,7 +670,7 @@ ln -sf %{name}-apache-regexp.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-jaka
 
 %if %{with javamail}
 install build/lib/%{name}-javamail.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-javamail-%{version}.jar
-echo "javamail/mailapi jaf ant/ant-javamail" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/javamail
+echo "mail jaf ant/ant-javamail" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/javamail
 %endif
 
 %if %{with jdepend}
This page took 0.058776 seconds and 4 git commands to generate.