]> git.pld-linux.org Git - packages/angst.git/commitdiff
- patch fixing no DESTDIR in makefile
authorleafnode <leafnode@pld-linux.org>
Tue, 10 Aug 2004 11:17:10 +0000 (11:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- patch fixing libnet names

Changed files:
    angst-DESTDIR.patch -> 1.1
    angst-libnet.patch -> 1.1

angst-DESTDIR.patch [new file with mode: 0644]
angst-libnet.patch [new file with mode: 0644]

diff --git a/angst-DESTDIR.patch b/angst-DESTDIR.patch
new file mode 100644 (file)
index 0000000..a353cfa
--- /dev/null
@@ -0,0 +1,30 @@
+diff -uNr angst-0.4b-orig/Makefile.linux angst-0.4b/Makefile.linux
+--- angst-0.4b-orig/Makefile.linux     2001-02-08 14:44:12.000000000 +0100
++++ angst-0.4b/Makefile.linux  2004-08-10 13:15:04.495042704 +0200
+@@ -6,9 +6,6 @@
+ # $Id$
+ CC = gcc
+-INSTALL_DIR = /usr/bin/install -c -o root -g bin
+-INSTALL_SBIN = /usr/bin/install -c -s -o root -g bin -m 555
+-INSTALL_MAN = /usr/bin/install -c -o root -g bin -m 444
+ CFLAGS = -O2 -Wall
+ INCLUDE = -I/usr/local/include
+ LIBS = -L/usr/local/lib `libnet-config --libs` -lpcap
+@@ -27,12 +24,10 @@
+       rm -f angst *.o missing/*.o *.core core
+ install:
+-      $(INSTALL_DIR) -d /usr/local/sbin
+-      rm -f /usr/local/sbin/angst
+-      $(INSTALL_SBIN) -m 550 angst /usr/local/sbin
+-      $(INSTALL_DIR) -d /usr/local/man/man8
+-      rm -f /usr/local/man/man8/angst.8
+-      $(INSTALL_MAN) angst.8 /usr/local/man/man8
++      install -d $(DESTDIR)/usr/sbin
++      install -m 550 angst $(DESTDIR)/usr/sbin
++      install -d $(DESTDIR)/usr/share/man/man8
++      install angst.8 $(DESTDIR)/usr/share/man/man8
+ uninstall:
+       rm -f /usr/local/sbin/angst
diff --git a/angst-libnet.patch b/angst-libnet.patch
new file mode 100644 (file)
index 0000000..8f115ce
--- /dev/null
@@ -0,0 +1,28 @@
+diff -uNr angst-0.4b-orig/angst.h angst-0.4b/angst.h
+--- angst-0.4b-orig/angst.h    2001-02-05 04:22:57.000000000 +0100
++++ angst-0.4b/angst.h 2004-08-10 13:12:18.946209952 +0200
+@@ -9,7 +9,7 @@
+ #include <stdarg.h>
+ #include <sys/param.h>
+ #include <sys/sysctl.h>
+-#include <libnet.h>
++#include <libnet1.h>
+ #include <pcap.h>
+ /* the default bpf program expression, if you change it and you want
+diff -uNr angst-0.4b-orig/Makefile.linux angst-0.4b/Makefile.linux
+--- angst-0.4b-orig/Makefile.linux     2004-08-10 13:11:16.488704000 +0200
++++ angst-0.4b/Makefile.linux  2004-08-10 13:11:48.827788648 +0200
+@@ -10,9 +10,9 @@
+ INSTALL_SBIN = /usr/bin/install -c -s -o root -g bin -m 555
+ INSTALL_MAN = /usr/bin/install -c -o root -g bin -m 444
+ CFLAGS = -O2 -Wall
+-INCLUDE = -I/usr/local/include
+-LIBS = -L/usr/local/lib `libnet-config --libs` -lpcap
+-DEFINE = `libnet-config --defines` -DLINUX #-DDEBUG
++INCLUDE = -I/usr/include
++LIBS = -L/usr/lib `libnet1-config --libs` -lpcap
++DEFINE = `libnet1-config --defines` -DLINUX #-DDEBUG
+ OBJS = main.o active.o enable.o help.o host.o pcap.o signal.o util.o missing/strlcat.o missing/strlcpy.o
+ .c.o:
This page took 0.076246 seconds and 4 git commands to generate.