]> git.pld-linux.org Git - packages/anacron.git/blobdiff - anacron.spec
- added using %%{rpmcflags} macro.
[packages/anacron.git] / anacron.spec
index 39133ea8f51c39faeabe9a61327bc4f6f35f5eeb..b7f214f879c0ccca4565d930e3d92102117a3dc5 100644 (file)
@@ -1,57 +1,63 @@
-Summary:       A cron-like program that can run jobs lost during downtime.
-Summary(pl):   Wersja crona z mo¿liwo¶ci± uruchamiania zapomnianych procesów.
+Summary:       A cron-like program that can run jobs lost during downtime
+Summary(pl):   Wersja crona z mo¿liwo¶ci± uruchamiania zapomnianych procesów
 Name:          anacron
-Version:       2.1
-Release:       6
+Version:       2.3
+Release:       16
 License:       GPL
-Group:         System Environment/Base
-Source0:       %{name}-%{version}.tar.bz2
-Source1:       anacrontab
-Source2:       anacron.init
+Group:         Daemons
+Group(de):     Server
+Group(pl):     Serwery
+Source0:       http://download.sourceforge.net/anacron/%{name}-%{version}.tar.gz
+Source1:       %{name}tab
+Source2:       %{name}.init
+URL:           http://anacron.sourceforge.net/
 Requires:      /bin/sh
 Prereq:                /sbin/chkconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Anacron (like `anac(h)ronistic') is a periodic command scheduler. It
-executes commands at intervals specified in days. Unlike cron, it does not
-assume that the system is running continuously. It can therefore be used to
-control the execution of daily, weekly and monthly jobs (or anything with a
-period of n days), on systems that don't run 24 hours a day. When installed
-and configured properly, Anacron will make sure that the commands are run
-at the specified intervals as closely as machine-uptime permits.
-
-This package is pre-configured to execute the daily jobs of the Red Hat
-Linux system. You should install this program if your system isn't powered
-on 24 hours a day to make sure the maintenance jobs of other Red Hat Linux
-packages are executed each day.
+executes commands at intervals specified in days. Unlike cron, it does
+not assume that the system is running continuously. It can therefore
+be used to control the execution of daily, weekly and monthly jobs (or
+anything with a period of n days), on systems that don't run 24 hours
+a day. When installed and configured properly, Anacron will make sure
+that the commands are run at the specified intervals as closely as
+machine-uptime permits.
+
+This package is pre-configured to execute the daily jobs of the Red
+Hat Linux system. You should install this program if your system isn't
+powered on 24 hours a day to make sure the maintenance jobs of other
+Red Hat Linux packages are executed each day.
 
 %description -l pl
-cron to standardowy unixowy program, okresowo uruchamiaj±cy zadane przez
-u¿ytkowników programy. anacron jest wersj± crona umo¿liwiaj±c± uruchamianie
-procesów które normalnie by siê nie wykona³y z powodu wy³±czenia maszyny.
-Jest to doskona³e rozwi±zanie dla komputerów domowych które nie s± w³±czone
-24h na dobê. Uwaga - anacron nie zastêpuje crona a jedynie go wspomaga! Nie
-ma mo¿liwo¶ci uruchamiania procesów np co godzinê
+cron to standardowy unixowy program, okresowo uruchamiaj±cy zadane
+przez u¿ytkowników programy. anacron jest wersj± crona umo¿liwiaj±c±
+uruchamianie procesów które normalnie by siê nie wykona³y na przyk³ad
+z powodu wy³±czenia maszyny. Jest to doskona³e rozwi±zanie dla
+komputerów domowych które nie s± w³±czone 24h na dobê. Uwaga - anacron
+nie zastêpuje crona a jedynie go wspomaga! Nie ma na przyk³ad
+mo¿liwo¶ci uruchamiania procesów np co godzinê.
 
 %prep
 %setup -q
 
 %build
-make CFLAGS="$RPM_OPT_FLAGS"
+%{__make} CFLAGS="%{rpmcflags}"
 
 %install
-install -d $RPM_BUILD_ROOT/{etc/,usr/sbin/,usr/share/man/man5,usr/share/man/man8/}
-install -d $RPM_BUILD_ROOT/var/spool/anacron/
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},%{_mandir}/man{5,8}} \
+       $RPM_BUILD_ROOT/{var/spool/anacron,etc/rc.d/init.d}
 
-#
 install anacron $RPM_BUILD_ROOT%{_sbindir}
 install anacron.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 install anacrontab.5 $RPM_BUILD_ROOT%{_mandir}/man5/
-install %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
-for i in cron.daily cron.weekly cron.monthly;do
-install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/$i/
+for i in cron.daily cron.weekly cron.monthly; do
+install  -d $RPM_BUILD_ROOT%{_sysconfdir}/$i/
 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/$i/0anacron
 #!/bin/sh
 #
@@ -68,30 +74,37 @@ anacron -u $i
 EOF
 done
 
-strip $RPM_BUILD_ROOT/%{_sbindir}/anacron
-
-install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/
-install $RPM_SOURCE_DIR/anacron.init $RPM_BUILD_ROOT/etc/rc.d/init.d/anacron
+gzip -9nf ChangeLog README TODO
 
 %post
 /sbin/chkconfig --add anacron
 
+if [ -f /var/lock/subsys/anacron ]; then
+       /etc/rc.d/init.d/anacron restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/anacron start\" to start Anacron daemon."
+fi
+
 %preun
 /sbin/chkconfig --del anacron
+if [ "$1" = "0" ];then
+       if [ -f /var/lock/subsys/anacron ]; then
+               /etc/rc.d/init.d/anacron stop >&2
+       fi
+       /sbin/chkconfig --del anacron
+fi
 
 %clean 
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING NEWS README
+%doc ChangeLog* COPYING* README* TODO*
+%attr(755,root,root) %{_sbindir}/anacron
+%attr(754,root,root) /etc/rc.d/init.d/*
 %config %{_sysconfdir}/anacrontab
 %dir /var/spool/anacron/
-%{_mandir}/man5/*
-%{_mandir}/man8/*
-%defattr(755,root,root,755)
-%config /etc/rc.d/init.d/*
-%attr(755,root,root) %{_sbindir}/anacron
 %config %{_sysconfdir}/cron.daily/0anacron
 %config %{_sysconfdir}/cron.monthly/0anacron
 %config %{_sysconfdir}/cron.weekly/0anacron
+%{_mandir}/man[58]/*
This page took 0.058388 seconds and 4 git commands to generate.