]> git.pld-linux.org Git - packages/anacron.git/blob - anacron.spec
75c5c4673edfd9586c45d35acbac69860a2191a1
[packages/anacron.git] / anacron.spec
1 Summary:        A cron-like program that can run jobs lost during downtime
2 Summary(pl):    Wersja crona z mo¿liwo¶ci± uruchamiania zapomnianych procesów
3 Summary(pt_BR): Auxiliar do cron para máquinas que não ficam ligadas o tempo todo
4 Name:           anacron
5 Version:        2.3
6 Release:        21
7 License:        GPL
8 Group:          Daemons
9 Source0:        http://download.sourceforge.net/anacron/%{name}-%{version}.tar.gz
10 Source1:        %{name}tab
11 Source2:        %{name}.init
12 Patch0:         %{name}-SIGTERM.patch
13 Patch1:         %{name}-sendmail.patch
14 URL:            http://anacron.sourceforge.net/
15 Requires:       /usr/lib/sendmail
16 Prereq:         /sbin/chkconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Anacron (like `anac(h)ronistic') is a periodic command scheduler. It
21 executes commands at intervals specified in days. Unlike cron, it does
22 not assume that the system is running continuously. It can therefore
23 be used to control the execution of daily, weekly and monthly jobs (or
24 anything with a period of n days), on systems that don't run 24 hours
25 a day. When installed and configured properly, Anacron will make sure
26 that the commands are run at the specified intervals as closely as
27 machine-uptime permits.
28
29 This package is pre-configured to execute the daily jobs of the PLD
30 Linux system. You should install this program if your system isn't
31 powered on 24 hours a day to make sure the maintenance jobs of other
32 Red Hat Linux packages are executed each day.
33
34 %description -l pl
35 Anacron (od ,,anac(h)ronistic'') zajmuje siê okresowym wykonywaniem
36 poleceñ. Wykonuje je w odstêpachê bêd±cych wielokrotno¶ci± dni. W
37 przeciwieñstwie do crona nie zak³ada, ¿e system dzia³a 24 godziny na
38 dobê. Dziêki temu mo¿e byæ u¿ywany do wykonywania codziennych,
39 cotygodniowych i comiesiêcznych (lub innych powtarzaj±cych siê co ile¶
40 dni) zadañ w systemach, które nie s± w³±czone non-stop. Zainstalowany
41 i poprawnie skonfigurowany Anacron zapewni wykonywanie zleconych zadañ
42 tak blisko wyznaczonych terminów, jak tylko mo¿liwe.
43
44 Ten pakiet zosta³ wstêpnie skonfigurowany do dzia³ania w systemie PLD
45 Linux. Powiniene¶ zainstalowaæ ten program na systemach, które nie s±
46 w³±czone non-stop aby zapewniæ uruchamianie ró¿nych zadañ
47 utrzymuj±cych system we w³a¶ciwych odstêpach czasu.
48
49 %description -l pt_BR
50 Anacron é uma agenda para marcar a execução de comandos em horários
51 programados. Ao contrário do cron, o anacron não requer que o sistema
52 esteja rodando continuamente, podendo ser executado em sistemas que
53 não estão ligados 24 horas por dia.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59
60 %build
61 %{__make} CFLAGS="%{rpmcflags}"
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},%{_mandir}/man{5,8}} \
66         $RPM_BUILD_ROOT/{var/spool/anacron,etc/rc.d/init.d}
67
68 install anacron $RPM_BUILD_ROOT%{_sbindir}
69 install anacron.8 $RPM_BUILD_ROOT%{_mandir}/man8/
70 install anacrontab.5 $RPM_BUILD_ROOT%{_mandir}/man5/
71 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
72 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
73
74 for i in cron.daily cron.weekly cron.monthly; do
75 install  -d $RPM_BUILD_ROOT%{_sysconfdir}/$i/
76 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/$i/0anacron
77 #!/bin/sh
78 #
79 # anacron's cron script
80 #
81 # This script updates anacron time stamps. It is called through run-parts
82 # either by anacron itself or by cron.
83 #
84 # The script is called "0anacron" to assure that it will be executed
85 # _before_ all other scripts.
86
87 anacron -u $i
88
89 EOF
90 done
91
92 gzip -9nf ChangeLog README TODO
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 /sbin/chkconfig --add anacron
99
100 if [ -f /var/lock/subsys/anacron ]; then
101         /etc/rc.d/init.d/anacron restart >&2
102 else
103         echo "Run \"/etc/rc.d/init.d/anacron start\" to start Anacron daemon."
104 fi
105
106 %preun
107 if [ "$1" = "0" ];then
108         if [ -f /var/lock/subsys/anacron ]; then
109                 /etc/rc.d/init.d/anacron stop >&2
110         fi
111         /sbin/chkconfig --del anacron
112 fi
113
114 %files
115 %defattr(644,root,root,755)
116 %doc ChangeLog* README* TODO*
117 %attr(755,root,root) %{_sbindir}/anacron
118 %attr(754,root,root) /etc/rc.d/init.d/*
119 %config %{_sysconfdir}/anacrontab
120 %dir /var/spool/anacron/
121 %config %{_sysconfdir}/cron.daily/0anacron
122 %config %{_sysconfdir}/cron.monthly/0anacron
123 %config %{_sysconfdir}/cron.weekly/0anacron
124 %{_mandir}/man[58]/*
This page took 0.032625 seconds and 2 git commands to generate.