]> git.pld-linux.org Git - packages/anaconda.git/blobdiff - anaconda.spec
- enable system-logs for GUI
[packages/anaconda.git] / anaconda.spec
index 1c3669e1502eaefa428d81dcad3927830eaa2a3f..2020ccccf3683483021a9232ef4fa8c3226f4cc9 100644 (file)
@@ -1,5 +1,28 @@
 # TODO
 # - kill /mnt/runtime symlink hacks (leave the host alone!)
+# - 01:20:59 ERROR   : lokkit run failed: /usr/sbin/lokkit can not be run
+# - lrwxrwxrwx  1 root root     11 Aug 31 04:21 menu.lst -> ./grub.conf (DEAD LINK)
+#   -rw-r--r--  1 root root    551 Aug 31 04:21 menu.lst.rpmsave
+# - can't find font latcyrheb
+#  LANG="en_US.UTF-8"
+#  SYSFONT="latarcyrheb-sun16"
+# - sysconfig/timezone
+# - yuminstaller downloads all packages twice
+#  1156976072.958    317 192.168.2.3 TCP_MISS/200 209182 GET http://distrib/pld/dists/ac/PLD/i686/PLD/RPMS/sed-4.1.5-2.i686.rpm - DIRECT/x.x.x.x application/x-rpm
+#  1156976073.808    701 192.168.2.3 TCP_HIT/200 209188 GET http://distrib/pld/dists/ac/PLD/i686/PLD/RPMS/sed-4.1.5-2.i686.rpm - NONE/- application/x-rpm
+# - network config files are not pld-style
+# - lvm2-initrd should be installed
+# - /etc/fstab
+# - /etc/modprobe.conf for geninitrd
+# - gui installer packages selector:
+#Traceback (most recent call last):
+#  File "/home/glen/tmp/anaconda-11.0.5-root-glen//usr/lib/anaconda/gui.py", line 954, in nextClicked
+#  File "/home/glen/tmp/anaconda-11.0.5-root-glen//usr/lib/anaconda/gui.py", line 1313, in setScreen
+#  File "/home/glen/tmp/anaconda-11.0.5-root-glen//usr/lib/anaconda/iw/package_gui.py", line 29, in getScreen
+#  File "/usr/share/python2.4/site-packages/pirut/GroupSelector.py", line 410, in doRefresh
+#  File "/usr/share/python2.4/site-packages/pirut/GroupSelector.py", line 407, in populateCategories
+#TypeError: iter should be a GtkTreeIter
+# - definition of anaconda pixmaps: http://www.raimokoski.com/lineox/Distro-definition-dir.txt
 #
 %if 0
 # FC to PLD deps replace rules, extracted from cvs logs
@@ -17,7 +40,7 @@ Summary:      Graphical system installer
 Summary(pl):   Graficzny instalator systemu
 Name:          anaconda
 Version:       11.0.5
-Release:       0.78
+Release:       0.95
 License:       GPL
 Group:         Applications/System
 Source0:       %{name}-%{version}.tar.bz2
@@ -44,6 +67,7 @@ Patch11:      %{name}-branding.patch
 Patch12:       %{name}-x11.patch
 Patch13:       %{name}-installclasses.patch
 Patch14:       %{name}-release_notes_viewer_gui.patch
+Patch15:       %{name}-hosttree.patch
 URL:           http://fedora.redhat.com/projects/anaconda-installer/
 BuildRequires: bzip2-devel
 BuildRequires: device-mapper-static >= 1.01.05
@@ -73,7 +97,7 @@ Requires:     glibc-localedb-all
 Requires:      grubby
 Requires:      hfsutils
 Requires:      jfsutils
-Requires:      kudzu > 1.2.0
+Requires:      kudzu >= 1.2.34.3-1.1
 Requires:      lvm2
 Requires:      mdadm
 Requires:      python-booty >= 0.71-0.6
@@ -81,7 +105,7 @@ Requires:    python-devel-tools
 Requires:      python-kickstart
 Requires:      python-libxml2
 Requires:      python-parted
-Requires:      python-rhpl >= 0.176-1.1
+Requires:      python-rhpl >= 0.176-1.2
 Requires:      python-rpm >= 4.2-0.61
 Requires:      python-snack
 Requires:      python-urlgrabber >= 2.9.8
@@ -111,11 +135,12 @@ Requires: X11-Xserver
 Requires:      X11-fonts
 Requires:      pirut
 Requires:      python-gnome-canvas
+Requires:      system-config-date
 Requires:      system-config-keyboard
-#Requires:     system-logos
+Requires:      system-logos
 Requires:      vnc-utils
 %ifnarch s390 s390x ppc64
-Requires:      python-rhpxl >= 0.18-0.6
+Requires:      python-rhpxl >= 0.18-0.9
 %endif
 
 %description gui
@@ -182,6 +207,7 @@ Kod 
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 rm -f po/no.po
 mv -f po/{eu_ES,eu}.po
@@ -197,8 +223,8 @@ sed -i -e 's/$(PYTHON) scripts/python scripts/' Makefile
 %build
 # locale check
 if [ "$(locale -a | grep -c en_US.utf8)" = 0 ]; then
-       echo >&2 "en_US.utf8 locale not available. build will fail!"
-       echo >&2 "Install glibc-localedb-all or compile it!"
+       : "en_US.utf8 locale not available. build will fail!"
+       : "Install glibc-localedb-all or compile it!"
        exit 1
 fi
 
@@ -226,6 +252,17 @@ cp %{SOURCE3} $RPM_BUILD_ROOT%{_libdir}/anaconda-runtime/mk-images.i386
 cp %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/anaconda-runtime/scrubtree
 cp %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/anaconda/splash.png
 
+# for ./isys/lang.c:isysLoadKeymap()
+%ifarch %{ix86}
+cp -a loader2/keymaps-i386 $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
+%endif
+%ifarch ppc
+cp -a loader2/keymaps-ppc $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
+%endif
+%ifarch %{x8664}
+cp -a loader2/keymaps-x86_64 $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
+%endif
+
 %find_lang %{name}
 
 # hack so py_postclean would preserve it
@@ -239,6 +276,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc docs/*
+%{_sysconfdir}/keymaps.gz
 %attr(755,root,root) %{_sbindir}/anaconda
 %dir %{_libdir}/anaconda
 %{_libdir}/anaconda/*.py[co]
@@ -276,7 +314,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/anaconda/*-stub
 %dir %{_libdir}/anaconda-runtime
-%dir %attr(755,root,root) %{_libdir}/anaconda-runtime/boot
+%dir %{_libdir}/anaconda-runtime/boot
 %attr(755,root,root) %{_libdir}/anaconda-runtime/boot/syslinux.cfg
 %{_libdir}/anaconda-runtime/boot/boot.msg
 %{_libdir}/anaconda-runtime/boot/general.msg
@@ -291,7 +329,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/anaconda-runtime/implantisomd5
 %{_libdir}/anaconda-runtime/keymaps-override-*
 %attr(755,root,root) %{_libdir}/anaconda-runtime/libunicode-lite.so.1
-%dir %attr(755,root,root) %{_libdir}/anaconda-runtime/loader
+%dir %{_libdir}/anaconda-runtime/loader
 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/init
 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/loader
 %{_libdir}/anaconda-runtime/loader/loader.tr
This page took 0.084343 seconds and 4 git commands to generate.