]> git.pld-linux.org Git - packages/anaconda.git/blob - anaconda.spec
- BR: curl
[packages/anaconda.git] / anaconda.spec
1 # TODO
2 # - code poldek backend (python-poldek pkg exists!)
3 # - pldize /etc/fstab
4 # - /etc/modprobe.conf for geninitrd
5 #
6 %define         rel     200808292136
7 Summary:        Graphical system installer
8 Summary(pl.UTF-8):      Graficzny instalator systemu
9 Name:           anaconda
10 Version:        11.4.1.%{rel}
11 Release:        3
12 License:        GPL
13 Group:          Applications/System
14 # http://team.pld-linux.org/~patrys/anaconda.git - origin/pld-branch
15 Source0:        %{name}-%{rel}.tar.bz2
16 # Source0-md5:  1a3e6c15b9080fef45b53c2a471383ce
17 URL:            http://fedoraproject.org/wiki/Anaconda
18 # will kill it in the future
19 BuildRequires:  curl
20 BuildRequires:  device-mapper-static >= 1.01.05
21 BuildRequires:  e2fsprogs-devel
22 BuildRequires:  gettext-devel >= 0.11
23 BuildRequires:  glib2-static
24 BuildRequires:  glibc-static
25 BuildRequires:  gtk+2-devel
26 BuildRequires:  isomd5sum-devel
27 BuildRequires:  libdhcp-devel
28 BuildRequires:  libdhcp-static
29 BuildRequires:  libdhcp4client-devel
30 BuildRequires:  libdhcp6client-devel
31 BuildRequires:  libnl-devel
32 BuildRequires:  libselinux-devel >= 1.6
33 BuildRequires:  libsepol-devel
34 BuildRequires:  newt-devel
35 BuildRequires:  popt-devel
36 BuildRequires:  python-devel
37 BuildRequires:  python-kickstart >= 1.42
38 BuildRequires:  python-rhpl
39 BuildRequires:  python-rpm
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  rpmbuild(macros) >= 1.234
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  slang-static
44 BuildRequires:  zlib-static
45 Requires:       /etc/pld-release
46 Requires:       bdevid
47 Requires:       device-mapper >= 1.01.05
48 Requires:       dosfstools
49 Requires:       e2fsprogs
50 Requires:       grubby
51 Requires:       hal
52 Requires:       hfsutils
53 Requires:       jfsutils
54 Requires:       lvm2
55 Requires:       mdadm
56 Requires:       python-bdevid >= 6.0.24
57 Requires:       python-booty >= 0.93
58 Requires:       python-cracklib
59 Requires:       python-dbus
60 Requires:       python-devel-tools
61 Requires:       python-iniparse
62 Requires:       python-kickstart >= 1.42
63 Requires:       python-libuser
64 Requires:       python-libxml2
65 Requires:       python-parted >= 1.8.9
66 Requires:       python-rhpl >= 0.216
67 Requires:       python-rpm >= 4.2-0.61
68 Requires:       python-selinux
69 Requires:       python-snack
70 Requires:       python-urlgrabber >= 2.9.8
71 Requires:       reiserfsprogs
72 Requires:       system-config-date >= 1.9.17
73 Requires:       tzdata
74 Requires:       util-linux
75 Requires:       xfsprogs
76 Requires:       yum >= 2.5.1-3
77 %ifnarch s390 s390x
78 Requires:       python-pyblock >= 0.7-1
79 %endif
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 The anaconda package contains the program which can be used to install
84 system. These files are of little use on an already installed system.
85
86 %description -l pl.UTF-8
87 Pakiet anaconda zawiera program, którego można użyć do zainstalowania
88 systemu. Pliki te mają niewiele zastosowań na już zainstalowanym
89 systemie.
90
91 %package gui
92 Summary:        Anaconda GTK+2 GUI
93 Group:          Applications/System
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       X11-OpenGL-core
96 Requires:       X11-Xserver
97 Requires:       X11-fonts
98 Requires:       python-gnome-canvas
99 Requires:       python-pygtk-glade
100 Requires:       system-config-date
101 Requires:       system-config-keyboard
102
103 %description gui
104 Anaconda GUI portion.
105
106 %package runtime
107 Summary:        Graphical system installer portions needed only for fresh installs
108 Summary(pl.UTF-8):      Elementy graficznego instalatora systemu potrzebne tylko przy nowych instalacjach
109 Group:          Applications/System
110 AutoReqProv:    false
111 Requires:       %{name} = %{version}-%{release}
112 Requires:       /usr/bin/strip
113 Requires:       X11
114 Requires:       createrepo >= 0.4.3
115 Requires:       gawk
116 Requires:       glibc >= 6:2.3.6-5.1
117 Requires:       kbd
118 Requires:       policycoreutils >= 1.30
119 Requires:       python
120 Requires:       python-libxml2
121 Requires:       python-rpm >= 4.2-0.61
122 Requires:       squashfs
123 Requires:       yum >= 2.4.0
124
125 %description runtime
126 The anaconda-runtime package contains parts of the installation system
127 which are needed for installing new systems. These files are used to
128 build media sets, but are not meant for use on already installed
129 systems.
130
131 %description runtime -l pl.UTF-8
132 Pakiet anaconda-runtime zawiera elementy instalatora potrzebne tylko
133 do instalowania nowych systemów. Pliki te służą do tworzenia zestawu
134 nośników, nie są przewidziane do używania na już zainstalowanych
135 systemach.
136
137 %package debug
138 Summary:        Sourcecode for Anaconda
139 Summary(pl.UTF-8):      Kod źródłowy Anacondy
140 Group:          Applications/System
141 AutoReqProv:    false
142 Requires:       %{name} = %{version}-%{release}
143
144 %description debug
145 Anaconda sourcecode for debugging purposes.
146
147 %description debug -l pl.UTF-8
148 Kod źródłowy Anacondy do celów diagnostycznych.
149
150 %prep
151 %setup -q -n %{name}-%{rel}
152
153 %build
154 %{__make} depend -j1 \
155         PYTHON="%{__python}" \
156         PYTHONINCLUDE="%{py_incdir}" \
157         CC="%{__cc}"
158
159 %{__make} -j1 \
160         PYTHON="%{__python}" \
161         PYTHONINCLUDE="%{py_incdir}" \
162         CC="%{__cc}" \
163         REALCC="%{__cc}" \
164         OPTFLAGS="%{rpmcflags}"
165
166 ./py-compile isys/isys.py
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 install isys/isys.py[co] $RPM_BUILD_ROOT%{_libdir}/anaconda
175
176 # for ./isys/lang.c:isysLoadKeymap()
177 %ifarch %{ix86}
178 cp -a loader2/keymaps-i386 $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
179 %endif
180 %ifarch ppc
181 cp -a loader2/keymaps-ppc $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
182 %endif
183 %ifarch %{x8664}
184 cp -a loader2/keymaps-x86_64 $RPM_BUILD_ROOT%{_sysconfdir}/keymaps.gz
185 %endif
186
187 %find_lang %{name}
188
189 %{!?debug:%py_postclean %{_libdir}/anaconda}
190
191 %clean
192 rm -rf $RPM_BUILD_ROOT
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc docs/*
197 %{_sysconfdir}/keymaps.gz
198 /etc/security/console.apps/liveinst
199 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/liveinst
200 %attr(755,root,root) %{_bindir}/liveinst
201 %attr(755,root,root) %{_sbindir}/anaconda
202 %attr(755,root,root) %{_sbindir}/gptsync
203 %attr(755,root,root) %{_sbindir}/liveinst
204 %attr(755,root,root) %{_sbindir}/showpart
205 %dir %{_libdir}/anaconda
206 %{_libdir}/anaconda/*.py[co]
207 %dir %{_libdir}/anaconda/installclasses
208 %{_libdir}/anaconda/installclasses/*.py[co]
209 %dir %{_libdir}/anaconda/textw
210 %{_libdir}/anaconda/textw/*.py[co]
211 %{_libdir}/anaconda/lang-names
212 %{_libdir}/anaconda/lang-table
213 %attr(755,root,root) %{_libdir}/anaconda/_isys.so
214
215 %files gui
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/mini-wm
218 %attr(755,root,root) %{_libdir}/anaconda/xutils.so
219 %{_desktopdir}/liveinst.desktop
220 %dir %{_libdir}/anaconda/iw
221 %{_libdir}/anaconda/iw/*.py[co]
222 %{_datadir}/anaconda
223
224 %if %{!?debug:0}%{?debug:1}
225 %files debug
226 %defattr(644,root,root,755)
227 %{_libdir}/anaconda/*.py
228 %{_libdir}/anaconda/installclasses/*.py
229 %{_libdir}/anaconda/iw/*.py
230 %{_libdir}/anaconda/textw/*.py
231 %endif
232
233 %files runtime
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/anaconda/*-stub
236 %dir %{_libdir}/anaconda-runtime
237 %dir %{_libdir}/anaconda-runtime/boot
238 %{_libdir}/anaconda-runtime/boot/boot.msg
239 %{_libdir}/anaconda-runtime/boot/general.msg
240 %{_libdir}/anaconda-runtime/boot/grub.conf
241 %{_libdir}/anaconda-runtime/boot/options.msg
242 %{_libdir}/anaconda-runtime/boot/param.msg
243 %{_libdir}/anaconda-runtime/boot/rescue.msg
244 %{_libdir}/anaconda-runtime/boot/syslinux.cfg
245 %attr(755,root,root) %{_libdir}/anaconda-runtime/buildinstall
246 %attr(755,root,root) %{_libdir}/anaconda-runtime/buildinstall.functions
247 %attr(755,root,root) %{_libdir}/anaconda-runtime/genmodinfo
248 %attr(755,root,root) %{_libdir}/anaconda-runtime/getkeymaps
249 %{_libdir}/anaconda-runtime/keymaps-override-*
250 %dir %{_libdir}/anaconda-runtime/loader
251 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/init
252 %attr(755,root,root) %{_libdir}/anaconda-runtime/loader/loader
253 %{_libdir}/anaconda-runtime/loader/loader.tr
254 %{_libdir}/anaconda-runtime/loader/unicode-linedraw-chars.txt
255 %attr(755,root,root) %{_libdir}/anaconda-runtime/makestamp.py
256 %attr(755,root,root) %{_libdir}/anaconda-runtime/maketreeinfo.py
257 %attr(755,root,root) %{_libdir}/anaconda-runtime/mapshdr
258 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images
259 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.alpha
260 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.ia64
261 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.efi
262 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.ppc
263 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.s390
264 %attr(755,root,root) %{_libdir}/anaconda-runtime/mk-images.x86
265 %attr(755,root,root) %{_libdir}/anaconda-runtime/modlist
266 %attr(755,root,root) %{_libdir}/anaconda-runtime/pyrc.py
267 %attr(755,root,root) %{_libdir}/anaconda-runtime/readmap
268 %attr(755,root,root) %{_libdir}/anaconda-runtime/scrubtree
269 %{_libdir}/anaconda-runtime/screenfont-*.gz
270 %attr(755,root,root) %{_libdir}/anaconda-runtime/trimpciids
271 %attr(755,root,root) %{_libdir}/anaconda-runtime/upd-instroot
272 %attr(755,root,root) %{_libdir}/anaconda-runtime/upd-updates
This page took 0.051251 seconds and 4 git commands to generate.