]> git.pld-linux.org Git - packages/amsn.git/commitdiff
- add -no-exact-http.patch, -songbird-exception.patch from fc; update deps
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 25 Feb 2010 22:54:55 +0000 (22:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    amsn-no-exact-http.patch -> 1.1
    amsn-songbird-exception.patch -> 1.1
    amsn.spec -> 1.36

amsn-no-exact-http.patch [new file with mode: 0644]
amsn-songbird-exception.patch [new file with mode: 0644]
amsn.spec

diff --git a/amsn-no-exact-http.patch b/amsn-no-exact-http.patch
new file mode 100644 (file)
index 0000000..8f996d4
--- /dev/null
@@ -0,0 +1,22 @@
+--- amsn/autoupdate.tcl        2009-11-11 09:23:42.736604374 +0100
++++ amsn~/autoupdate.tcl       2009-11-11 09:38:25.349355120 +0100
+@@ -536,7 +536,7 @@
+       }
+       #///////////////////////////////////////////////////////////////////////
+-      package require -exact http 2.4.4
++      package require http 2.4.4
+       proc check_web_version { token } {
+               global version rcversion weburl
+--- amsn/proxy.tcl     2009-11-11 09:23:43.270603596 +0100
++++ amsn~/proxy.tcl    2009-11-11 09:31:51.524364201 +0100
+@@ -9,7 +9,7 @@
+ ::Version::setSubversionId {$Id$}
+ package provide Proxy 0.1
+-package require -exact http 2.4.4
++package require http 2.4.4
+ # This should be converted to a proper package, to use with package require
+ source socks.tcl      ;# SOCKS5 proxy support
diff --git a/amsn-songbird-exception.patch b/amsn-songbird-exception.patch
new file mode 100644 (file)
index 0000000..4db4100
--- /dev/null
@@ -0,0 +1,19 @@
+--- amsn/plugins/music/infosongbird    (revision 11807)
++++ amsn/plugins/music/infosongbird    (working copy)
+@@ -1,7 +1,10 @@
+ #!/usr/bin/env python
+-import dbus
+-bus = dbus.SessionBus()
+-object = bus.get_object('org.mozilla.songbird', '/org/mozilla/songbird')
+-print object.getStatus()
+-print object.getTitle()
+-print object.getArtist()
++try:
++      import dbus
++      bus = dbus.SessionBus()
++      object = bus.get_object('org.mozilla.songbird', '/org/mozilla/songbird')
++      print object.getStatus()
++      print object.getTitle()
++      print object.getArtist()
++except dbus.exceptions.DBusException:
++      print "not installed"
index 4f16d927159d93c5a843966c648cf18c42dd75f2..e4ab6146e59e8675c1614939cc5775359aaa64d3 100644 (file)
--- a/amsn.spec
+++ b/amsn.spec
@@ -7,7 +7,7 @@ Summary(fr.UTF-8):      Clône MSN Messenger pour Linux
 Summary(pl.UTF-8):     Klon MSN Messengera dla Linuksa
 Name:          amsn
 Version:       0.98.1
-Release:       2.3
+Release:       2.4
 License:       GPL
 Group:         Applications/Communications
 Source0:       http://downloads.sourceforge.net/amsn/%{name}-%{version}.tar.gz
@@ -17,6 +17,8 @@ Patch0:               %{name}-desktop.patch
 Patch1:                %{name}-paths.patch
 Patch2:                %{name}-libpng.patch
 Patch3:                %{name}-bwidget.patch
+Patch4:                %{name}-no-exact-http.patch
+Patch5:                %{name}-songbird-exception.patch
 URL:           http://www.amsn-project.net/
 BuildRequires: farsight2-devel
 BuildRequires: libjpeg-devel
@@ -36,11 +38,12 @@ Requires(post,postun):      hicolor-icon-theme
 # IM's convert is needed to display pictures (buddy icons).
 Requires:      ImageMagick
 Requires:      tcl >= 8.5.7
-Requires:      tcllib
-Requires:      tk-BWidget >= 1.8.0-2
 # MSN Protocol 9 won't let you in without SSL anymore.
 Requires:      tcl-tls
+Requires:      tcllib
 Requires:      tk >= 8.4
+Requires:      tk-BWidget >= 1.8.0-2
+Requires:      xdg-utils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                find_lang       %{SOURCE1} %{buildroot}
@@ -104,6 +107,8 @@ rm -r plugins/music/MusicWin
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 # NOTE: enable debug allows us to keep debug symbols in -debuginfo package
@@ -148,7 +153,7 @@ mv $RPM_BUILD_ROOT%{_datadir}/%{name}/utils/asyncresolver $RPM_BUILD_ROOT%{tcl_s
 mv $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_desktopdir}}/%{name}.desktop
 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/desktop-icons/* $RPM_BUILD_ROOT%{_iconsdir}/hicolor
 rm -r $RPM_BUILD_ROOT%{_datadir}/%{name}/desktop-icons
-rm $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
+rm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 
 # docs in docs
 rm -r $RPM_BUILD_ROOT%{_datadir}/%{name}/utils/*/test.tcl
This page took 0.043855 seconds and 4 git commands to generate.