]> git.pld-linux.org Git - packages/amavis-stats.git/blobdiff - amavis-stats.spec
- obsolete
[packages/amavis-stats.git] / amavis-stats.spec
index 9d652a367fa4a1f1e1f11e413c7985a73c985e28..cfd9f7f8927f704f478aea6956b80d81a586c59d 100644 (file)
@@ -1,25 +1,30 @@
+#
+# TODO:
+#   - add init script
+#   - add trigger to update apache configuration
+#
 %include       /usr/lib/rpm/macros.perl
-%define                _rc     rc6
 Summary:       Simple amavisd-new statistics generator
-Summary(pl):   Prosty generator statystyk dla amavisd-new
+Summary(pl.UTF-8):     Prosty generator statystyk dla amavisd-new
 Name:          amavis-stats
-Version:       0.1.13
-Release:       0.%{_rc}.5
+Version:       0.1.22
+Release:       0.1
 License:       GPL
 Group:         Applications/System
-Source0:       http://rekudos.net/download/%{name}-%{version}-%{_rc}.tar.gz
-# Source0-md5: 39156ca0eba50405d836aaf9d97743bf
-Source1:       %{name}.cron
+Source0:       http://downloads.topicdesk.com/amavis_stats/%{name}-%{version}.tar.gz
+# Source0-md5: 5bea6811c00a4fda4b96b6a318a04a92
 Patch0:                %{name}-gzip.patch
-Patch1:                %{name}-more_ac.patch
-Patch2:                %{name}-Makefile.patch
-URL:           http://rekudos.net/amavis-stats/
+Patch1:                %{name}-Makefile.patch
+Patch2:                %{name}-pid.patch
+URL:           http://osx.topicdesk.com/content/view/42/59/
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: sed >= 4.0
 Provides:      %{name}-%{version}-%{release}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      /var/lib/%{name}
+%define                _pkgcachedir    /var/cache/%{name}
 %define                _webapps        /etc/webapps
 %define                _webapp         %{name}
 %define                _webappdir      %{_webapps}/%{_webapp}
@@ -30,62 +35,64 @@ amavis-stats is a simple amavis statistics generator based on rrdtool.
 It produces graphs from amavisd-new log entries of infections broken
 down by virus.
 
-%description -l pl
+%description -l pl.UTF-8
 amavis-stats jest prostym generatorem statystyk opartym na rrdtool.
-Tworzy wykresy zainfekowanych wiadomo¶ci, w rozbiciu na poszczególne
-wirusy, na podstawie logów amavisd-new.
+Tworzy wykresy zainfekowanych wiadomości, w rozbiciu na poszczególne
+wirusy, na podstawie logów amavisd-new.
 
 %package php
 Summary:       PHP interface for amavis-stats
-Summary(pl):   Interfejs PHP dla amavis-stats
+Summary(pl.UTF-8):     Interfejs PHP dla amavis-stats
 Group:         Applications/System
 Requires:      %{name}-%{version}-%{release}
-Requires:      php
-Requires:      php-pcre
+Requires:      php(pcre)
 Requires:      webapps
+Requires:      webserver(php)
 
 %description php
 PHP interface for amavis-stats.
 
-%description php -l pl
+%description php -l pl.UTF-8
 Interfejs PHP dla amavis-stats.
 
 %prep
-%setup -q -n %{name}-%{version}-%{_rc}
+%setup -q
 %patch0 -p1
-%patch1 -p0
+%patch1 -p1
 %patch2 -p1
 
 %build
-%configure
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+sed -i -e '/basic_machine=powerpc-apple/s/$/\n\t\t;;\n\tnoarch-*)\n\t\tbasic_machine=noarch/;' config.sub
+%configure \
+       --with-user=http \
+       --with-group=http \
+       --with-log-file=/var/log/maillog
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/cron.d
-user=`id -u`
-group=`id -g`
 
 %{__make} install \
-       install_prefix=$RPM_BUILD_ROOT \
-       amavis_user=$user \
-       amavis_group=$group \
-       web_user=$user \
-       web_group=$group
-
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/amavis-stats
-ln -s amavis-stats.php $RPM_BUILD_ROOT%{_datadir}/%{name}/index.php
+       DESTDIR=$RPM_BUILD_ROOT
+
 install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
-mv $RPM_BUILD_ROOT{/etc/amavis-stats/apache.conf,%{_webapps}/%{_webapp}/httpd.conf}
+mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.alias.conf,%{_webapps}/%{_webapp}/httpd.conf}
+mv $RPM_BUILD_ROOT{%{_datadir}/amavis-stats/amavis-stats.php.conf,%{_webapps}/%{_webapp}}
+ln -s %{_webapps}/%{_webapp}/amavis-stats.php.conf $RPM_BUILD_ROOT%{_datadir}/%{name}/amavis-stats.php.conf
 cp $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/{httpd,apache}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%triggerin php -- apache1
+%triggerin php -- apache1 < 1.3.37-3, apache1-base
 %webapp_register apache %{_webapp}
 
-%triggerun php -- apache1
+%triggerun php -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
 %triggerin php -- apache < 2.2.0, apache-base
@@ -110,10 +117,10 @@ rm -f /etc/httpd/httpd.conf/99_%{name}.conf
 
 %files
 %defattr(644,root,root,755)
-%doc README debian/changelog
+%doc README ChangeLog
 %attr(755,root,root) %{_sbindir}/amavis-stats
 %dir %{_pkglibdir}
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/amavis-stats
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/amavis-stats.conf
 %{_mandir}/man1/*
 
 %files php
@@ -121,9 +128,15 @@ rm -f /etc/httpd/httpd.conf/99_%{name}.conf
 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/amavis-stats.php.conf
 %dir %{_appdir}
-# symlink
+%{_appdir}/amavis-stats.php.conf
 %{_appdir}/img
-%{_appdir}/%{name}.php
+%{_appdir}/includes
 %{_appdir}/index.php
-%attr(775,root,http) %dir %{_pkglibdir}/img
+%{_appdir}/templates
+%{_appdir}/%{name}.php
+%{_appdir}/%{name}.html
+%{_appdir}/*.png
+%{_appdir}/*.ttf
+%attr(775,root,http) %dir %{_pkgcachedir}
This page took 0.098528 seconds and 4 git commands to generate.