]> git.pld-linux.org Git - packages/amarok.git/commitdiff
- drop obsolete files
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 5 Jul 2009 17:14:15 +0000 (17:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    amarok-artist_postfix.patch -> 1.2
    amarok-gcc4.patch -> 1.3
    amarok-helixplayer-morearchs.patch -> 1.2
    amarok-libmtp.patch -> 1.2
    amarok-libnjb.patch -> 1.2
    amarok-mongrel.patch -> 1.6
    amarok-qtsrcipt_notr.patch -> 1.2
    amarok-smp.patch -> 1.4
    amarok-sparc.patch -> 1.3
    amarok-titleorder.patch -> 1.2
    kde-ac260-lt.patch -> 1.2
    kde-common-PLD.patch -> 1.12
    kde-common-gcc4.patch -> 1.3
    kde4-kdeextragear-multimedia-NJB.patch -> 1.2

14 files changed:
amarok-artist_postfix.patch [deleted file]
amarok-gcc4.patch [deleted file]
amarok-helixplayer-morearchs.patch [deleted file]
amarok-libmtp.patch [deleted file]
amarok-libnjb.patch [deleted file]
amarok-mongrel.patch [deleted file]
amarok-qtsrcipt_notr.patch [deleted file]
amarok-smp.patch [deleted file]
amarok-sparc.patch [deleted file]
amarok-titleorder.patch [deleted file]
kde-ac260-lt.patch [deleted file]
kde-common-PLD.patch [deleted file]
kde-common-gcc4.patch [deleted file]
kde4-kdeextragear-multimedia-NJB.patch [deleted file]

diff --git a/amarok-artist_postfix.patch b/amarok-artist_postfix.patch
deleted file mode 100644 (file)
index 8974ae4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/context/engines/wikipedia/WikipediaEngine.cpp  2009-02-21 09:51:22.000000000 +0100
-+++ src/context/engines/wikipedia/WikipediaEngine.cpp.new      2009-03-12 21:51:34.469113928 +0100
-@@ -347,7 +347,7 @@
-     else if( wikiLocale() == "de" )
-         return " (Band)";
-     else if( wikiLocale() == "pl" )
--        return " (Kapela)";
-+        return " (grupa muzyczna)";
-     return QString();
- }
diff --git a/amarok-gcc4.patch b/amarok-gcc4.patch
deleted file mode 100644 (file)
index a9f913c..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
---- amarok-1.4.4/amarok/src/engine/helix/helix-sp/helix-include/common/include/hxtypes.h.orig  2006-10-26 22:40:20.000000000 +0200
-+++ amarok-1.4.4/amarok/src/engine/helix/helix-sp/helix-include/common/include/hxtypes.h       2006-12-11 23:23:07.181351000 +0100
-@@ -326,16 +326,6 @@
- #endif
- #endif
--#ifndef NOMINMAX
--/* Always use macro versions of these! */
--#ifndef max
--#define max(a, b)  (((a) > (b)) ? (a) : (b))
--#endif
--#ifndef min
--#define min(a, b)  (((a) < (b)) ? (a) : (b))
--#endif
--#endif
--
- /* Should use capitalized macro versions of these, as the lowercase
-               versions conflict with the STL spec */
- //get these from sys/param.h to avoid tons of warnings about redefining them:
---- amarok-1.4.10/amarok/src/engine/helix/hxplayercontrol.cpp~ 2008-08-13 23:21:51.000000000 +0200
-+++ amarok-1.4.10/amarok/src/engine/helix/hxplayercontrol.cpp  2008-08-26 11:30:52.000000000 +0200
-@@ -18,6 +18,7 @@
- #include <sys/time.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <stdlib.h>
- #include <unistd.h>
- #include <iostream>
- #include <cstring>
diff --git a/amarok-helixplayer-morearchs.patch b/amarok-helixplayer-morearchs.patch
deleted file mode 100644 (file)
index 8bfdbdc..0000000
+++ /dev/null
@@ -1,230 +0,0 @@
---- amarok/amarok/src/engine/helix/helix-sp/helix-include/common/include/atomicbase.h.orig     2005-11-03 22:22:27.000000000 +0100
-+++ amarok/amarok/src/engine/helix/helix-sp/helix-include/common/include/atomicbase.h  2005-11-03 23:14:46.000000000 +0100
-@@ -179,7 +179,7 @@
- #elif defined (__sparc__) && defined (__GNUC__)
- /* Increment by 1 */
--inline void
-+static inline void
- HXAtomicIncUINT32(UINT32* pNum)
- {
-     __asm__ __volatile__(\
-@@ -200,7 +200,7 @@
- }
- /* Decrement by 1 */
--inline void
-+static inline void
- HXAtomicDecUINT32(UINT32* pNum)
- {
-     __asm__ __volatile__(
-@@ -221,7 +221,7 @@
- }
- /* Increment by 1 and return new value */
--inline UINT32
-+static inline UINT32
- HXAtomicIncRetUINT32(UINT32* pNum)
- {
-     volatile UINT32 ulRet;
-@@ -245,7 +245,7 @@
- }
- /* Decrement by 1 and return new value */
--inline UINT32
-+static inline UINT32
- HXAtomicDecRetUINT32(UINT32* pNum)
- {   volatile UINT32 ulRet;
-     __asm__ __volatile__(
-@@ -268,7 +268,7 @@
- }
- /* Add n */
--inline void
-+static inline void
- HXAtomicAddUINT32(UINT32* pNum, UINT32 ulNum)
- {
-     __asm__ __volatile__(
-@@ -290,7 +290,7 @@
- }
- /* Subtract n */
--inline void
-+static inline void
- HXAtomicSubUINT32(UINT32* pNum, UINT32 ulNum)
- {
-     __asm__ __volatile__(
-@@ -312,7 +312,7 @@
- }
- /* Add n and return new value */
--inline UINT32
-+static inline UINT32
- HXAtomicAddRetUINT32(UINT32* pNum, UINT32 ulNum)
- {
-     volatile UINT32 ulRet; \
-@@ -337,7 +337,7 @@
- }
- /* Subtract n and return new value */
--inline UINT32
-+static inline UINT32
- HXAtomicSubRetUINT32(UINT32* pNum, UINT32 ulNum)
- {   volatile UINT32 ulRet;
-     __asm__ __volatile__(
-@@ -360,14 +360,14 @@
-         return ulRet;
- }
--inline void HXAtomicIncINT32(INT32* p)              { HXAtomicIncUINT32((UINT32*)p); }
--inline void HXAtomicDecINT32(INT32* p)              { HXAtomicDecUINT32((UINT32*)p); }
--inline void HXAtomicAddINT32(INT32* p, INT32 n)     { HXAtomicAddUINT32((UINT32*)p, (UINT32)n); }
--inline void HXAtomicSubINT32(INT32* p, INT32 n)     { HXAtomicSubUINT32((UINT32*)p, (UINT32)n); }
--inline INT32 HXAtomicIncRetINT32(INT32* p)          { return HXAtomicIncRetUINT32((UINT32*)p); }
--inline INT32 HXAtomicDecRetINT32(INT32* p)          { return HXAtomicDecRetUINT32((UINT32*)p); }
--inline INT32 HXAtomicAddRetINT32(INT32* p, INT32 n) { return HXAtomicAddRetUINT32((UINT32*)p, (UINT32)n); }
--inline INT32 HXAtomicSubRetINT32(INT32* p, INT32 n) { return HXAtomicSubRetUINT32((UINT32*)p, (UINT32)n); }
-+static inline void HXAtomicIncINT32(INT32* p)              { HXAtomicIncUINT32((UINT32*)p); }
-+static inline void HXAtomicDecINT32(INT32* p)              { HXAtomicDecUINT32((UINT32*)p); }
-+static inline void HXAtomicAddINT32(INT32* p, INT32 n)     { HXAtomicAddUINT32((UINT32*)p, (UINT32)n); }
-+static inline void HXAtomicSubINT32(INT32* p, INT32 n)     { HXAtomicSubUINT32((UINT32*)p, (UINT32)n); }
-+static inline INT32 HXAtomicIncRetINT32(INT32* p)          { return HXAtomicIncRetUINT32((UINT32*)p); }
-+static inline INT32 HXAtomicDecRetINT32(INT32* p)          { return HXAtomicDecRetUINT32((UINT32*)p); }
-+static inline INT32 HXAtomicAddRetINT32(INT32* p, INT32 n) { return HXAtomicAddRetUINT32((UINT32*)p, (UINT32)n); }
-+static inline INT32 HXAtomicSubRetINT32(INT32* p, INT32 n) { return HXAtomicSubRetUINT32((UINT32*)p, (UINT32)n); }
-@@ -547,7 +547,7 @@
- #elif defined(__GNUC__) && !defined(_OPENBSD) && \
-       (__GNUC__>2 || (__GNUC__==2 && __GNUC_MINOR__>=95)) && \
-       ( defined (__i486__) || defined (__i586__) || defined (__i686__) || \
--        defined (__pentium__) || defined (__pentiumpro__))
-+        defined (__pentium__) || defined (__pentiumpro__) || defined (__pentium4__) || defined (__athlon__))
- /* Increment by 1 */
- static __inline__ void
-@@ -855,6 +855,114 @@
-  */
- #elif defined (__alpha)
-+#  ifdef __GNUC__
-+
-+/* Increment by 1 and return new value */
-+static inline INT32
-+HXAtomicIncRetINT32(INT32* pNum)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        addl    $1, 1, $1\n"       // Increment value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Decrement by 1 and return new value */
-+static inline INT32
-+HXAtomicDecRetINT32(INT32* pNum)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        subl    $1, 1, $1\n"       // Decrement value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Add n and return new value */
-+static inline INT32
-+HXAtomicAddRetINT32(INT32* pNum, INT32 n)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        addl    $1, %1, $1\n"      // Add n to value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "r" (n), "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Subtract n and return new value */
-+static inline INT32
-+HXAtomicSubRetINT32(INT32* pNum, INT32 n)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        subl    $1, %1, $1\n"      // Subtract n from value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "r" (n), "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Increment by 1 and return new value */
-+static inline UINT32
-+HXAtomicIncRetUINT32(UINT32* pNum)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        addl    $1, 1, $1\n"       // Increment value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Decrement by 1 and return new value */
-+static inline UINT32
-+HXAtomicDecRetUINT32(UINT32* pNum)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        subl    $1, 1, $1\n"       // Decrement value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Add n and return new value */
-+static inline UINT32
-+HXAtomicAddRetUINT32(UINT32* pNum, UINT32 n)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        addl    $1, %1, $1\n"      // Add n to value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "r" (n), "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+/* Subtract n and return new value */
-+static inline UINT32
-+HXAtomicSubRetUINT32(UINT32* pNum, UINT32 n)
-+{
-+    asm volatile (
-+        "10:     ldl_l   $1, %0\n"          // Load-lock value into a register
-+        "        subl    $1, %1, $1\n"      // Subtract n from value
-+        "        stl_c   $1, %0\n"          // Save new value into *pNum
-+        "        beq     $1, 10b\n"         // Retry if sequence failed
-+        : "=m" (*pNum) : "r" (n), "m" (*pNum) : "$1");
-+    return *pNum;
-+}
-+
-+#  else
-+
- #include <c_asm.h>
- /* Increment by 1 and return new value */
-@@ -961,6 +1067,8 @@
-         , pNum, n);
- }
-+#  endif
-+
- #define HXAtomicIncINT32(p)    HXAtomicIncRetINT32((p))
- #define HXAtomicDecINT32(p)    HXAtomicDecRetINT32((p))
- #define HXAtomicAddINT32(p,n)  HXAtomicAddRetINT32((p),(n))
diff --git a/amarok-libmtp.patch b/amarok-libmtp.patch
deleted file mode 100644 (file)
index a450007..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
---- amarok/src/mediadevice/mtp/mtpmediadevice.cpp
-+++ amarok/src/mediadevice/mtp/mtpmediadevice.cpp
-@@ -293,12 +293,13 @@
-         parent_id = getDefaultParentId();
-     }
-     debug() << "Parent id : " << parent_id << endl;
-+    trackmeta->parent_id = parent_id;
-     m_critical_mutex.lock();
-     debug() << "Sending track... " << bundle.url().path().utf8() << endl;
-     int ret = LIBMTP_Send_Track_From_File(
-         m_device, bundle.url().path().utf8(), trackmeta,
--        progressCallback, this, parent_id
-+        progressCallback, this
-     );
-     m_critical_mutex.unlock();
-@@ -529,7 +530,7 @@
-         for( MtpMediaItem *it = dynamic_cast<MtpMediaItem*>(items->first()); it; it = dynamic_cast<MtpMediaItem*>(items->next()) )
-             album_object->tracks[i++] = it->track()->id();
-         album_object->no_tracks = items->count();
--        ret = LIBMTP_Create_New_Album( m_device, album_object, 0 );
-+        ret = LIBMTP_Create_New_Album( m_device, album_object );
-         if( ret != 0 )
-         {
-             debug() << "creating album failed : " << ret << endl;
-@@ -608,7 +609,7 @@
- {
-     debug() << "Creating new folder '" << name << "' as a child of "<< parent_id << endl;
-     char *name_copy = qstrdup( name );
--    uint32_t new_folder_id = LIBMTP_Create_Folder( m_device, name_copy, parent_id );
-+    uint32_t new_folder_id = LIBMTP_Create_Folder( m_device, name_copy, parent_id, 0 );
-     delete(name_copy);
-     debug() << "New folder ID: " << new_folder_id << endl;
-     if( new_folder_id == 0 )
-@@ -913,7 +914,7 @@
-     if( item->playlist()->id() == 0 )
-     {
-         debug() << "creating new playlist : " << metadata->name << endl;
--        int ret = LIBMTP_Create_New_Playlist( m_device, metadata, 0 );
-+        int ret = LIBMTP_Create_New_Playlist( m_device, metadata );
-         if( ret == 0 )
-         {
-             item->playlist()->setId( metadata->playlist_id );
diff --git a/amarok-libnjb.patch b/amarok-libnjb.patch
deleted file mode 100644 (file)
index 5643e5d..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ur amarok-1.4.1-beta1/amarok/src/mediadevice/njb/njbmediadevice.h amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/njbmediadevice.h
---- amarok-1.4.1-beta1/amarok/src/mediadevice/njb/njbmediadevice.h     2006-06-18 20:56:09.000000000 +0000
-+++ amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/njbmediadevice.h 2006-06-20 10:08:31.000000000 +0000
-@@ -17,7 +17,7 @@
- // #include <mediadevice.h>
- #include <mediabrowser.h>
- #include <transferdialog.h>
--#include <libnjb.h>
-+#include <libnjb/libnjb.h>
- #include <qptrlist.h>
- #include <qlistview.h>
-diff -ur amarok-1.4.1-beta1/amarok/src/mediadevice/njb/playlist.h amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/playlist.h
---- amarok-1.4.1-beta1/amarok/src/mediadevice/njb/playlist.h   2006-06-18 20:56:09.000000000 +0000
-+++ amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/playlist.h       2006-06-20 10:28:27.000000000 +0000
-@@ -20,7 +20,7 @@
- #define __playlist_h__
- // libnjb
--#include <libnjb.h>
-+#include <libnjb/libnjb.h>
- // Qt
- #include <qstringlist.h>
-diff -ur amarok-1.4.1-beta1/amarok/src/mediadevice/njb/track.h amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/track.h
---- amarok-1.4.1-beta1/amarok/src/mediadevice/njb/track.h      2006-06-18 20:56:09.000000000 +0000
-+++ amarok-1.4.1-beta1.new/amarok/src/mediadevice/njb/track.h  2006-06-20 10:28:44.000000000 +0000
-@@ -24,7 +24,7 @@
- #include <qstring.h>
- // libnjb
--#include <libnjb.h>
-+#include <libnjb/libnjb.h>
- #include "metabundle.h"
diff --git a/amarok-mongrel.patch b/amarok-mongrel.patch
deleted file mode 100644 (file)
index cd12b31..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
---- amarok-1.4.9.1/amarok/src/mediadevice/daap/daapserver.cpp~ 2008-04-10 23:16:37.000000000 +0300
-+++ amarok-1.4.9.1/amarok/src/mediadevice/daap/daapserver.cpp  2008-05-03 20:38:40.854585305 +0300
-@@ -30,9 +30,6 @@
-     m_server = new KProcIO();
-     m_server->setComm( KProcess::All );
-     *m_server << "amarok_daapserver.rb";
--    *m_server << locate( "data", "amarok/ruby_lib/" );
--    *m_server << locate( "lib", "ruby_lib/" );
--    *m_server << locate( "data", "amarok/scripts/ruby_debug/debug.rb" );
-     if( !m_server->start( KProcIO::NotifyOnExit, true ) ) {
-         error() << "Failed to start amarok_daapserver.rb" << endl;
-         return;
---- amarok-1.4.9.1/amarok/src/mediadevice/daap/Makefile.am     2008-05-03 20:43:00.885572020 +0300
-+++ amarok-1.4.9.1/amarok/src/mediadevice/daap/Makefile.am     2008-05-03 20:47:24.272751916 +0300
-@@ -36,10 +36,10 @@
- bin_SCRIPTS = amarok_daapserver.rb
--SUBDIRS = daapreader mongrel
-+SUBDIRS = daapreader
- amarokrubylibdir = \
--    $(kde_datadir)/amarok/ruby_lib
-+    $(ruby_rubylibdir)/amarok
- amarokrubylib_DATA = \
-     codes.rb
---- amarok-1.4.9.1/amarok/src/mediadevice/daap/amarok_daapserver.rb~   2008-04-10 23:16:37.000000000 +0300
-+++ amarok-1.4.9.1/amarok/src/mediadevice/daap/amarok_daapserver.rb    2008-05-03 20:43:49.504374104 +0300
-@@ -3,15 +3,10 @@
- #A DAAP Server
- # (c) 2006 Ian Monroe <ian@monroe.nu>
- # License: GNU General Public License V2
--$LOAD_PATH.push(ARGV[0])
--puts "here it is: #{ARGV[0]}"
--$LOAD_PATH.push(ARGV[1])
--puts "here it is: #{ARGV[1]}"
--require "codes.rb"
-+require "amarok/codes"
- require 'mongrel'
--require "#{ARGV[2]}" #debug.rb
--
-+require "amarok/debug"
- require 'uri'
- require 'pp'
- #require 'ruby-prof'
---- amarok-1.4.9.1/amarok/src/scripts/ruby_debug/Makefile.am~  2008-04-10 23:16:37.000000000 +0300
-+++ amarok-1.4.9.1/amarok/src/scripts/ruby_debug/Makefile.am   2008-05-03 20:44:52.908028283 +0300
-@@ -1,5 +1,5 @@
- rubydebugdir = \
--    $(kde_datadir)/amarok/scripts/ruby_debug
-+    $(ruby_rubylibdir)/amarok
- rubydebug_DATA = \
-     debug.rb
---- amarok-1.4.9.1/amarok/src/scripts/lyrics_lyrc/lyrics_lyrc.rb~      2008-05-03 20:49:32.000000000 +0300
-+++ amarok-1.4.9.1/amarok/src/scripts/lyrics_lyrc/lyrics_lyrc.rb       2008-05-04 13:10:28.364031973 +0300
-@@ -12,7 +12,7 @@
- require "net/http"
- require "rexml/document"
--# require File.dirname( File.expand_path( __FILE__ ) ) + "/../ruby_debug/debug.rb"
-+# require "amarok/debug"
- require "uri"
- @app_name = "Lyrics_Lyrc"
diff --git a/amarok-qtsrcipt_notr.patch b/amarok-qtsrcipt_notr.patch
deleted file mode 100644 (file)
index 1cf3af7..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up amarok-2.0.90/CMakeLists.txt.qtscript_not_required amarok-2.0.90/CMakeLists.txt
---- amarok-2.0.90/CMakeLists.txt.qtscript_not_required 2009-04-06 16:29:12.000000000 -0500
-+++ amarok-2.0.90/CMakeLists.txt       2009-04-10 13:00:07.000000000 -0500
-@@ -38,8 +38,8 @@ if( WITH_PLAYER )
-     macro_log_feature( KDE4_FOUND "kdelibs" "The toolkit Amarok uses to build" "http://www.kde.org" TRUE "4.2.0" "" )
--    find_package( QtScriptQtBindings REQUIRED )
--    macro_log_feature( QTSCRIPTQTBINDINGS_FOUND "qtscript-qt" "QtScript Qt Bindings" "http://code.google.com/p/qtscriptgenerator/" TRUE "" "" )
-+    macro_optional_find_package(QtScriptQtBindings)
-+    macro_log_feature( QTSCRIPTQTBINDINGS_FOUND "qtscript-qt" "QtScript Qt Bindings" "http://code.google.com/p/qtscriptgenerator/" FALSE "" "" )
-     add_definitions(${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
diff --git a/amarok-smp.patch b/amarok-smp.patch
deleted file mode 100644 (file)
index d89fc7d..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok-1.4.5/amarok/src/app.cpp~   2007-02-09 00:02:36.637412281 +0200
-+++ amarok-1.4.5/amarok/src/app.cpp    2007-02-15 14:10:19.091799011 +0200
-@@ -186,7 +186,7 @@
-     new Amarok::DcopScriptHandler();
-     new Amarok::DcopDevicesHandler();
--    fixHyperThreading();
-+    // fixHyperThreading();
-     // tell AtomicString that this is the GUI thread
-     if ( !AtomicString::isMainThread() )
-         qWarning("AtomicString was initialized from a thread other than the GUI "
diff --git a/amarok-sparc.patch b/amarok-sparc.patch
deleted file mode 100644 (file)
index 3397e29..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- amarok-1.4.5/admin/acinclude.m4.in~        2007-02-03 13:22:56.983737611 +0200
-+++ amarok-1.4.5/admin/acinclude.m4.in 2007-02-03 13:24:33.815926416 +0200
-@@ -3197,7 +3197,7 @@
-         CXXFLAGS="-Wall -W -Wpointer-arith $CXXFLAGS"
-         case $host in
-           *-*-linux-gnu)      
--            CFLAGS="-std=iso9899:1990 -W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
-+            CFLAGS="-W -Wall -Wchar-subscripts -Wshadow -Wpointer-arith -Wmissing-prototypes -Wwrite-strings -D_XOPEN_SOURCE=500 -D_BSD_SOURCE $CFLAGS"
-             CXXFLAGS="-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts $CXXFLAGS"
-             KDE_CHECK_COMPILER_FLAG(Wmissing-format-attribute, [CXXFLAGS="$CXXFLAGS -Wformat-security -Wmissing-format-attribute"])
-             KDE_CHECK_C_COMPILER_FLAG(Wmissing-format-attribute, [CFLAGS="$CFLAGS -Wformat-security -Wmissing-format-attribute"])
diff --git a/amarok-titleorder.patch b/amarok-titleorder.patch
deleted file mode 100644 (file)
index 424c421..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- amarok-1.4.4/amarok/src/app.cpp~   2006-10-26 23:40:20.000000000 +0300
-+++ amarok-1.4.4/amarok/src/app.cpp    2006-12-26 21:52:35.829202536 +0200
-@@ -994,7 +990,7 @@
-         if ( oldState == Engine::Paused )
-             Amarok::OSD::instance()->OSDWidget::show( i18n( "state, as in playing", "Play" ) );
-         if ( !bundle.prettyTitle().isEmpty() )
--            m_pPlaylistWindow->setCaption( i18n("Amarok - %1").arg( bundle.veryNiceTitle() ) );
-+            m_pPlaylistWindow->setCaption( i18n("%1 - Amarok").arg( bundle.veryNiceTitle() ) );
-         break;
-     case Engine::Paused:
-@@ -1016,7 +1012,7 @@
- {
-     Amarok::OSD::instance()->show( bundle );
-     if ( !bundle.prettyTitle().isEmpty() )
--        m_pPlaylistWindow->setCaption( i18n("Amarok - %1").arg( bundle.veryNiceTitle() ) );
-+        m_pPlaylistWindow->setCaption( i18n("%1 - Amarok").arg( bundle.veryNiceTitle() ) );
-     TrackToolTip::instance()->setTrack( bundle );
- }
diff --git a/kde-ac260-lt.patch b/kde-ac260-lt.patch
deleted file mode 100644 (file)
index acbbc6c..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN arts-1.5.4.org/admin/libtool.m4.in arts-1.5.4/admin/libtool.m4.in
---- arts-1.5.4.org/admin/libtool.m4.in 2006-07-24 09:06:24.000000000 +0200
-+++ arts-1.5.4/admin/libtool.m4.in     2006-09-09 12:45:13.172062500 +0200
-@@ -3542,7 +3542,7 @@
-   # The `*' in the case matches for architectures that use `case' in
-   # $output_verbose_cmd can trigger glob expansion during the loop
-   # eval without this substitution.
--  output_verbose_link_cmd="`$echo \"X$output_verbose_link_cmd\" | $Xsed -e \"$no_glob_subst\"`"
-+  output_verbose_link_cmd=`$echo "X$output_verbose_link_cmd" | $Xsed -e "$no_glob_subst"`
-   for p in `eval $output_verbose_link_cmd`; do
-     case $p in
diff --git a/kde-common-PLD.patch b/kde-common-PLD.patch
deleted file mode 100644 (file)
index 21a7c91..0000000
+++ /dev/null
@@ -1,174 +0,0 @@
---- kdelibs-3.5.3.or/admin/acinclude.m4.in     2006-05-23 13:02:06.000000000 +0000
-+++ kdelibs-3.5.3/admin/acinclude.m4.in        2006-07-01 14:55:49.345359250 +0000
-@@ -428,7 +428,7 @@
- if test "$1" = "default"; then
-   if test -z "$kde_htmldir"; then
--    kde_htmldir='\${datadir}/doc/HTML'
-+    kde_htmldir='/usr/share/doc/kde/HTML'
-   fi
-   if test -z "$kde_appsdir"; then
-     kde_appsdir='\${datadir}/applnk'
-@@ -2977,41 +2977,6 @@
- AC_DEFUN([KDE_CHECK_FOR_BAD_COMPILER],
- [
--  AC_MSG_CHECKING([whether $CC is blacklisted])
--
--  dnl In theory we have tu run this test against $CC and $CXX
--  dnl in C and in C++ mode, because its perfectly legal for
--  dnl the user to mix compiler versions, since C has a defined
--  dnl ABI. 
--  dnl 
--  dnl For now, we assume the user is not on crack.
--
--  AC_TRY_COMPILE([
--#ifdef __GNUC__
--#if __GNUC__ == 4 && __GNUC_MINOR__ == 0 && __GNUC_PATCHLEVEL__ == 0
--choke me
--#endif
--#endif
--], ,
--  kde_bad_compiler=no, 
--  kde_bad_compiler=yes
--)
--
--  AC_MSG_RESULT($kde_bad_compiler)
--
--if test "$kde_bad_compiler" = "yes"; then
--  AC_MSG_ERROR([
--
--This particular compiler version is blacklisted because it
--is known to miscompile KDE. Please use a newer version, or
--if that is not yet available, choose an older version. 
--
--Please do not report a bug or bother us reporting this
--configure error. We know about it, and we introduced
--it by intention to avoid untraceable bugs or crashes in KDE.
--
--])
--fi
- ])
-@@ -3153,8 +3118,6 @@
-   AC_PROG_CXX
--  KDE_CHECK_FOR_BAD_COMPILER
--
-   if test "$GXX" = "yes" || test "$CXX" = "KCC"; then
-     if test "$kde_use_debug_code" != "no"; then
-       if test "$CXX" = "KCC"; then
-@@ -4579,9 +4542,9 @@
-   LIBPYTHON=-lpython$version
- fi
--AC_FIND_FILE(python$version/copy.py, $python_libdirs, python_moddir)
-+AC_FIND_FILE(python$version/copy.pyc, "/usr/share" , python_moddir)
- python_moddir=$python_moddir/python$version
--if test ! -r $python_moddir/copy.py; then
-+if test ! -r $python_moddir/copy.pyc; then
-   python_moddir=no
- fi
-@@ -4728,32 +4691,11 @@
- [
-     AC_MSG_CHECKING([for utmp file])
--    AC_CACHE_VAL(kde_cv_utmp_file,
--    [
--    kde_cv_utmp_file=no
-+    AC_CACHE_VAL(kde_cv_utmp_file, [kde_cv_utmp_file=/var/run/utmpx])
--    for ac_file in    \
--                      \
--      /var/run/utmp \
--      /var/adm/utmp \
--      /etc/utmp     \
--     ; \
--    do
--     if test -r "$ac_file"; then
--       kde_cv_utmp_file=$ac_file
--       break
--     fi
--    done
--    ])
--
--    if test "$kde_cv_utmp_file" != "no"; then
--      AC_DEFINE_UNQUOTED(UTMP, "$kde_cv_utmp_file", [Define the file for utmp entries])
--      $1
--      AC_MSG_RESULT($kde_cv_utmp_file)
--    else
--      $2
--      AC_MSG_RESULT([non found])
--    fi
-+    AC_DEFINE_UNQUOTED(UTMP, "$kde_cv_utmp_file", [Define the file for utmp entries])
-+    $1
-+    AC_MSG_RESULT(We are using $kde_cv_utmp_file in PLD instead.)
- ])
-@@ -5536,7 +5478,7 @@
-   kde_qtdir="$with_qt_dir"
- fi
--AC_FIND_FILE(qsql.html, [ $kde_qtdir/doc/html $QTDIR/doc/html /usr/share/doc/packages/qt3/html /usr/lib/qt/doc /usr/lib/qt3/doc /usr/lib/qt3/doc/html /usr/doc/qt3/html /usr/doc/qt3 /usr/share/doc/qt3-doc /usr/share/qt3/doc/html /usr/X11R6/share/doc/qt/html ], QTDOCDIR)
-+AC_FIND_FILE(qsql.html, [ /usr/share/doc/qt-doc/html ], QTDOCDIR)
- AC_MSG_RESULT($QTDOCDIR)
- AC_SUBST(QTDOCDIR)
---- gwenview-1.4.0/admin/am_edit       2006-09-25 00:04:55.213036950 +0300
-+++ kdelibs-3.5.5/admin/am_edit        2006-10-03 11:40:08.052152886 +0300
-@@ -499,6 +499,15 @@
-         }
-     }
-+    $lookup = '(CXXLINK = \$\(LIBTOOL\).*--mode=link.*) \$\(CXXLD\)';
-+    if ($MakefileData =~ m/$lookup/) {
-+        substituteLine($lookup, "$1 \"\$\(CXXLD\)\"");
-+    }
-+    $lookup = '(LINK = \$\(LIBTOOL\).*--mode=link.*) \$\(CCLD\)';
-+    if ($MakefileData =~ m/$lookup/) {
-+        substituteLine($lookup, "$1 \"\$\(CCLD\)\"");
-+    }
-+
-     $MakefileData =~ s/\$\(KCXXFLAGS\)/\$\(CXXFLAGS\)/g;
-     $lookup = '(.*)cp -pr \$\$/\$\$file \$\(distdir\)/\$\$file(.*)';
-@@ -578,6 +587,14 @@
-         local @kde_options = split(/[\034\s]+/, $kde_options_str);
-         if (grep(/^foreign$/, @kde_options)) {
-             push(@foreignfiles, $makefileDir . "/");
-+
-+            # always do this. don't care if it's foreign file. we *need* CXXLD quoted for libtool argument.
-+            $lookup = '(CXXLINK = \$\(LIBTOOL\).*--mode=link) \$\(CXXLD\)';
-+            if ($MakefileData =~ m/$lookup/) {
-+                substituteLine($lookup, "$1 \"\$\(CXXLD\)\"");
-+                updateMakefile ();
-+            }
-+
-             return 0; # don't touch me
-         }
-         for $opt (@kde_options) {
-
---- x/admin/acinclude.m4.in.orig       2008-10-08 10:18:48.844247699 +0200
-+++ x/admin/acinclude.m4.in    2008-10-08 10:21:26.884232831 +0200
-@@ -4612,7 +4612,8 @@
- AC_DEFUN([KDE_CHECK_PYTHON],
- [
--  KDE_CHECK_PYTHON_INTERN("2.5",
-+ KDE_CHECK_PYTHON_INTERN("2.6",
-+  [KDE_CHECK_PYTHON_INTERN("2.5",
-     [KDE_CHECK_PYTHON_INTERN("2.4",
-      [KDE_CHECK_PYTHON_INTERN("2.3", 
-        [KDE_CHECK_PYTHON_INTERN("2.2", 
-@@ -4624,6 +4625,7 @@
-        ])
-      ])
-   ])
-+ ])
- ])
- AC_DEFUN([KDE_CHECK_STL],
diff --git a/kde-common-gcc4.patch b/kde-common-gcc4.patch
deleted file mode 100644 (file)
index 9ccb0ea..0000000
+++ /dev/null
@@ -1,127 +0,0 @@
---- amaroc/admin/acinclude.m4.in.orig  2006-04-03 18:02:49.000000000 +0200
-+++ amaroc/admin/acinclude.m4.in       2006-04-03 18:20:39.000000000 +0200
-@@ -428,7 +428,7 @@
- if test "$1" = "default"; then
-   if test -z "$kde_htmldir"; then
--    kde_htmldir='\${datadir}/doc/HTML'
-+    kde_htmldir='/usr/share/doc/kde/HTML'
-   fi
-   if test -z "$kde_appsdir"; then
-     kde_appsdir='\${datadir}/applnk'
-@@ -2974,48 +2974,6 @@
-   fi
- ])
--
--AC_DEFUN([KDE_CHECK_FOR_BAD_COMPILER],
--[
--  AC_MSG_CHECKING([whether $CC is blacklisted])
--
--  dnl In theory we have tu run this test against $CC and $CXX
--  dnl in C and in C++ mode, because its perfectly legal for
--  dnl the user to mix compiler versions, since C has a defined
--  dnl ABI. 
--  dnl 
--  dnl For now, we assume the user is not on crack.
--
--  AC_TRY_COMPILE([
--#ifdef __GNUC__
--#if __GNUC__ == 4 && __GNUC_MINOR__ == 0 && __GNUC_PATCHLEVEL__ == 0
--choke me
--#endif
--#endif
--], ,
--  kde_bad_compiler=no, 
--  kde_bad_compiler=yes
--)
--
--  AC_MSG_RESULT($kde_bad_compiler)
--
--if test "$kde_bad_compiler" = "yes"; then
--  AC_MSG_ERROR([
--
--This particular compiler version is blacklisted because it
--is known to miscompile KDE. Please use a newer version, or
--if that is not yet available, choose an older version. 
--
--Please do not report a bug or bother us reporting this
--configure error. We know about it, and we introduced
--it by intention to avoid untraceable bugs or crashes in KDE.
--
--])
--fi
--
--])
--
--
- AC_DEFUN([KDE_CHECK_FOR_OPT_NOINLINE_MATCH],
- [
-   AC_CACHE_CHECK([whether system headers can cope with -O2 -fno-inline],
-@@ -3153,8 +3111,6 @@
-   AC_PROG_CXX
--  KDE_CHECK_FOR_BAD_COMPILER
--
-   if test "$GXX" = "yes" || test "$CXX" = "KCC"; then
-     if test "$kde_use_debug_code" != "no"; then
-       if test "$CXX" = "KCC"; then
-@@ -4576,9 +4532,9 @@
-   LIBPYTHON=-lpython$version
- fi
--AC_FIND_FILE(python$version/copy.py, $python_libdirs, python_moddir)
-+AC_FIND_FILE(python$version/copy.pyc, "/usr/share" , python_moddir)
- python_moddir=$python_moddir/python$version
--if test ! -r $python_moddir/copy.py; then
-+if test ! -r $python_moddir/copy.pyc; then
-   python_moddir=no
- fi
-@@ -4725,32 +4681,11 @@
- [
-     AC_MSG_CHECKING([for utmp file])
--    AC_CACHE_VAL(kde_cv_utmp_file,
--    [
--    kde_cv_utmp_file=no
--
--    for ac_file in    \
--                      \
--      /var/run/utmp \
--      /var/adm/utmp \
--      /etc/utmp     \
--     ; \
--    do
--     if test -r "$ac_file"; then
--       kde_cv_utmp_file=$ac_file
--       break
--     fi
--    done
--    ])
-+    AC_CACHE_VAL(kde_cv_utmp_file, [kde_cv_utmp_file=/var/run/utmpx])
--    if test "$kde_cv_utmp_file" != "no"; then
--      AC_DEFINE_UNQUOTED(UTMP, "$kde_cv_utmp_file", [Define the file for utmp entries])
--      $1
--      AC_MSG_RESULT($kde_cv_utmp_file)
--    else
--      $2
--      AC_MSG_RESULT([non found])
--    fi
-+    AC_DEFINE_UNQUOTED(UTMP, "$kde_cv_utmp_file", [Define the file for utmp entries])
-+    $1
-+    AC_MSG_RESULT(We are using $kde_cv_utmp_file in PLD instead.)
- ])
-@@ -5533,7 +5468,7 @@
-   kde_qtdir="$with_qt_dir"
- fi
--AC_FIND_FILE(qsql.html, [ $kde_qtdir/doc/html $QTDIR/doc/html /usr/share/doc/packages/qt3/html /usr/lib/qt/doc /usr/lib/qt3/doc /usr/lib/qt3/doc/html /usr/doc/qt3/html /usr/doc/qt3 /usr/share/doc/qt3-doc /usr/share/qt3/doc/html /usr/X11R6/share/doc/qt/html ], QTDOCDIR)
-+AC_FIND_FILE(qsql.html, [ /usr/share/doc/qt-doc/html ], QTDOCDIR)
- AC_MSG_RESULT($QTDOCDIR)
- AC_SUBST(QTDOCDIR)
diff --git a/kde4-kdeextragear-multimedia-NJB.patch b/kde4-kdeextragear-multimedia-NJB.patch
deleted file mode 100644 (file)
index 4ee09a0..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- amarok/cmake/modules/FindNjb.cmake.orig    2008-06-08 11:21:07.000000000 +0200
-+++ amarok/cmake/modules/FindNjb.cmake 2008-06-08 11:27:09.000000000 +0200
-@@ -23,7 +23,7 @@
-     set(NJB_DEFINITIONS ${_NJBCflags})
-   endif(NOT WIN32)
--  FIND_PATH(NJB_INCLUDE_DIR libnjb.h
-+  FIND_PATH(NJB_INCLUDE_DIR libnjb/libnjb.h
-     ${_NJBIncDir}
-   )
-   
---- amarok/src/mediadevice/njb/playlist.h.orig 2008-06-08 11:28:16.000000000 +0200
-+++ amarok/src/mediadevice/njb/playlist.h      2008-06-08 11:29:17.000000000 +0200
-@@ -20,7 +20,7 @@
- #define __playlist_h__
- // libnjb
--#include <libnjb.h>
-+#include <libnjb/libnjb.h>
- // Qt
- #include <QStringList>
---- amarok/src/mediadevice/njb/track.h.orig    2008-06-08 11:28:30.000000000 +0200
-+++ amarok/src/mediadevice/njb/track.h 2008-06-08 11:29:43.000000000 +0200
-@@ -27,7 +27,7 @@
- #include <Q3PtrList>
- // libnjb
--#include <libnjb.h>
-+#include <libnjb/libnjb.h>
- #include "metabundle.h"
This page took 0.0777099999999999 seconds and 4 git commands to generate.