]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- rpm-build-macros >= 1.600 required for fixed cmake macro
[packages/amarok.git] / amarok.spec
index 2ae2ad735b4bc377f648c38628c13fe72e120393..f2629a10aee459790f0cf4948ca3ec1acde211c8 100644 (file)
@@ -2,50 +2,35 @@
 # - try not to link with static mysql
 
 %define                state   stable
-%define                qtver   4.5.3
-%define                kdever  4.3.3
+%define                qtver   4.7.0
+%define                kdever  4.5.0
 
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       2.2.2
+Version:       2.4.0
 Release:       1
 License:       GPL
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: c2c4ae2f2ff7154a064b554cdee557a9
-Patch0:                %{name}-link.patch
-Patch1:                %{name}-qthreadpool.patch
+# Source0-md5: bdb6ddc8e38d0982a0786ff8ac96d923
+Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
 URL:           http://amarok.kde.org/
-BuildRequires: Qt3Support-devel >= %{qtver}
-BuildRequires: QtCore-devel >= %{qtver}
-BuildRequires: QtDBus-devel >= %{qtver}
-BuildRequires: QtDesigner-devel >= %{qtver}
 BuildRequires: QtNetwork-devel >= %{qtver}
-BuildRequires: QtOpenGL-devel >= %{qtver}
-BuildRequires: QtScript-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
-BuildRequires: QtSvg-devel >= %{qtver}
-BuildRequires: QtTest-devel >= %{qtver}
-BuildRequires: QtUiTools-devel >= %{qtver}
-BuildRequires: QtWebKit-devel >= %{qtver}
-BuildRequires: QtXml-devel >= %{qtver}
-BuildRequires: automoc4
-BuildRequires: cmake >= 2.6.1-2
+BuildRequires: automoc4 >= 0.9.88
+BuildRequires: cmake >= 2.8.0
 BuildRequires: curl-devel
 BuildRequires: gettext-devel
-BuildRequires: giflib-devel
 BuildRequires: glib2-devel
-BuildRequires: kde4-kdebase-devel >= %{kdever}
+BuildRequires: kde4-kdelibs-devel >= %{kdever}
 BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
 BuildRequires: libgpod-devel >= 0.7.0
-BuildRequires: libifp-devel >= 1.0.0.2
 BuildRequires: liblastfm-devel
 BuildRequires: libmtp-devel >= 0.3.0
-BuildRequires: libnjb-devel >= 2.2.4
-BuildRequires: libvisual-devel >= 0.4.0
+BuildRequires: libofa-devel
+BuildRequires: libwrap-devel
 BuildRequires: loudmouth-devel
-BuildRequires: mpeg4ip-devel >= 1:1.6
 BuildRequires: mysql-devel >= 5.1.31-3
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
@@ -53,16 +38,13 @@ BuildRequires:      qca-devel
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: qtscriptbindings
-BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.129
-BuildRequires: soprano-devel >= 2.1
-BuildRequires: strigi-devel >= 0.5.10
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: soprano-devel
+BuildRequires: strigi-devel >= 0.7.0
 BuildRequires: taglib-devel >= 1.6
 BuildRequires: taglib-extras-devel >= 1.0.0
-BuildRequires: utempter-devel
 BuildRequires: xorg-lib-libXpm-devel
 Requires(post,postun): /sbin/ldconfig
-Requires:      kde4-kdebase-core
 Requires:      kde4-kdemultimedia-audiocd
 Requires:      kde4-phonon
 Requires:      qtscriptbindings
@@ -125,20 +107,12 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 
 %prep
 %setup -q
-#%patch0 -p0
-#%patch1 -p0
+%patch0 -p1
 
 %build
 install -d build
 cd build
-%cmake \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DLIB_INSTALL_DIR=%{_libdir} \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64 \
-%endif
-       ../
+%cmake ..
 
 %{__make}
 
@@ -153,7 +127,13 @@ rm -rf $RPM_BUILD_ROOT
 # remove bogus dir
 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
 
-%find_lang %{name} --with-kde
+# remove unsupported locale
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
+
+# remove .so symlinks so that noone gets the stupid idea to package them
+rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
+
+%find_lang %{name} --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -169,30 +149,21 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
 %attr(755,root,root) %{_bindir}/amarok_afttagger
+%attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
+%attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
+%attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
-%attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
-%attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
+%attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
+%attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
+%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
+%attr(755,root,root) %{_libdir}/libampache_account_login.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
@@ -201,20 +172,43 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
 %dir %{_datadir}/apps/amarok
-%attr(755,root,root) %{_libdir}/libamaroklib.so
-%attr(755,root,root) %{_libdir}/libamarokocsclient.so
-%attr(755,root,root) %{_libdir}/libamarokocsclient.so.4
-%attr(755,root,root) %{_libdir}/libamarokocsclient.so.4.4.0
-%attr(755,root,root) %{_libdir}/libamarokpud.so
 %dir %{_datadir}/apps/amarok/scripts
 %{_datadir}/apps/amarok/data
 %{_datadir}/apps/amarok/icons
@@ -229,19 +223,42 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
-%{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
+%{_datadir}/applications/kde4/amarok_containers.desktop
 %{_datadir}/kde4/services/amarok.protocol
 %{_datadir}/kde4/services/amaroklastfm.protocol
+%{_datadir}/kde4/services/amarokitpc.protocol
 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
+%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
+%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
+%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
+%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
+%{_datadir}/kde4/services/amarok-context-applet-info.desktop
+%{_datadir}/kde4/services/amarok-context-applet-labels.desktop
 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
+%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
+%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
+%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
-%{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
+%{_datadir}/kde4/services/amarok-data-engine-info.desktop
+%{_datadir}/kde4/services/amarok-data-engine-labels.desktop
 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
+%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
+%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
+%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
-%{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
+%{_datadir}/kde4/services/amarok_massstorage-device.desktop
 %{_datadir}/kde4/services/amarok_service_ampache.desktop
 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
@@ -251,26 +268,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
-%{_datadir}/kde4/services/amarok-context-applet-albums.desktop
-%{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
-%{_datadir}/kde4/services/amarok_massstorage-device.desktop
 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
-%{_datadir}/kde4/services/amarok-context-applet-info.desktop
-%{_datadir}/kde4/services/amarok-context-applet-photos.desktop
-%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
-%{_datadir}/kde4/services/amarok-data-engine-info.desktop
-%{_datadir}/kde4/services/amarok-data-engine-photos.desktop
-%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
-%{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
-%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
-%{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
-%{_datadir}/kde4/services/amarok_collection-umscollection.desktop
+%{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
+%{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
+%{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
+%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
-%{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
 %{_desktopdir}/kde4/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
 %{_datadir}/config/amarok_homerc
This page took 0.058195 seconds and 4 git commands to generate.