]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- x32 rebuild
[packages/amarok.git] / amarok.spec
index 8425525b3527801cf79013a5383fefbe7264c404..88592296d1fde9301a308b5e380acef4e92a39fe 100644 (file)
@@ -1,8 +1,12 @@
 #
 # TODO
 # - use mysql-embedded in the future and try not to link with static mysqld lib
-#
-
+# - amarok now requires his own database which is not automaticly created
+# Add spec:
+# libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
+#     Enable gpodder.net service
+# -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
+# /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
 %define                state   stable
 %define                qtver   4.7.1
 %define                kdever  4.5.5
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       2.4.0
-Release:       4
+Version:       2.8.0
+Release:       7
 License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: bdb6ddc8e38d0982a0786ff8ac96d923
-Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
+# Source0-md5: 53cfcb4819668b10e13b061478c7b32a
+Patch0:                %{name}-upnp-dep.patch
 URL:           http://amarok.kde.org/
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
 BuildRequires: automoc4 >= 0.9.88
 BuildRequires: cmake >= 2.8.0
 BuildRequires: curl-devel
-BuildRequires: gettext-devel
+BuildRequires: ffmpeg-devel >= 0.7.1
+BuildRequires: gettext-tools
 BuildRequires: glib2-devel
+BuildRequires: herqq-devel
 BuildRequires: kde4-kdelibs-devel >= %{kdever}
-BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
+BuildRequires: kde4-nepomuk-core-devel
+BuildRequires: libaio-devel
 BuildRequires: libgpod-devel >= 0.7.0
 BuildRequires: liblastfm-devel
-BuildRequires: libmtp-devel >= 0.3.0
+BuildRequires: libmtp-devel >= 1.0.4
 BuildRequires: libofa-devel
 BuildRequires: libwrap-devel
 BuildRequires: loudmouth-devel
@@ -37,17 +44,17 @@ BuildRequires:      mysql-devel >= 5.1.31-3
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: qca-devel
+BuildRequires: qjson-devel >= 0.5
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: qtscriptbindings
 BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: soprano-devel
 BuildRequires: strigi-devel >= 0.7.0
-BuildRequires: taglib-devel >= 1.6
+BuildRequires: taglib-devel >= 1.7
 BuildRequires: taglib-extras-devel >= 1.0.0
 BuildRequires: xorg-lib-libXpm-devel
 Requires(post,postun): /sbin/ldconfig
-Requires:      kde4-kdemultimedia-audiocd
 Requires:      kde4-phonon
 Requires:      qtscriptbindings
 Suggests:      libvisual-plugin-actor-JESS
@@ -114,6 +121,7 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 install -d build
 cd build
 %cmake \
+       -DKDE4_BUILD_TESTS=OFF \
        -DWITH_MYSQL_EMBEDDED=OFF \
        ../
 
@@ -128,7 +136,7 @@ rm -rf $RPM_BUILD_ROOT
        kde_libs_htmldir=%{_kdedocdir}
 
 # remove unsupported locale
-%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian*
 
 # remove .so symlinks so that noone gets the stupid idea to package them
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
@@ -149,6 +157,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
 %attr(755,root,root) %{_bindir}/amarok_afttagger
+%attr(755,root,root) %{_bindir}/amzdownloader
 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
@@ -159,51 +168,46 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libamarokshared.so.?
+%attr(755,root,root) %{_libdir}/libamarokshared.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
-%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
+#%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
+#%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
 %attr(755,root,root) %{_libdir}/libampache_account_login.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
+#%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_analyzer.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_service_lastfm.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
-%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-nepomukcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
@@ -226,51 +230,44 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
-%{_datadir}/applications/kde4/amarok_containers.desktop
+%{_desktopdir}/kde4/amarok_containers.desktop
+%{_desktopdir}/kde4/amzdownloader.desktop
 %{_datadir}/kde4/services/amarok.protocol
-%{_datadir}/kde4/services/amaroklastfm.protocol
 %{_datadir}/kde4/services/amarokitpc.protocol
 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
-%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
+#%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
+%{_datadir}/kde4/services/amarok_collection-nepomukcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
+%{_datadir}/kde4/services/amarok-context-applet-analyzer.desktop
 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
-%{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
-%{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
-%{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
-%{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
-%{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
-%{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
-%{_datadir}/kde4/services/amarok_massstorage-device.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
 %{_datadir}/kde4/services/amarok_service_ampache.desktop
 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
-%{_datadir}/kde4/services/amarok_service_lastfm.desktop
-%{_datadir}/kde4/services/amarok_service_lastfm_config.desktop
 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
-%{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
-%{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
@@ -282,6 +279,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/kde4/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
 %{_datadir}/config/amarok_homerc
+%attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
+%{_datadir}/apps/kconf_update/amarok.upd
+%{_datadir}/mime/packages/amzdownloader.xml
 
 %files scripts
 %defattr(644,root,root,755)
@@ -303,3 +303,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
+%dir %{_datadir}/apps/amarok/scripts/free_music_charts_service
+%{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCEmblem.png
+%{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCIcon.png
+%{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCShow.png
+%{_datadir}/apps/amarok/scripts/free_music_charts_service/main.js
+%{_datadir}/apps/amarok/scripts/free_music_charts_service/script.spec
This page took 0.086155 seconds and 4 git commands to generate.