]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- attpempt to fix build with ffmpeg 0.7 and 0.8
[packages/amarok.git] / amarok.spec
index 8842068a1c1dbce41e5553c5ddef07664d23682f..3876ca8411870c1cd8a5d92b17c1a9aab9371c8a 100644 (file)
@@ -1,20 +1,24 @@
+#
 # TODO
-# - try not to link with static mysql
+# - use mysql-embedded in the future and try not to link with static mysqld lib
+# - does not run
+#
 
 %define                state   stable
-%define                qtver   4.7.0
-%define                kdever  4.5.0
+%define                qtver   4.7.1
+%define                kdever  4.5.5
 
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       2.4.0
-Release:       1
-License:       GPL
+Version:       2.4.1
+Release:       0.1
+License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: bdb6ddc8e38d0982a0786ff8ac96d923
+# Source0-md5: 4c65c5cd4d7bd267bdbef8e912fd6cb6
 Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
+Patch1:                %{name}-ffmpeg08.patch
 URL:           http://amarok.kde.org/
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
@@ -25,6 +29,7 @@ BuildRequires:        gettext-devel
 BuildRequires: glib2-devel
 BuildRequires: kde4-kdelibs-devel >= %{kdever}
 BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
+BuildRequires: libaio-devel
 BuildRequires: libgpod-devel >= 0.7.0
 BuildRequires: liblastfm-devel
 BuildRequires: libmtp-devel >= 0.3.0
@@ -38,7 +43,7 @@ BuildRequires:        qca-devel
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: qtscriptbindings
-BuildRequires: rpmbuild(macros) >= 1.577
+BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: soprano-devel
 BuildRequires: strigi-devel >= 0.7.0
 BuildRequires: taglib-devel >= 1.6
@@ -64,7 +69,6 @@ Suggests:     libvisual-plugin-actor-madspin
 Suggests:      libvisual-plugin-actor-nastyfft
 Suggests:      libvisual-plugin-actor-oinksie
 Suggests:      libvisual-plugin-input-alsa
-Suggests:      libvisual-plugin-input-esd
 Suggests:      libvisual-plugin-input-jack
 Suggests:      libvisual-plugin-input-mplayer
 Suggests:      libvisual-plugin-morph-alphablend
@@ -108,11 +112,14 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
 cd build
-%cmake ..
+%cmake \
+       -DWITH_MYSQL_EMBEDDED=OFF \
+       ../
 
 %{__make}
 
@@ -124,14 +131,11 @@ rm -rf $RPM_BUILD_ROOT
        kde_htmldir=%{_kdedocdir} \
        kde_libs_htmldir=%{_kdedocdir}
 
-# remove bogus dir
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
-
 # remove unsupported locale
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
 
 # remove .so symlinks so that noone gets the stupid idea to package them
-rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
 
 %find_lang %{name} --all-name --with-kde
 
@@ -161,15 +165,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
-%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
+#%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
+#%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
 %attr(755,root,root) %{_libdir}/libampache_account_login.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
+#%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
@@ -192,7 +196,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
@@ -226,7 +232,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
-%{_datadir}/applications/kde4/amarok_containers.desktop
+%{_desktopdir}/kde4/amarok_containers.desktop
 %{_datadir}/kde4/services/amarok.protocol
 %{_datadir}/kde4/services/amaroklastfm.protocol
 %{_datadir}/kde4/services/amarokitpc.protocol
@@ -235,7 +241,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
-%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
+#%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
@@ -258,7 +264,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
-%{_datadir}/kde4/services/amarok_massstorage-device.desktop
+%{_datadir}/kde4/services/amarok_device_massstorage.desktop
+%{_datadir}/kde4/services/amarok_device_nfs.desktop
+%{_datadir}/kde4/services/amarok_device_smb.desktop
 %{_datadir}/kde4/services/amarok_service_ampache.desktop
 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
This page took 0.03991 seconds and 4 git commands to generate.