]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- updated to 2.6.0
[packages/amarok.git] / amarok.spec
index 3e9c61422f6501635dc44845689699d8a64c8cd8..2840a34968ab54141444008aaf41aa0fc0ab3e42 100644 (file)
@@ -1,44 +1,56 @@
+#
 # TODO
-# - try not to link with static mysql
-
+# - use mysql-embedded in the future and try not to link with static mysqld lib
+# - amarok now requires his own database which is not automaticly created 
+# Add spec:
+# libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
+#     Enable gpodder.net service
+# -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
+# /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
 %define                state   stable
-%define                qtver   4.6.2
-%define                kdever  4.4.4
+%define                qtver   4.7.1
+%define                kdever  4.5.5
 
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       2.3.1
-Release:       2
-License:       GPL
+Version:       2.6.0
+Release:       1
+License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: 6679adaf5cc757b1515a9f03cdcb6066
-Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
+# Source0-md5: 116f53c1109c7acd1ac7d78ec75c01c4
+Patch0:                %{name}-upnp-dep.patch
 URL:           http://amarok.kde.org/
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
 BuildRequires: automoc4 >= 0.9.88
 BuildRequires: cmake >= 2.8.0
 BuildRequires: curl-devel
+BuildRequires: ffmpeg-devel >= 0.7.1
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel
+BuildRequires: herqq-devel
 BuildRequires: kde4-kdelibs-devel >= %{kdever}
-BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
+BuildRequires: libaio-devel
 BuildRequires: libgpod-devel >= 0.7.0
 BuildRequires: liblastfm-devel
-BuildRequires: libmtp-devel >= 0.3.0
+BuildRequires: libmtp-devel >= 1.0.4
+BuildRequires: libofa-devel
+BuildRequires: libwrap-devel
 BuildRequires: loudmouth-devel
 BuildRequires: mysql-devel >= 5.1.31-3
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: qca-devel
+BuildRequires: qjson-devel >= 0.5
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: qtscriptbindings
-BuildRequires: rpmbuild(macros) >= 1.129
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: soprano-devel
 BuildRequires: strigi-devel >= 0.7.0
-BuildRequires: taglib-devel >= 1.6
+BuildRequires: taglib-devel >= 1.7
 BuildRequires: taglib-extras-devel >= 1.0.0
 BuildRequires: xorg-lib-libXpm-devel
 Requires(post,postun): /sbin/ldconfig
@@ -61,7 +73,6 @@ Suggests:     libvisual-plugin-actor-madspin
 Suggests:      libvisual-plugin-actor-nastyfft
 Suggests:      libvisual-plugin-actor-oinksie
 Suggests:      libvisual-plugin-input-alsa
-Suggests:      libvisual-plugin-input-esd
 Suggests:      libvisual-plugin-input-jack
 Suggests:      libvisual-plugin-input-mplayer
 Suggests:      libvisual-plugin-morph-alphablend
@@ -110,12 +121,7 @@ Więcej o skryptach w amaroKu można dowiedzieć się stąd:
 install -d build
 cd build
 %cmake \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DLIB_INSTALL_DIR=%{_libdir} \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-%if "%{_lib}" == "lib64"
-       -DLIB_SUFFIX=64 \
-%endif
+       -DWITH_MYSQL_EMBEDDED=OFF \
        ../
 
 %{__make}
@@ -128,14 +134,11 @@ rm -rf $RPM_BUILD_ROOT
        kde_htmldir=%{_kdedocdir} \
        kde_libs_htmldir=%{_kdedocdir}
 
-# remove bogus dir
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
-
 # remove unsupported locale
-rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/sr@ijekavian*
 
 # remove .so symlinks so that noone gets the stupid idea to package them
-rm -f $RPM_BUILD_ROOT/%{_libdir}/lib*.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
 
 %find_lang %{name} --all-name --with-kde
 
@@ -163,35 +166,44 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
-%attr(755,root,root) %{_libdir}/strigi/strigita_audible.so
-%attr(755,root,root) %{_libdir}/strigi/strigita_mp4.so
+%attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
+%attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
+#%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
+#%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
+%attr(755,root,root) %{_libdir}/libampache_account_login.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_appletscript_simple_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
+#%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_spectrum_analyzer.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_spectrum_analyzer.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
-%attr(755,root,root) %{_libdir}/kde4/amarok_massstorage-device.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_massstorage.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_nfs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_device_smb.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_runnerscript_javascript.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
@@ -199,10 +211,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
 %dir %{_datadir}/apps/amarok
 %dir %{_datadir}/apps/amarok/scripts
 %{_datadir}/apps/amarok/data
@@ -218,7 +236,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
-%{_datadir}/dbus-1/interfaces/org.kde.amarok.SqlCollection.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
+%{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
+%{_desktopdir}/kde4/amarok_containers.desktop
 %{_datadir}/kde4/services/amarok.protocol
 %{_datadir}/kde4/services/amaroklastfm.protocol
 %{_datadir}/kde4/services/amarokitpc.protocol
@@ -227,28 +248,36 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
-%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
+#%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
+%{_datadir}/kde4/services/amarok-context-applet-labels.desktop
 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-context-applet-spectrum-analyzer.desktop
 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
+%{_datadir}/kde4/services/amarok-data-engine-labels.desktop
 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-data-engine-spectrum-analyzer.desktop
 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
-%{_datadir}/kde4/services/amarok_massstorage-device.desktop
+%{_datadir}/kde4/services/amarok_device_massstorage.desktop
+%{_datadir}/kde4/services/amarok_device_nfs.desktop
+%{_datadir}/kde4/services/amarok_device_smb.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
 %{_datadir}/kde4/services/amarok_service_ampache.desktop
 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
@@ -261,6 +290,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
 %{_datadir}/kde4/services/amarok-scriptengine-applet-simple-javascript.desktop
 %{_datadir}/kde4/services/amarok-scriptengine-runner-javascript.desktop
+%{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
+%{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
+%{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
+%{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
@@ -268,6 +301,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/kde4/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
 %{_datadir}/config/amarok_homerc
+%attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
+%{_datadir}/apps/kconf_update/amarok.upd
 
 %files scripts
 %defattr(644,root,root,755)
This page took 0.068959 seconds and 4 git commands to generate.