]> git.pld-linux.org Git - packages/amarok.git/blobdiff - amarok.spec
- updated to 2.6.0
[packages/amarok.git] / amarok.spec
index 260fb2b0e2dc9f930af2c42406c5996c97cba037..2840a34968ab54141444008aaf41aa0fc0ab3e42 100644 (file)
@@ -1,9 +1,12 @@
 #
 # TODO
 # - use mysql-embedded in the future and try not to link with static mysqld lib
-# - does not run
-#
-
+# - amarok now requires his own database which is not automaticly created 
+# Add spec:
+# libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
+#     Enable gpodder.net service
+# -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
+# /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
 %define                state   stable
 %define                qtver   4.7.1
 %define                kdever  4.5.5
 Summary:       A KDE audio player
 Summary(pl.UTF-8):     Odtwarzacz audio dla KDE
 Name:          amarok
-Version:       2.4.1
-Release:       0.1
+Version:       2.6.0
+Release:       1
 License:       GPL v2+ and LGPL v2.1+
 Group:         X11/Applications/Multimedia
 Source0:       ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
-# Source0-md5: 4c65c5cd4d7bd267bdbef8e912fd6cb6
-Patch0:                %{name}-disable_qtscriptbindings_check_fix.patch
+# Source0-md5: 116f53c1109c7acd1ac7d78ec75c01c4
+Patch0:                %{name}-upnp-dep.patch
 URL:           http://amarok.kde.org/
 BuildRequires: QtNetwork-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
 BuildRequires: automoc4 >= 0.9.88
 BuildRequires: cmake >= 2.8.0
 BuildRequires: curl-devel
+BuildRequires: ffmpeg-devel >= 0.7.1
 BuildRequires: gettext-devel
 BuildRequires: glib2-devel
+BuildRequires: herqq-devel
 BuildRequires: kde4-kdelibs-devel >= %{kdever}
-BuildRequires: kde4-kdemultimedia-devel >= %{kdever}
 BuildRequires: libaio-devel
 BuildRequires: libgpod-devel >= 0.7.0
 BuildRequires: liblastfm-devel
-BuildRequires: libmtp-devel >= 0.3.0
+BuildRequires: libmtp-devel >= 1.0.4
 BuildRequires: libofa-devel
 BuildRequires: libwrap-devel
 BuildRequires: loudmouth-devel
@@ -39,13 +43,14 @@ BuildRequires:      mysql-devel >= 5.1.31-3
 BuildRequires: pcre-devel
 BuildRequires: pkgconfig
 BuildRequires: qca-devel
+BuildRequires: qjson-devel >= 0.5
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
 BuildRequires: qtscriptbindings
 BuildRequires: rpmbuild(macros) >= 1.600
 BuildRequires: soprano-devel
 BuildRequires: strigi-devel >= 0.7.0
-BuildRequires: taglib-devel >= 1.6
+BuildRequires: taglib-devel >= 1.7
 BuildRequires: taglib-extras-devel >= 1.0.0
 BuildRequires: xorg-lib-libXpm-devel
 Requires(post,postun): /sbin/ldconfig
@@ -182,6 +187,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_spectrum_analyzer.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
@@ -191,6 +197,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_similarArtists.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_spectrum_analyzer.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_upcomingEvents.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_videoclip.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
@@ -204,10 +211,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
+%attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_lastfm.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
@@ -250,6 +259,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
 %{_datadir}/kde4/services/amarok-context-applet-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-context-applet-spectrum-analyzer.desktop
 %{_datadir}/kde4/services/amarok-context-applet-upcomingEvents.desktop
 %{_datadir}/kde4/services/amarok-context-applet-videoclip.desktop
 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
@@ -259,12 +269,15 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
 %{_datadir}/kde4/services/amarok-data-engine-similarArtists.desktop
+%{_datadir}/kde4/services/amarok-data-engine-spectrum-analyzer.desktop
 %{_datadir}/kde4/services/amarok-data-engine-upcomingEvents.desktop
 %{_datadir}/kde4/services/amarok-data-engine-videoclip.desktop
 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
 %{_datadir}/kde4/services/amarok_device_massstorage.desktop
 %{_datadir}/kde4/services/amarok_device_nfs.desktop
 %{_datadir}/kde4/services/amarok_device_smb.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore.desktop
+%{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
 %{_datadir}/kde4/services/amarok_service_ampache.desktop
 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
@@ -288,6 +301,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/kde4/amarok.desktop
 %{_iconsdir}/*/*/apps/amarok.*
 %{_datadir}/config/amarok_homerc
+%attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
+%{_datadir}/apps/kconf_update/amarok.upd
 
 %files scripts
 %defattr(644,root,root,755)
This page took 0.035508 seconds and 4 git commands to generate.