]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- updated to 050525
[packages/amarok.git] / amarok.spec
CommitLineData
8d75a549 1#
4fc43dcb 2# TODO:
3# * postgresql support alongside mysql
4# * NMM, MAS audio backend support
5# * make descriptions less useless
6#
948e9545 7# Conditional builds:
48801ec3 8%bcond_without arts # disable arts engine
8d75a549 9%bcond_without gstreamer # disable gstreamer
7dae3fc2 10%bcond_without xine # disable xine engine
48801ec3 11%bcond_without xmms # disable xmms wrapping
bdca4c01 12%bcond_without zeroconf # disbale suport for zeroconf
604d331d 13%bcond_with mysql # enable mysql support
d4535bda 14#
bdca4c01 15%define _snap 050525
3dce540f 16Summary: A KDE audio player
17Summary(pl): Odtwarzacz audio dla KDE
18Name: amarok
4fc43dcb 19Version: 1.2.99
20Release: 0.%{_snap}.1
3dce540f 21License: GPL
22Group: X11/Applications/Multimedia
4fc43dcb 23Source0: %{name}-%{_snap}.tar.bz2
bdca4c01 24# Source0-md5: e2caf007c56b921556e65b5f9b6f3a92
4fc43dcb 25Patch0: kde-common-gcc4.patch
567ab89c 26URL: http://amarok.kde.org/
4fc43dcb 27BuildRequires: SDL-devel
28BuildRequires: alsa-lib-devel
29BuildRequires: arts-qt-devel
30BuildRequires: automake
512f2835 31%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
bb9faa6b 32BuildRequires: kdebase-devel
4fc43dcb 33BuildRequires: kdemultimedia-akode
ac33bc29 34BuildRequires: kdemultimedia-devel >= 9:3.1.93
4fc43dcb 35BuildRequires: libmusicbrainz-devel
36BuildRequires: libvisual-devel >= 0.2.0
37BuildRequires: pcre-devel
3022f84e 38BuildRequires: rpmbuild(macros) >= 1.129
43342c86 39BuildRequires: sed >= 4.0
48801ec3 40BuildRequires: sqlite3-devel
512f2835 41BuildRequires: taglib-devel >= 1.3.1
f96a59dd 42#BuildRequires: unsermake >= 040511
512f2835
SP
43%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
44%{?with_xmms:BuildRequires: xmms-devel}
45%{?with_mysql:BuildRequires: mysql-devel}
af820bda 46#BuildRequires: kdebindings-kjsembed-devel
48801ec3 47Requires: %{name}-plugin = %{version}-%{release}
3dce540f 48Requires: kdebase-core >= 9:3.1.93
50fa799e 49Requires: kdemultimedia-audiocd >= 9:3.1.93
3dce540f 50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53A KDE audio player.
54
55%description -l pl
56Odtwarzacz audio dla KDE.
57
48801ec3 58%package arts
59Summary: Plugin arts
60Summary(pl): Wtyczka arts
61Group: X11/Applications/Multimedia
62Requires: %{name} = %{version}-%{release}
63Provides: %{name}-plugin = %{version}-%{release}
64
65%description arts
66Plugin arts.
67
68%description arts -l pl
69Wtyczka arts.
70
bdca4c01 71
4fc43dcb 72%package akode
73Summary: Plugin akode
74Summary(pl): Wtyczka akode
75Group: X11/Applications/Multimedia
76Requires: %{name} = %{version}-%{release}
77Provides: %{name}-plugin = %{version}-%{release}
78
79%description akode
80Plugin akode.
81
82%description akode -l pl
83Wtyczka akode.
84
85
8d75a549 86%package gstreamer
d4535bda 87Summary: Plugin gstreamer
8d75a549 88Summary(pl): Wtyczka gstreamer
89Group: X11/Applications/Multimedia
4fc43dcb 90# needed libs
91# at least /usr/lib/gstreamer-0.8/libgstresample.so
92# probably /usr/lib/gstreamer-0.8/libgstadder.so
93# and probably /usr/lib/gstreamer-0.8/libgstvolume.so
94Requires: gstreamer-audio-effects
4d1b1b41 95Requires: %{name} = %{version}-%{release}
48801ec3 96Provides: %{name}-plugin = %{version}-%{release}
8d75a549 97
98%description gstreamer
d4535bda 99Plugin gstreamer.
8d75a549 100
101%description gstreamer -l pl
102Wtyczka gstreamer.
103
7dae3fc2 104%package xine
105Summary: Plugin xine
106Summary(pl): Wtyczka xine
107Group: X11/Applications/Multimedia
1aff4314 108Requires: %{name} = %{version}-%{release}
48801ec3 109Provides: %{name}-plugin = %{version}-%{release}
7dae3fc2 110
111%description xine
112Plugin xine.
113
114%description xine -l pl
115Wtyczka xine.
116
bdca4c01 117%package zeroconf
118Summary: Zeroconf data
119Summary(pl): Dane dla zeroconf
120Group: X11/Applications/Multimedia
121Requires: %{name} = %{version}-%{release}
122Requires: kdenetwork-kdnssd
123Provides: %{name}-plugin = %{version}-%{release}
124
125%description zeroconf
126Zeroconf data.
127
128%description zeroconf -l pl
129Zeroconf data.
130
131
3dce540f 132%prep
4fc43dcb 133%setup -q -n %{name}
134%patch0 -p1
69409e85 135%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
136 amarok/src/amarok.desktop \
137
3dce540f 138%build
4fc43dcb 139cp -f /usr/share/automake/config.sub admin
d3a55e61 140
4fc43dcb 141#export UNSERMAKE=/usr/share/unsermake/unsermake
d3a55e61 142
143%{__make} -f admin/Makefile.common cvs
144
3dce540f 145%configure \
146 --disable-rpath \
48801ec3 147 %{!?with_arts:--without-arts} \
7dae3fc2 148 %{!?with_xine:--without-xine} \
149 %{!?with_gstreamer:--without-gstreamer} \
f49f397f 150 %{?with_mysql:--with-mysql} \
bb9faa6b 151 --disable-final \
f15a6325 152 --with-qt-libraries=%{_libdir} \
153 --without-included-sqlite
3dce540f 154
155%{__make}
156
157%install
158rm -rf $RPM_BUILD_ROOT
159
160%{__make} install \
161 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 162 kde_htmldir=%{_kdedocdir} \
163 kde_libs_htmldir=%{_kdedocdir}
43342c86 164
3248aa1e 165# remove bogus dir
166rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
167
4fc43dcb 168#find_lang amarok --all-name --with-kde
3dce540f 169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
af820bda
SP
173%post
174echo "Remember to install libvisual-plugins-* packages if you"
175echo "want to have a visualizations in amarok."
176
bdca4c01 177%files
178# -f %{name}.lang
3dce540f 179%defattr(644,root,root,755)
4fc43dcb 180%doc amarok/AUTHORS amarok/ChangeLog amarok/README amarok/TODO
d4535bda 181%attr(755,root,root) %{_bindir}/amarok
3fd16f2f 182%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
d3a55e61 183%attr(755,root,root) %{_bindir}/amarokapp
add3317f 184%attr(755,root,root) %{_bindir}/amarok_libvisual
4fc43dcb 185#%attr(755,root,root) %{_bindir}/release_amarok
512f2835 186%{_libdir}/kde3/konqsidebar_universalamarok.la
512f2835 187%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
2aaa0c03 188%{_libdir}/kde3/libamarok_void-engine_plugin.la
189%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
3dce540f 190%{_datadir}/apps/amarok
7dae3fc2 191%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
2aaa0c03 192%{_datadir}/apps/konqsidebartng/add/amarok.desktop
4fc43dcb 193%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
194%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
2aaa0c03 195%{_datadir}/apps/profiles/amarok.profile.xml
196%{_datadir}/config/amarokrc
d3a55e61 197%{_datadir}/config.kcfg/amarok.kcfg
7dae3fc2 198%{_datadir}/services/amarok_void-engine_plugin.desktop
d3a55e61 199%{_datadir}/servicetypes/amarok_plugin.desktop
3dce540f 200%{_desktopdir}/kde/amarok.desktop
2aaa0c03 201%{_iconsdir}/*/*/apps/amarok.*
8d75a549 202
48801ec3 203%if %{with arts}
204%files arts
205%defattr(644,root,root,755)
206%{_libdir}/kde3/libamarok_artsengine_plugin.la
207%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
208%{_libdir}/libamarokarts.la
209%attr(755,root,root) %{_libdir}/libamarokarts.so
210%{_libdir}/mcop/Amarok
211%{_libdir}/mcop/amarokarts.mcopclass
212%{_libdir}/mcop/amarokarts.mcoptype
213%{_datadir}/services/amarok_artsengine_plugin.desktop
214%endif
215
4fc43dcb 216%files akode
217%defattr(644,root,root,755)
218%{_libdir}/kde3/libamarok_aKode-engine.la
219%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
220%{_datadir}/services/amarok_aKode-engine.desktop
221
8d75a549 222%if %{with gstreamer}
223%files gstreamer
224%defattr(644,root,root,755)
225%{_libdir}/kde3/libamarok_gstengine_plugin.la
226%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
7dae3fc2 227%{_datadir}/config.kcfg/gstconfig.kcfg
8d75a549 228%{_datadir}/services/amarok_gstengine_plugin.desktop
229%endif
7dae3fc2 230
231%if %{with xine}
232%files xine
233%defattr(644,root,root,755)
234%{_libdir}/kde3/libamarok_xine-engine.la
235%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
236%{_datadir}/services/amarok_xine-engine.desktop
4fc43dcb 237#%{_datadir}/services/amarok_xineengine_plugin.desktop
7dae3fc2 238%endif
bdca4c01 239
240%if %{with zeroconf}
241%files zeroconf
242%defattr(644,root,root,755)
243%{_datadir}/apps/zeroconf/_shoutcast._tcp
244%endif
This page took 0.178293 seconds and 4 git commands to generate.